Phase Noise (R&S FSW-K40)
Contents
  • Welcome to the Phase Noise Measurement Application
  • Measurements and Result Displays
  • Measurement Basics
  • Configuration
  • Analysis
  • How to Configure Phase Noise Measurements
  • Remote Control Commands for Phase Noise Measurements
  • List of Commands
Top


Welcome to the Phase Noise Measurement Application

Phase Noise (R&S FSW-K40) > Welcome to the Phase Noise Measurement Application
Welcome to the Phase Noise Measurement Application

The R&S FSW-K40 is a firmware application that adds functionality to measure the phase noise characteristics of a device under test with the R&S FSW signal analyzer.

This user manual contains a description of the functionality that the application provides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage

http://www2.rohde-schwarz.com/product/FSW.html.

Installation

Find detailed installing instructions in the Getting Started or the release notes of the R&S FSW.

Contents
  • Starting the Application
  • Understanding the Display Information


Starting the Application

Phase Noise (R&S FSW-K40) > Welcome to the Phase Noise Measurement Application > Starting the Application
Starting the Application

The phase noise measurement application adds a new type of measurement to the R&S FSW.

To activate the the Phase Noise application

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "Phase Noise" item.

    The R&S FSW opens a new measurement channel for the Phase Noise application.

    All settings specific to phase noise measurements are in their default state.

For details see "Operating Modes" .

Multiple Measurement Channels and Sequencer Function

When you enter an application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application.

The number of channels that can be configured at the same time depends on the available memory on the instrument.

Only one measurement can be performed at any time, namely the one in the currently active channel. However, in order to perform the configured measurements consecutively, a Sequencer function is provided.

If activated, the measurements configured in the currently active channels are performed one after the other in the order of the tabs. The currently active measurement is indicated by a [image] symbol in the tab label. The result displays of the individual channels are updated in the tabs (as well as the "MultiView") as the measurements are performed. Sequential operation itself is independent of the currently displayed tab.

For details on the Sequencer function see "Running a Sequence of Measurements" .


Understanding the Display Information

Phase Noise (R&S FSW-K40) > Welcome to the Phase Noise Measurement Application > Understanding the Display Information
Understanding the Display Information

The following figure shows the display as it looks for phase noise measurements. All different information areas are labeled. They are explained in more detail in the following sections.

Screen layout of the phase noise measurement application
1 = Toolbar
2 = Channel bar
3 = Diagram header
4 = Result display
5 = Softkey bar
6 = Measurement status
7 = Status bar

For a description of the elements not described below, please refer to the Getting Started of the R&S FSW.

Measurement status

The application shows the progress of the measurement in a series of green bars at the bottom of the diagram area. For each half decade in the measurement, the applications adds a bar that spans the frequency range of the corresponding half decade.

The bar has several features.

  • The numbers within the green bar show the progress of the measurement(s) in the half decade the application currently works on.
    The first number is the current, the second number the total count of measurements for that half decade. The last number is the time the measurement requires.
  • A double-click on the bar opens an input field to define the number of averages for that half decade.
  • A right-click on the bar opens a context menu.

    The context menu provides easy access to various parameters (resolution bandwidth, sweep mode etc.) that define the measurement characteristics for a half decade. The values in parentheses are the currently selected values. For more information on the available parameters see "Half Decades Configuration Table".
Channel bar information

The channel bar contains information about the current measurement setup, progress and results.

Channel bar of the phase noise application

Frequency

Frequency the R&S FSW has been tuned to.

The frontend frequency is the expected frequency of the carrier. When frequency tracking or verification is on, the application might adjust the frontend frequency.

Ref Level & Att

Reference level (first value) and attenuation (second value) of the R&S FSW.

When level tracking or verification is on, the application might adjust the frontend level.

Measurement

Complete phase noise measurement range. For more information see "Phase Noise Measurement Range".

Measured Level

DUT level that has been actually measured.

The measured level might differ from the frontend level, e.g. if you are using level verification.

Initial Delta

Difference between the nominal level and the first level that has been measured.

Drift

Difference between the 1st level that has been measured and the level that has been measured last.

In continuous sweep mode, the drift is the difference between the 1st level that has been measured in the 1st sweep and the level that has been measured last.

Measured Frequency

DUT frequency that has been actually measured.

The measured frequency might differ from the frontend frequency, e.g. if you are using level verification.

Initial Delta

Difference between the nominal frequency and the first frequency that has been measured.

Drift

Difference between the 1st frequency that has been measured and the frequency that has been measured last.

In continuous sweep mode, the drift is the difference between the 1st frequency that has been measured in the 1st sweep and the frequency that has been measured last.

SGL [#/#]

Sweep mode (single or continuous). If you use trace averaging, it also shows the current measurement number out of the total number of measurements.

The following two figures show the relations between the frequency and level errors.

Frequency errors
ffront = initial frequency set on the frontend
fmeas_x = actual frequency that has been measured
Level errors
Pfront = reference level if tracking = off
Pfront = initial reference level if tracking = on
Pmeas_1 = becomes reference level after first sweep if tracking = on
Pmeas_2 = becomes reference level after second sweep if tracking = on
Pmeas_3 = becomes reference level after third sweep if tracking = on
Window title bar information

For each diagram, the header provides the following information:

Window title bar information of the phase noise application
1 = Window number
2 = Window type
3 = Trace color and number
4 = Trace mode
5 = Smoothing state and degree
Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.


Measurements and Result Displays

Phase Noise (R&S FSW-K40) > Measurements and Result Displays
Measurements and Result Displays

The R&S FSW-K40 measures the phase noise of a single sideband of a carrier.

It features several result displays. Result displays are different representations of the measurement results. They may be diagrams that show the results in a graphic way or tables that show the results in a numeric way.

►

Select the [image] icon in the toolbar or press the MEAS key.

The application enters the SmartGrid configuration mode.

For more information on the SmartGrid functionality see the R&S FSW Getting Started.

In the default state of the application, only the graphical display of phase noise results is active.

└ Phase Noise Diagram
└ Residual Noise
└ Spot Noise
└ Spur List
└ Sweep Result List
└ Spectrum Monitor
└ Frequency Drift
└ Frequency and Level Stability
└ Reference Measurement


Phase Noise Diagram

Phase Noise (R&S FSW-K40) > Measurements and Result Displays > Phase Noise Diagram
Phase Noise Diagram

The phase noise diagram shows the power level of the phase noise over a variable frequency offset from the carrier frequency.

Measurement range

The unit of both axes in the diagram is fix. The x-axis always shows the offset frequencies in relation to the carrier frequency on a logarithmic scale in Hz. It always has a logarithmic scale to make sure of a equal representation of offsets near and far away from the carrier. The range of offsets that the x-axis shows is variable and depends on the measurement range you have defined and the scope of the x-axis that you have set.

For more information on the measurement range see "Phase Noise Measurement Range".

If the measurement range you have set is necessary, but you need a better resolution of the results, you can limit the displayed result by changing the x-axis scope. The scope works like a zoom to get a better view of the trace at various points. It does not start a new measurement or alter the current measurements results in any way.

The y-axis always shows the phase noise power level contained in a 1 Hz bandwidth in relation to the level of the carrier. The unit for this information is dBc/Hz and is also fix.

Y-axis scale

The scale of the y-axis is variable. Usually it is best to use the automatic scaling that the application provides, because it makes sure that the whole trace is always visible. You can, however, also customize the range, the minimum and the maximum values on the y-axis by changing the y-axis scale.

The measurement results are displayed as traces in the diagram area. Up to six active traces at any time are possible. Each of those may have a different setup and thus show different aspects of the measurement results.

In the default state, the application shows two traces. A yellow one and a blue one. Both result from the same measurement data, but have been evaluated differently. On the first trace, smoothing has been applied, the second one shows the raw data.

For more information on trace smoothing see "Trace Averaging".

Overview of the phase noise result display

The figure above shows a phase noise curve with typical characteristics. Frequency offsets near the carrier usually have higher phase noise levels than those further away from the carrier. The curve has a falling slope until the thermal noise of the DUT has been reached. From this point on, it is more or less a straight horizontal line.

Remote command:

TRACe[:​DATA]?


Residual Noise

Phase Noise (R&S FSW-K40) > Measurements and Result Displays > Residual Noise
Residual Noise

The residual noise display summarizes the residual noise results in a table.

For more information on the residual noise results see "Residual Effects".

The table consists of up to four rows with each row representing a different integration interval. Each row basically contains the same information with the exception that the first row always shows the results for the first trace and the other rows with custom integration ranges the results for any one trace.

The residual noise information is made up out of several values.

Type | Shows the number of the trace that is integrated (T[x]).
Start / Stop Offset | Shows the start and stop offset of the integration interval.
Int. PHN | Shows the Integrated Phase Noise. The integral is calculated over the frequency range defined by the Start and Stop Offset values.
PM | Shows the Residual PM result in degrees and rad.
FM | Shows the Residual FM results in Hz.
Jitter | Shows the Jitter in seconds.

For more information on residual noise see "Residual Effects".

Remote command:

Querying Residual PM:

FETCh:​PNOise<t>:​RPM?

Querying Residual FM:

FETCh:​PNOise<t>:​RFM?

Querying Jitter:

FETCh:​PNOise<t>:​RMS?

Querying Integrated Phase Noise

Querying user ranges:

FETCh:​PNOise<t>:​USER<range>:​RFM?

FETCh:​PNOise<t>:​USER<range>:​RMS?

FETCh:​PNOise<t>:​USER<range>:​RPM?


Spot Noise

Phase Noise (R&S FSW-K40) > Measurements and Result Displays > Spot Noise
Spot Noise

Spot noise is the phase noise at a particular frequency offset (or spot) that is part of the measurement range. It is thus like a fixed marker.

The unit of spot noise results is dBc/Hz. The application shows the results in a table.

The table consists of a variable number of 10x frequencies (depending on the measurement range), and a maximum of five user frequencies, with each row containing the spot noise information for a particular frequency offset.

The spot noise information is made up out of several variables.

Type | Shows where the spot noise offset frequency comes from. By default, the application evaluates the spot noise for the first offset frequency of a decade only (10x Hz, beginning at 1 kHz). However, you can add up to five customized offsets frequencies that you want to know the phase noise for. If you want to use more custom offsets, you can add another spot noise table. The "User" label indicates a custom offset frequency.
Offset Frequency | Shows the offset frequency the spot noise is evaluated for. You may add any offset that is part of the measurement range. The number in brackets (T<x>) indicates the trace the result refers to.
Phase Noise | Shows the phase noise for the corresponding offset frequency. The number in brackets (T<x>) indicates the trace the result refers to.
Remote command:

Querying spot noise results on 10x offset frequencies:

CALCulate<n>:​SNOise:​DECades:​X?

CALCulate<n>:​SNOise:​DECades:​Y?

Querying custom spot noise results:

CALCulate<n>:​SNOise<m>:​Y?


Spur List

Phase Noise (R&S FSW-K40) > Measurements and Result Displays > Spur List
Spur List

Spurs are peak levels at one or more offset frequencies and are caused mostly by interfering signals. The application shows the location of all detected spurs in a table.

The table consists of a variable number of rows. For each detected spur, the table shows several results.

Number

Shows the spur number. Spurs are sorted by their frequency, beginning with the spur with the lowest frequency.

Offset Frequency

Shows the position (offset frequency) of the spur.

Power

Shows the power level of the spur in dBc.

Jitter

Shows the jitter value of the spur in s.

In addition to the jitter for each spur, the result display also shows the Discrete Jitter and the Random Jitter at the end of the table.

  • The Discrete Jitter is the RMS value of all individual jitter values.
  • The Random Jitter is the difference of the overall jitter (as shown in the Residual Noise result display) and the Discrete Jitter.
    The result is an RMS value: RandomJitter2 = Jitter2 - DiscreteJitter2

For more information see "Spurs and Spur Removal".

Remote command:

FETCh:​PNOise:​SPURs?

FETCh:​PNOise:​SPURs:​DISCrete?

FETCh:​PNOise:​SPURs:​RANDom?


Sweep Result List

Phase Noise (R&S FSW-K40) > Measurements and Result Displays > Sweep Result List
Sweep Result List

The sweep result list summarizes the results of the phase noise measurement.

The table consists of several rows with each row representing a half decade. The number of rows depends on the number of half decades analyzed during the measurement.

The sweep results are made up out of several values.

  • Results in a red font indicate that the frequency drift is so large that the frequency has drifted into the range of a higher half decade. The result is therefore invalid.
  • Results in a green font indicate the half decade that is currently measured.
Start / Stop | Shows the start and stop offset of the half decade.
Sampling Rate | Shows the sampling rate used in the corresponding half decade.
AVG | Shows the number of measurements performed in the half decade to calculate the average (final) result.
Freq Drift | Shows the difference to the initial (nominal) frequency that was measured in the half decade. If you perform more than one measurement (averages) in the half decade, the value is updated for each single measurement. The last value that has been measured in the half decade will remain in the table.
Max Drift | Shows the highest difference to the initial (nominal) frequency that was measured in the half decade.
Level Drift | Shows the difference to the initial (nominal) level that was measured in the half decade. If you perform more than one measurement (averages) in the half decade, the value is updated for each single measurement. The last value that has been measured in the half decade will remain in the table.
Remote command:

Start offset: FETCh:​PNOise:​SWEep:​STARt?

Stop offset: FETCh:​PNOise:​SWEep:​STOP?

Sample rate: FETCh:​PNOise:​SWEep:​SRATe?

Averages: FETCh:​PNOise:​SWEep:​AVG?

Frequency drift: FETCh:​PNOise:​SWEep:​FDRift?

Max drift: FETCh:​PNOise:​SWEep:​MDRift?

Level drift: FETCh:​PNOise:​SWEep:​LDRift?


Spectrum Monitor

Phase Noise (R&S FSW-K40) > Measurements and Result Displays > Spectrum Monitor
Spectrum Monitor

The spectrum monitor shows the spectrum for the half decade that is currently measured.

Span

The span on the x-axis is defined by the start and stop frequency of the half decade that is currently measured.

Y-axis scale

The scale of the y-axis is automatically determined according to the signal characteristics.

In I/Q mode, the result display contains two traces.
  • The yellow trace ("raw trace") represents the live signal with the actual center frequency currently measured.
  • The blue trace ("track trace") equalizes frequency drifting signals and thus shows a stable version of the signal with the intended center frequency.

If necessary, you can turn the traces on and off. For more information see "Spectrum Monitor: Raw Trace / Trk Trace (On Off)".

The green vertical lines indicate the phase noise offset to be measured on in relation to the displayed center frequency.The position of the two green line depends on the half decade that is currently measured and the sampling rate you have selected.

Remote command:

TRACe[:​DATA]?


Frequency Drift

Phase Noise (R&S FSW-K40) > Measurements and Result Displays > Frequency Drift
Frequency Drift

The frequency drift shows the instantenous frequency over time for the half decade that is currently measured.

Time span

The displayed time span on the x-axis is defined by the time it takes to perform a measurement in the half decade that is currently measured. If the measurement time for a particular half decade is very long (several seconds), the application probably updates the result display several times. In that case, the application splits the measurement into several "sub-measurements".

Y-axis scale

The scale of the y-axis is automatically determined according to the sampling rate. For a better resolution, the trace is offset by the first measured frequency value. Thus, the trace always starts at 0 Hz. The initial correction value is displayed in the diagram as a numeric result.

To get a better resolution of the time axis, use the zoom function.

If necessary, you can turn the trace on and off. For more information see "Frequency Drift: Trace 1 (On Off)".


Frequency and Level Stability

Phase Noise (R&S FSW-K40) > Measurements and Result Displays > Frequency and Level Stability
Frequency and Level Stability

The stability results show the current level and frequency drift characteristics of the carrier signal compared to the initial frequency and level. In addition to the numerical results, the result display also contains a graphical represenation of the drift characteristics.

The result display contains the following results.
  • Carrier Stability
    Difference between the 1st frequency that has been measured and the frequency that has been measured last.
  • Δ to Ref Level
    Difference between the 1st level that has been measured and the level that has been measured last.

The results correspond to the Level Drift and Frequency Drift results displayed in the channel bar. For more information see "Channel bar information"

Note that the results are only valid for I/Q FFT measurements (see "Global Sweep Mode").


Reference Measurement

Phase Noise (R&S FSW-K40) > Measurements and Result Displays > Reference Measurement
Reference Measurement

The reference measurement measures the inherent noise figure (DANL) of the R&S FSW.

To determine the inherent noise, the application performs a measurement without the signal at the input. The resulting trace shows the inherent noise of the R&S FSW only. When you substract that inherent noise from the phase noise of the measurement with trace mathematics, you get a trace that shows the phase noise of the DUT only.

Remote command:

CONFigure:​REFMeas ONCE


Measurement Basics

Phase Noise (R&S FSW-K40) > Measurement Basics
Measurement Basics

The measurement basics contain background information on the terminology and principles of phase noise measurements.

Phase noise measurements in general determine the single sideband phase noise characteristics of a device under test (DUT).

Contents
  • Spurs and Spur Removal
  • Residual Effects
  • Phase Noise Measurement Range
  • Sweep Modes
  • Trace Averaging
  • Frequency Determination
  • Level Determination
  • Signal Attenuation
  • Using Limit Lines
  • Analyzing Several Traces - Trace Mode
  • Using Markers


Spurs and Spur Removal

Phase Noise (R&S FSW-K40) > Measurement Basics > Spurs and Spur Removal
Spurs and Spur Removal

Most phase noise results contain spurs. Spurs are peak levels at one or more offset frequencies and are caused mostly by interfering signals. For some applications you may want to specifically indentify the location of spurs. However, for some applications, spurs do not matter in evaluating the results and you may want to remove them from the trace in order to get a "smooth" phase noise trace.

Spur removal

The application allows you to (visually) remove spurs from the trace. Spur removal is based on an algorithm that detects and completely removes the spurs from the trace and fills the gaps with data that has been determined mathematically.

The spur removal functionality separates the actual spur power from the underlying phase noise and displays the latter in a two-stage process. The first stage of spur detection is based on an eigenvalue decomposition during the signal processing.

Spur threshold

During the second stage, the application uses statistical methods to remove a spur. A spur is detected, if the level of the signal is above a certain threshold. The spur threshold is relative to an imaginary median trace that the application calculates.

If parts of the signal are identfied as spurs, the application removes all signal parts above that level and substitutes them with the median trace.

Spur detection and removal principle


Residual Effects

Phase Noise (R&S FSW-K40) > Measurement Basics > Residual Effects
Residual Effects

Residual noise effects are modulation products that originate directly from the phase noise. It is possible deduct them mathematically from the phase noise of a DUT.

The application calculates three residual noise effects. All calculations are based on an integration of the phase noise over a particular offset frequency range.

Residual PM

The residual phase modulation is phase modulation whose origin is the phase noise.

Residual FM

The residual frequency modulation is noise that results from frequency fluctuation of the signal. Its unit is Hz.

Jitter

The jitter is noise that results from temporal fluctuations of the signal. Its unit is seconds.

Residual noise based on an integration between 10 kHz and 100 kHz offset


Phase Noise Measurement Range

Phase Noise (R&S FSW-K40) > Measurement Basics > Phase Noise Measurement Range
Phase Noise Measurement Range

Phase noise measurements determine the phase noise of a DUT over a particular measurement range. This measurement range is defined by two offset frequencies. The frequency offsets themselves are relative to the nominal frequency of the DUT.

The measurement range again is divided into several (logarithmic) decades, or, for configuration purposes, into half decades.

Measurement range and half decades

This breakdown into several half decades is made to speed up measurements. You can configure each half decade separately in the "Half Decade Configuration Table". For quick, standardized measurements, the application provides several predefined sweep types or allows you to configure each half decade manually, but globally.

The main issue in this context is the resolution bandwidth (RBW) and its effect on the measurement time. In general, it is best to use a resolution bandwidth as small as possible for the most accurate measurement results. However, accuracy comes at the price of measurement speed.

To avoid very long measurement times, the application provides only a certain range of RBW that are available for each half decade.


Sweep Modes

Phase Noise (R&S FSW-K40) > Measurement Basics > Sweep Modes
Sweep Modes

Sweep modes define the data processing method.

Swept

The application performs a sweep of the frequency spectrum.

I/Q FFT

The application evaluates the I/Q data that has been collected and calculates the trace based on that data.


Trace Averaging

Phase Noise (R&S FSW-K40) > Measurement Basics > Trace Averaging
Trace Averaging

The application provides several modes of trace averaging that you can use separately or in any combination.

The order in which averaging is performed is as follows. For more details for each averaging mode see below.

  1. Half decade averaging.

    The application measures each half decade a particualr number of times before measuring the next one.

  2. Sweep Count.

    The application measures the complete measurement range a particular number of times. It again includes half decade averaging as defined.

    After the measurement over the sweep count is finished, the application displays the averaged results.

  3. Trace smoothing.

    Calculates the moving average for the current trace.

Contents
  • Half Decade Averaging
  • Sweep Count
  • Trace Smoothing


Half Decade Averaging

Phase Noise (R&S FSW-K40) > Measurement Basics > Trace Averaging > Half Decade Averaging
Half Decade Averaging

Define the number of measurements that the application performs for each half decade before it displays the averaged results and measures the next half decade.

In combination with the RBW, this is the main factor that has an effect on the measurement time. Typically you will use a small number of averages for small RBWs because small RBWs already provide accurate results and a high number of averages for high RBWs to get more balanced results.


Sweep Count

Phase Noise (R&S FSW-K40) > Measurement Basics > Trace Averaging > Sweep Count
Sweep Count

The sweep count defines the number of sweeps that the application performs during a complete measurements.

A sweep in this context is the measurement over the complete measurement range (including half decade averaging) once. A complete measurement, however, can consists of more than one sweep. In that case the application measures until the number of sweeps that have been defined are done. The measurement configuration stays the same all the time.

In combination with the Average trace mode and half decade averaging, the sweep count averages the trace even more.


Trace Smoothing

Phase Noise (R&S FSW-K40) > Measurement Basics > Trace Averaging > Trace Smoothing
Trace Smoothing

Smoothing is a way to visually remove anomalies in the trace (like spurs) that may distort the results. The smoothing process is based on a moving average over the complete measurement range. The number of samples included in the averaging process (the aperture size) is variable and is a percentage of all samples that the trace consists of.

Sample size included in trace smoothing

The application smoothes the trace only after the measurement has been finished and the data has been analyzed and written to a trace. Thus, smoothing is really just an enhancement of the trace display, not of the data itself. This also means that smoothing is always applied after any other trace averagings have been done, as these happen during the measurement itself. You can turn trace smoothing on and off for all traces individually and compare, for example, the raw and the smooth trace.

Linear smoothing is based on the following algorithm:

Linear trace smoothing

Logarithmic smoothing is based on the following algorithm:

Logarithmic trace smoothing

with:

s = sample number

y(s) = logarithmic phase noise level

x = sample offset from s

n = aperture size


Frequency Determination

Phase Noise (R&S FSW-K40) > Measurement Basics > Frequency Determination
Frequency Determination
Nominal frequency

The nominal frequency is the output or center frequency of the DUT. To get correct and valid measurement results, the application needs to know the real frequency of the DUT.

Unverified signals

The R&S FSW tries to start the measurement as soon as you enter the phase noise application. If it cannot verify a signal, it will try to start the measurement over and over.

To stop the repeated (and probably unsuccessful) signal verification, stop the measurement on the first verification failure.

The available (nominal) frequency range depends on the hardware you are using. For more information see the datasheet of the R&S FSW.

If you are not sure about the nominal frequency, define a tolerance range to verify the frequency. For measurements on unstable or drifting DUTs, use the frequency tracking functionality.

Frequency verification

When you are using frequency verification, the application intiates a measurement that verifies that the frequency of the DUT is within a certain range of the nominal frequency. This measurement takes place before the actual phase noise measurement. Its purpose is to find strong signals within a frequency tolerance range and, if successful, to adjust the nominal frequency and lock onto that new frequency. The frequency tolerance is variable. You can define it in absolute or relative terms.

Frequency and level tolerance

You can define both absolute and relative tolerances. In that case, the application uses the higher tolerance to determine the frequency.

If there is no signal within the tolerance range, the application aborts the phase noise measurement.

In the numerical results, the application always shows the frequency the measurement was actually performed on. If the measured frequency is not the same as the nominal frequency, the numerical results also show the deviation from the nominal frequency.

Frequency tracking

When you are using the frequency tracking, the application tracks drifting frequencies of unstable DUTs. It internally adjusts and keeps a lock on the nominal frequency of the DUT.

Frequency and level tracking
Tracking bandwidth

The tracking bandwidth defines the bandwidth within which the application tracks the frequency.

Normally, the application adjusts the sample rate to the half decade it is currently measuring. For half decades that are near the carrier, the sample rate is small. Half decades far from the carrier use a higher sample rate. However, in case of drifting signals, this method may result in data loss because the default bandwidth for a half decade might be too small for the actual drift in the frequency. In that case, you can define the tracking bandwidth which increases the sample rate if necessary and thus increases the chance to capture the signal.

Frequency tracking with tracking bandwidth turned off (left) and a tracking bandwidth of 100 Hz (right)


Level Determination

Phase Noise (R&S FSW-K40) > Measurement Basics > Level Determination
Level Determination
Nominal level

The nominal level in other terms is the reference level of the R&S FSW. This is the level that the analyzer expects at the RF input.

The available level range depends on the hardware. For more information see the datasheet of the R&S FSW.

Make sure to define a level that is as close to the level of the DUT to get the best dynamic range for the measurement. At the same time make sure that the signal level is not higher than the reference level to avoid an overload of the A/D converter and thus deteriorating measurement results.

If you are not sure about the power level of the DUT, but would still like to use the best dynamic range and get results that are as accurate as possible, you can verify or track the level.

Level verification

When you are using the level verification, the application initiates a measurement that determines the level of the DUT. If the level of the DUT is within a certain tolerance range, it will adjust the nominal level to that of the DUT. Else, it will abort the phase noise measurement.

Define a level tolerance in relation to the current nominal level. The tolerance range works for DUT levels that are above or below the current nominal level.

Level tracking

For tests on DUTs whose level varies, use level tracking. If active, the application keeps track of the DUTs level during the phase noise measurement and adjusts the nominal level accordingly.

For a graphical representation of level verification and level tracking see the figures in "Frequency Determination".


Signal Attenuation

Phase Noise (R&S FSW-K40) > Measurement Basics > Signal Attenuation
Signal Attenuation

Attenuation of the signal may become necessary if you have to reduce the power of the signal that you have applied. Power reduction is necessary, for example, to prevent an overload of the input mixer. An overload of the input mixer may lead to incorrect measurement results or damage to the hardware if the signal power is too strong.

In the default state, the application automatically determines the attenuation according to the reference level. If necessary, you can also define the attenuation manually.

When you attenuate the signal, the application adjusts graphical and numerical results accordingly.

Because the reference level and attenuation are interdependent, changing the attenuation manually may also adjust the reference level.

RF attenuation

RF attenuation is always available. It is a combination of mechanical and IF attenuation.

The mechanical attenuator is located directly after the RF input of the R&S FSW. Its step size is 5 dB. IF attenuation is applied after the signal has been down-converted. Its step size is 1 dB.

Thus, the step size for RF attenuation as a whole is 1 dB. Mechanical attenuation is used whenever possible (attenuation levels that are divisible by 5). IF attenuation handles the 1 dB steps only.

Example:

If you set an attenuation level of 18 dB, 15 dB are mechanical attenuation and 3 dB are IF attenuation.

If you set an attenuation level 0f 6 dB, 5 dB are mechanical attenuation and 1 dB is IF attenuation.

Electronic attenuation

Electronic attenuation is available with R&S FSW-B25. You can use it in addition to mechanical attenuation. The step size of electronic attenuation is 1 dB with attenuation levels not divisible by 5 again handled by the IF attenuator. Compared to RF attenuation, you can define the amount of mechanical and electronic attenuation freely.


Using Limit Lines

Phase Noise (R&S FSW-K40) > Measurement Basics > Using Limit Lines
Using Limit Lines

Limit lines provide an easy way to verify if measurement results are within the limits you need them to be. As soon as you turn a limit line on, the application will indicate if the phase noise a trace displays is in line with the limits or if it violates the limits.

The application provides two kinds of limit lines. 'Normal' limit lines as you know them from the Spectrum application and special thermal limit lines for easy verification of thermal noise results.

Phase noise limit lines

Phase noise limit lines have been designed specifically for phase noise measurements. Their shape is based on the thermal noise floor of the DUT and the typical run of the phase noise curve.

The typical slope of the phase noise curve depends on the offset from the DUT frequency. In the white noise range (the noise floor), far away from the carrier, the slope is more or less 0 dB per frequency decade. In the colored noise segment, the slope is greater than 0 dB. The slope, however, is not constant in that segment, but again is typical for various carrier offset segments (or ranges).

The application supports the definition of up to five ranges, each with a different slope. The ranges themselves are defined by corner frequencies. Corner frequencies are those frequencies that mark the boundaries of typical curve slopes. If you use all five ranges, the result would be a limit line with six segments.

All segments have a slope of 10 dB per decade (f-1) by default.

In most cases, these special limit lines will suffice for phase noise measurements as they represent the typical shape of a phase noise curve.

Typical looks of a special limit line
Normal limit lines

Normal limit lines on the other hand may have any shape and may consist of up to 200 data points. You can turn on up to 8 normal limit lines at the same time. Each of those limit line can test one or several traces.

If you want to use them for phase noise measurements however, a limit line must be scaled in the unit dBc/Hz and must be defined on a logarithmic scale on the horizontal axis.

Possible looks of a normal limit line


Analyzing Several Traces - Trace Mode

Phase Noise (R&S FSW-K40) > Measurement Basics > Analyzing Several Traces - Trace Mode
Analyzing Several Traces - Trace Mode

If several sweeps are performed one after the other, or continuous sweeps are performed, the trace mode determines how the data for subsequent traces is processed. After each sweep, the trace mode determines whether:

  • the data is frozen (View)
  • the data is hidden (Blank)
  • the data is replaced by new values (Clear Write)
  • the data is replaced selectively (Max Hold, Min Hold, Average)

Each time the trace mode is changed, the selected trace memory is cleared.

The R&S FSW provides the following trace modes:

Overview of available trace modes
Trace Mode | Description
Blank | Hides the selected trace.
Clear Write | Overwrite mode: the trace is overwritten by each sweep. This is the default setting.
Max Hold | The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.
Min Hold | The minimum value is determined from several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is lower than the previous one.
Average | The average is formed over several sweeps. The sweep count determines the number of averaging procedures.
View | The current contents of the trace memory are frozen and displayed.

If a trace is frozen ("View" mode), the instrument settings, apart from level range and reference level, can be changed without impact on the displayed trace. The fact that the displayed trace no longer matches the current instrument setting is indicated by the [image] icon on the tab label.

If the level range or reference level is changed, the R&S FSW automatically adapts the trace data to the changed display range. This allows an amplitude zoom to be made after the measurement in order to show details of the trace.

Trace averaging algorithm

In "Average" trace mode, the sweep count determines how many traces are averaged. The more traces are averaged, the smoother the trace is likely to become.

The algorithm for averaging traces depends on the sweep mode and sweep count.

  • sweep count = 0 (default)
    In continuous sweep mode, a continuous average is calculated for 10 sweeps, according to the following formula:
    Equation 1

    Due to the weighting between the current trace and the average trace, past values have practically no influence on the displayed trace after about ten sweeps. With this setting, signal noise is effectively reduced without need for restarting the averaging process after a change of the signal.
  • sweep count = 1
    The currently measured trace is displayed and stored in the trace memory. No averaging is performed.
  • sweep count > 1
    For both "Single Sweep" mode and "Continuous Sweep" mode, averaging takes place over the selected number of sweeps. In this case the displayed trace is determined during averaging according to the following formula:
    Equation 2

    where n is the number of the current sweep (n = 2 ... Sweep Count).
    No averaging is carried out for the first sweep but the measured value is stored in the trace memory. With increasing n, the displayed trace is increasingly smoothed since there are more individual sweeps for averaging.
    After the selected number of sweeps the average trace is saved in the trace memory. Until this number of sweeps is reached, a preliminary average is displayed. When the averaging length defined by the "Sweep Count" is attained, averaging is continued in continuous sweep mode or for "Continue Single Sweep" according to the following formula:

    where N is the sweep count


Using Markers

Phase Noise (R&S FSW-K40) > Measurement Basics > Using Markers
Using Markers

Markers are used to mark points on traces, to read out measurement results and to select a display section quickly. The application provides 4 markers.

By default, the application positions the marker on the lowest level of the trace.You can change a marker position in several ways.

  • Enter a particular offset frequency in the input field that opens when you activate a marker.
  • Move the marker around with the rotary knob or the cursor keys.
  • Drag the marker around using the touchscreen.
Contents
  • Marker Types
  • Activating Markers


Marker Types

Phase Noise (R&S FSW-K40) > Measurement Basics > Using Markers > Marker Types
Marker Types

All markers can be used either as normal markers or delta markers. A normal marker indicates the absolute signal value at the defined position in the diagram. A delta marker indicates the value of the marker relative to the specified reference marker (by default marker 1).

In addition, special functions can be assigned to the individual markers. The availability of special marker functions depends on whether the measurement is performed in the frequency or time domain.


Activating Markers

Phase Noise (R&S FSW-K40) > Measurement Basics > Using Markers > Activating Markers
Activating Markers

Only active markers are displayed in the diagram and in the marker table. Active markers are indicated by a highlighted softkey.

By default, marker 1 is active and positioned on the maximum value (peak) of trace 1 as a normal marker. If several traces are displayed, the marker is set to the maximum value of the trace which has the lowest number and is not frozen (View mode). The next marker to be activated is set to the frequency of the next lower level (next peak) as a delta marker; its value is indicated as an offset to marker 1.

A marker can only be activated when at least one trace in the corresponding window is visible. If a trace is switched off, the corresponding markers and marker functions are also deactivated. If the trace is switched on again, the markers along with coupled functions are restored to their original positions, provided the markers have not been used on another trace.


Configuration

Phase Noise (R&S FSW-K40) > Configuration
Configuration

Phase noise measurements require a special application on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

When you activate a measurement channel in the Phase Noise application, a measurement for the input signal is started automatically with the default configuration. The "Phase Noise" menu is displayed and provides access to the most important configuration functions.

Automatic refresh of preview and visualization in dialog boxes after configuration changes

The R&S FSW supports you in finding the correct measurement settings quickly and easily - after each change in settings in dialog boxes, the preview and visualization areas are updated immediately and automatically to reflect the changes. Thus, you can see if the setting is appropriate or not before accepting the changes.

Contents
  • Configuration Overview
  • Default Settings for Phase Noise Measurements
  • Configuring the Frontend
  • Controlling the Measurement
  • Configuring the Measurement Range
  • Performing Measurements
  • Configuring In- and Outputs
  • Automatic Measurement Configuration


Configuration Overview

Phase Noise (R&S FSW-K40) > Configuration > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. The individual configuration steps are displayed in the order of the data flow. Thus, you can easily configure an entire measurement channel from input over processing to output and analysis by stepping through the dialog boxes as indicated in the "Overview".

In particular, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. Frontend

    See "Configuring the Frontend".

  2. Measurement Control

    See "Controlling the Measurement".

  3. Phase Noise Measurement

    See "Configuring the Measurement Range".

  4. Limit Analysis

    See "Using Limit Lines".

  5. Graphical Results

    See "Configuring Graphical Result Displays".

  6. Numerical Results

    See "Configure Numerical Result Displays".

To configure settings
►

Select any button in the "Overview" to open the corresponding dialog box.

Select a setting in the channel bar (at the top of the measurement channel tab) to change a specific setting.

└ Preset Channel


Preset Channel

Phase Noise (R&S FSW-K40) > Configuration > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

For details see "Default Settings for Phase Noise Measurements".

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Default Settings for Phase Noise Measurements

Phase Noise (R&S FSW-K40) > Configuration > Default Settings for Phase Noise Measurements
Default Settings for Phase Noise Measurements

When you enter the phase noise application for the first time, a set of parameters is passed on from the currently active application:

  • nominal or center frequency
  • nominal or reference level
  • input coupling

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Apart from these settings, the following default settings are activated directly after a measurement channel has been set to the Phase Noise application, or after a channel preset:

Default settings for phase noise measurement channels
Parameter | Value
Attenuation | Auto (0 dB)
Verify frequency & level | On
Frequency & level tracking | Off
Measurement range | 1 kHz ... 1 MHz
Sweep type | Normal
X axis scaling | Measurement range
Y axis scaling | 20 dBc/Hz ... 120 dBc/Hz
Smoothing | 1%
Smoothing type | Linear


Configuring the Frontend

Phase Noise (R&S FSW-K40) > Configuration > Configuring the Frontend
Configuring the Frontend

The "Frontend" tab of the "Measurement Settings" dialog box contains all funtions necessary to configure the frontend of the RF measurement hardware.

You can access this dialog box either via the "Phase Noise Analyzer" dialog box or the "Measurement Configuration" menu (➙ "Inpu/Frontend" softkey).

Functions to configure the RF input described elsewhere:

  • "Input Source Configuration"
└ Nominal Frequency
└ Nominal Level
└ Mechanical Attenuator / Value
└ Coupling


Nominal Frequency

Phase Noise (R&S FSW-K40) > Configuration > Configuring the Frontend > Nominal Frequency
Nominal Frequency

Defines the nominal frequency of the measurement.

For more information see "Frequency Determination".

Remote command:

[SENSe:​]FREQuency:​CENTer


Nominal Level

Phase Noise (R&S FSW-K40) > Configuration > Configuring the Frontend > Nominal Level
Nominal Level

Defines the nominal level of the R&S FSW.

For more informaation see ."Level Determination"

Remote command:

[SENSe:​]POWer:​RLEVel


Mechanical Attenuator / Value

Phase Noise (R&S FSW-K40) > Configuration > Configuring the Frontend > Mechanical Attenuator / Value
Mechanical Attenuator / Value

Turns mechanical attenuation on and off.

If on, you can define an attenuation level in 5 dB steps.

For more information see "Signal Attenuation".

Remote command:

Turning manual attenuation on and off:

INPut:​ATTenuation:​AUTO

Defining an attenuation level:

INPut:​ATTenuation


Coupling

Phase Noise (R&S FSW-K40) > Configuration > Configuring the Frontend > Coupling
Coupling

Selects the coupling method at the RF input.

AC coupling blocks any DC voltage from the input signal. DC coupling lets DC voltage through.

For more information refer to the data sheet.

Remote command:

INPut:​COUPling


Controlling the Measurement

Phase Noise (R&S FSW-K40) > Configuration > Controlling the Measurement
Controlling the Measurement

The "Control" tab of the "Measurement Settings" dialog box contains all funtions necessary to control the sequence of the phase noise measurement.

You can access this dialog box either via the "Phase Noise Analyzer" dialog box or the "Measurement Configuration" menu (➙ "Control" softkey).

└ Verify Frequency
└ Verify Level
└ On Verify Failed
└ Frequency Tracking
└ Level Tracking
└ AM Rejection
└ Max Freq Drift
└ Digital PLL
└ Decimation


Verify Frequency

Phase Noise (R&S FSW-K40) > Configuration > Controlling the Measurement > Verify Frequency
Verify Frequency

Turns frequency verification on and off.

If frequency verification is on, the R&S FSW initiates the phase noise measurement only if the frequency of the DUT is within a certain frequency tolerance range. The tolerance range is either a percentage range of the nominal frequency or a absolute deviation from the nominal frequency.

If you define both an absolute and relative tolerance, the application uses the higher tolerance level.

For more information see "Frequency Determination".

Remote command:

Verify frequency:

[SENSe:​]FREQuency:​VERify[:​STATe]

Relative tolerance:

[SENSe:​]FREQuency:​VERify:​TOLerance:​RELative

Absolute tolerance:

[SENSe:​]FREQuency:​VERify:​TOLerance:​ABSolute


Verify Level

Phase Noise (R&S FSW-K40) > Configuration > Controlling the Measurement > Verify Level
Verify Level

Turns level verification on and off.

If level verification is on, the R&S FSW initiates the phase noise measurement only if the level of the DUT is within a certain level tolerance range. The tolerance range is a level range relative to the nominal level.

For more information see "Level Determination".

Remote command:

Verify level:

[SENSe:​]POWer:​RLEVel:​VERify[:​STATe]

Level tolerance:

[SENSe:​]POWer:​RLEVel:​VERify:​TOLerance


On Verify Failed

Phase Noise (R&S FSW-K40) > Configuration > Controlling the Measurement > On Verify Failed
On Verify Failed

Selects the way the application reacts if signal verification fails.

Takes effect on both frequency and level verification.

"Restart" | Restarts the measurement if verification has failed.
"Stop" | Stops the measurement if verification has failed.
"Run Auto All" | Starts an automatic frequency and level detection routine if verification has failed. After the new frequency and level have been set, the measurement restarts. For more information see "Automatic Measurement Configuration".
Remote command:

[SENSe:​]SWEep:​SVFailed


Frequency Tracking

Phase Noise (R&S FSW-K40) > Configuration > Controlling the Measurement > Frequency Tracking
Frequency Tracking

Turns frequency tracking on and off.

If on, the application tracks the frequency of the DUT during the phase noise measurement and adjusts the nominal frequency accordingly. The application adjusts the frequency after each half decade measurement.

For more information see "Frequency Determination".

Remote command:

[SENSe:​]FREQuency:​TRACk


Level Tracking

Phase Noise (R&S FSW-K40) > Configuration > Controlling the Measurement > Level Tracking
Level Tracking

Turns level tracking on and off.

If on, the R&S FSW tracks the level of the DUT during phase noise measurements and adjusts the nominal level accordingly. The application adjusts the level after each half decade measurement.

For more information see "Level Determination".

Remote command:

[SENSe:​]POWer:​TRACk


AM Rejection

Phase Noise (R&S FSW-K40) > Configuration > Controlling the Measurement > AM Rejection
AM Rejection

Turns the suppression of AM noise on and off.

If on, the application suppresses the AM noise that the signal contains in order to display phase noise as pure as possible.

AM rejection is available for the I/Q sweep mode.

Remote command:

[SENSe:​]REJect:​AM


Max Freq Drift

Phase Noise (R&S FSW-K40) > Configuration > Controlling the Measurement > Max Freq Drift
Max Freq Drift

Defines the minimum bandwidth or sample rate used in the signal processing to increase the probability of capture drifting signals.

The tracking bandwidth is valid for all half decades measured in I/Q mode.

Remote command:

[SENSe:​]IQ:​TBW


Digital PLL

Phase Noise (R&S FSW-K40) > Configuration > Controlling the Measurement > Digital PLL
Digital PLL

Turns an additional frequency correction based on the I/Q data on and off.

If on, the application is able to track frequency changes during the I/Q data capture that would otherwise fall into the half decade measurement bandwidth (see Max Freq Drift).

The digital PLL works for all half decades measured in I/Q mode.

Remote command:

[SENSe:​]IQ:​DPLL


Decimation

Phase Noise (R&S FSW-K40) > Configuration > Controlling the Measurement > Decimation
Decimation

Turns decimation on and off.

If decimation is on, the application fills half decades with smaller offset frequencies with down-sample results of half decades with higher offsets.

Decimation is available in I/Q mode and if the sampling rate is high enough.

Remote command:

[SENSe:​]IQ:​DECimation


Configuring the Measurement Range

Phase Noise (R&S FSW-K40) > Configuration > Configuring the Measurement Range
Configuring the Measurement Range

The "Phase Noise" tab of the "Measurement Settings" dialog box contains all funtions necessary to configure the measurement range for phase noise measurements, including individual range settings.

You can access this dialog box either via the "Phase Noise Analyzer" dialog box, the "Bandwidth" menu (➙ "Bandwidth Config" softkey) or the "Measurement Configuration" menu (➙ "Phase Noise" softkey).

└ Range Start / Stop
└ Sweep Forward
└ Presets
└ Global RBW
└ Global Average Count
└ Multiplier
└ Global Sweep Mode
└ Global I/Q Window
└ Half Decades Configuration Table


Range Start / Stop

Phase Noise (R&S FSW-K40) > Configuration > Configuring the Measurement Range > Range Start / Stop
Range Start / Stop

Defines the frequency offsets that make up the measurement range.

Note that the maximum offset you can select depends on the hardware you are using.

Remote command:

Measurement Range Start

[SENSe:​]FREQuency:​STARt

Measurement Range Stop

[SENSe:​]FREQuency:​STOP


Sweep Forward

Phase Noise (R&S FSW-K40) > Configuration > Configuring the Measurement Range > Sweep Forward
Sweep Forward

Selects the sweep direction. Forward and reverse sweep direction are available.

Forward sweep direction performs a measurement that begins at the smallest frequency offset you have defined. The measurement ends after the largest offset has been reached.

Reverse sweep direction performs a measurement that begins at the largest frequency offset you have defined. The measurement ends after the smallest offset has been reached. The reverse sweep is the default sweep direction because the application is able to lock on a drifting carrier frequency in that case.

Remote command:

[SENSe:​]SWEep:​FORWard


Presets

Phase Noise (R&S FSW-K40) > Configuration > Configuring the Measurement Range > Presets
Presets

Selects predefined measurement settings for each individual half decade that are used for the measurement.

If the measurement settings differ from one of the preset states, the application displays a symbol ( [image]) at the label.

"Fast" | Fast measurements perform one measurement in each half decade. No averaging takes place.
"Normal" | Normal measurements use averaging for some half decades, but with respect to measurement speed.
"Average" | Average measurements use averaging for all half decades. However, you have to put up with slower measurement speed.
"Manual" | Manual configuration of the measurement range.
Remote command:

[SENSe:​]SWEep:​MODE


Global RBW

Phase Noise (R&S FSW-K40) > Configuration > Configuring the Measurement Range > Global RBW
Global RBW

Defines the resolution bandwidth for all half decades globally.

The resulting RBW is a percentage of the start frequency of the corresponding half decade.

If the resulting RBW is not available, the application rounds to the next available bandwidth.

You can also change the global bandwidth with the "RBW Global" softkey in the "Bandwidth" menu.

Remote command:

[SENSe:​]LIST:​BWIDth[:​RESolution]:​RATio


Global Average Count

Phase Noise (R&S FSW-K40) > Configuration > Configuring the Measurement Range > Global Average Count
Global Average Count

Defines the number of measurements that the application uses to calculate averaged results in each half decade.

The range is 1 to 10000.

Remote command:

[SENSe:​]LIST:​SWEep:​COUNt


Multiplier

Phase Noise (R&S FSW-K40) > Configuration > Configuring the Measurement Range > Multiplier
Multiplier

Turns a multiplier that changes the average count in each half decade on and off.

If on, you can define a value that multiplies the number of averages currently defined for each half decade by that value.

When you turn it off, the original averages are restored and used again.

Example:
You have three half decades:
  • 1st half decade average count: 1
  • 2nd half decade average count: 3
  • 3rd half decade average count: 5
If you turn the multiplier on and define a value of 5, the average count changes as follows:
  • 1st half decade average count: 5
  • 2nd half decade average count: 15
  • 3rd half decade average count: 25
Remote command:

[SENSe:​]LIST:​SWEep:​COUNt:​MULTiplier

[SENSe:​]LIST:​SWEep:​COUNt:​MULTiplier:​STATe


Global Sweep Mode

Phase Noise (R&S FSW-K40) > Configuration > Configuring the Measurement Range > Global Sweep Mode
Global Sweep Mode

Selects the analysis mode for all half decades. The sweep mode defines the way the application processes the data.

For more information see "Sweep Modes".

"Normal" | Uses spectrum analyzer data for the data analysis.
"I/Q / FFT" | Uses I/Q data for the data analysis.
Remote command:

[SENSe:​]LIST:​BWIDth:​RESolution:​TYPE


Global I/Q Window

Phase Noise (R&S FSW-K40) > Configuration > Configuring the Measurement Range > Global I/Q Window
Global I/Q Window

Selects the window function for all half decades.

The window function is available for I/Q analysis.

"Blackman Harris" | Blackman Harris window.
"Chebychev" | Chebychev window.
"Gaussian" | Gaussian window.
"Rectangular" | Rectangular window.
Remote command:

[SENSe]:​LIST:​IQWindow:​TYPE


Half Decades Configuration Table

Phase Noise (R&S FSW-K40) > Configuration > Configuring the Measurement Range > Half Decades Configuration Table
Half Decades Configuration Table

Contains all functionality to configure the phase noise measurement range.

"Start"

Shows the offset frequency that the half decade starts with.

"Stop"

Shows the offset frequency that the half decade stops with.

Tip: Note that double-clicking on one of the start or stop offset values is an easy way to adjust the measurement range.

"RBW"

Selects resolution bandwidth for the half decade.

To avoid invalid measurements and long measurement times, the availability of RBW for each half decade is limited.

"Sweep Mode"

Selects the measurement mode. The measurement mode is the way the application analyzes the data.

  • Swept
  • I/Q / FFT

For more information see "Sweep Modes".

"AVG"

Defines the number of averagings that the application performs before the results for a half decade are displayed.

"Window"

Selects the window type for a half decade.

Window functions are available for I/Q measurements.

"Meas Time"

Shows an estimation of how long the measurement of a half decade lasts.

Remote command:

RBW:

[SENSe:​]LIST:​RANGe<range>:​BWIDth[:​RESolution]

Sweep Mode

[SENSe:​]LIST:​RANGe<range>:​FILTer:​TYPE

Averages:

[SENSe:​]LIST:​RANGe<range>:​SWEep:​COUNt

Window:

[SENSe:​]LIST:​RANGe<range>:​IQWindow:​TYPE


Performing Measurements

Phase Noise (R&S FSW-K40) > Configuration > Performing Measurements
Performing Measurements

The "Sweep" menu contains all functionality necessary to control and perform phase noise measurements.

You can access the "Sweep" menu with the SWEEP key.

Functions to configure the sweep described elsewhere:
  • "Multiplier"
  • "Global Average Count"
└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Continue Single Sweep
└ Sweep/Average Count
└ Finish Half Decade


Continuous Sweep/RUN CONT

Phase Noise (R&S FSW-K40) > Configuration > Performing Measurements > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

After triggering, starts the sweep and repeats it continuously until stopped. This is the default setting.

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. Furthermore, the RUN CONT key controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate:​CONTinuous


Single Sweep/ RUN SINGLE

Phase Noise (R&S FSW-K40) > Configuration > Performing Measurements > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. Furthermore, the RUN SINGLE key controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate[:​IMMediate]


Continue Single Sweep

Phase Noise (R&S FSW-K40) > Configuration > Performing Measurements > Continue Single Sweep
Continue Single Sweep

After triggering, repeats the number of sweeps set in "Sweep Count", without deleting the trace of the last measurement.

While the measurement is running, the "Continue Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Remote command:

INITiate:​CONMeas


Sweep/Average Count

Phase Noise (R&S FSW-K40) > Configuration > Performing Measurements > Sweep/Average Count
Sweep/Average Count

Defines the number of sweeps to be performed in the single sweep mode. Values from 0 to 200000 are allowed. If the values 0 or 1 are set, one sweep is performed.

The sweep count is applied to all the traces in all diagrams.

If the trace modes "Average", "Max Hold" or "Min Hold" are set, this value also determines the number of averaging or maximum search procedures.

In continuous sweep mode, if sweep count = 0 (default), averaging is performed over 10 sweeps. For sweep count =1, no averaging, maxhold or minhold operations are performed.

For more information see "How Much Data is Measured: Sweep Points and Sweep Count" .

Remote command:

[SENSe:​]SWEep:​COUNt


Finish Half Decade

Phase Noise (R&S FSW-K40) > Configuration > Performing Measurements > Finish Half Decade
Finish Half Decade

Aborts the measurement in the current half decade and continues measuring the subsequent half decade.

Averaged results displayed for a half decade finished prematurely are based on the number of measurements already done.

Remote command:

[SENSe:​]SWEep:​FHDecade


Configuring In- and Outputs

Phase Noise (R&S FSW-K40) > Configuration > Configuring In- and Outputs
Configuring In- and Outputs

The "In- / Output" menu contains all functionality necessary to control and perform phase noise measurements.

You can access the "In- / Output" menu with the INPUT / OUTPUT key.

For more information on configuring the input mixer see "External Mixer (Option -B21)" .

Contents
  • Input Source Configuration
  • External Mixer Configuration


Input Source Configuration

Phase Noise (R&S FSW-K40) > Configuration > Configuring In- and Outputs > Input Source Configuration
Input Source Configuration

The "Radio Frequency" dialog box contains functionality to configure the input source.

You can access the "Radio Frequency" dialog box with the "Input Source Config" softkey (➙ In- / Output menu) and button (➙ Frontend dialog box).

Note that the "Radio Frequency (On Off)" button is unavailable in the R&S FSW-K40

└ Coupling
└ Input Connector


Coupling

Phase Noise (R&S FSW-K40) > Configuration > Configuring In- and Outputs > Input Source Configuration > Coupling
Coupling

Selects the coupling method at the RF input.

AC coupling blocks any DC voltage from the input signal. DC coupling lets DC voltage through.

For more information refer to the data sheet.

Remote command:

INPut:​COUPling


Input Connector

Phase Noise (R&S FSW-K40) > Configuration > Configuring In- and Outputs > Input Source Configuration > Input Connector
Input Connector

Selects the input source.

The Phase Noise application supports the following input sources:
  • RF Input
  • Analog Baseband Input
    The "Baseband Input I" requires option R&S FSW-B71.
Remote command:

INPut:​CONNector


External Mixer Configuration

Phase Noise (R&S FSW-K40) > Configuration > Configuring In- and Outputs > External Mixer Configuration
External Mixer Configuration

The "External Mixer" dialog box contains functionality to configure an external mixer (R&S FSW-B21).

Please refer to the User Manual of the R&S FSW for a detailed description on how to configure the external mixer.


Automatic Measurement Configuration

Phase Noise (R&S FSW-K40) > Configuration > Automatic Measurement Configuration
Automatic Measurement Configuration

The "Auto Set" menu contains all functionality necessary to determine measurement parameters automatically.

You can access the "Auto Set" menu with the AUTO SET key.

└ Adjusting all Determinable Settings Automatically (Auto All)
└ Adjusting the Center Frequency Automatically (Auto Freq)
└ Setting the Reference Level Automatically (Auto Level)


Adjusting all Determinable Settings Automatically (Auto All)

Phase Noise (R&S FSW-K40) > Configuration > Automatic Measurement Configuration > Adjusting all Determinable Settings Automatically (Auto All)
Adjusting all Determinable Settings Automatically (Auto All)

Activates all automatic adjustment functions for the current measurement settings.

This includes:

  • Auto Frequency
  • Auto Level
Remote command:

[SENSe:​]ADJust:​ALL


Adjusting the Center Frequency Automatically (Auto Freq)

Phase Noise (R&S FSW-K40) > Configuration > Automatic Measurement Configuration > Adjusting the Center Frequency Automatically (Auto Freq)
Adjusting the Center Frequency Automatically (Auto Freq)

This function adjusts the center frequency automatically.

The optimum center frequency is the frequency with the highest S/N ratio in the frequency span. As this function uses the signal counter, it is intended for use with sinusoidal signals.

(See "Performing a Highly Accurate Frequency Measurement (Signal Count)" )

Remote command:

[SENSe:​]ADJust:​FREQuency


Setting the Reference Level Automatically (Auto Level)

Phase Noise (R&S FSW-K40) > Configuration > Automatic Measurement Configuration > Setting the Reference Level Automatically (Auto Level)
Setting the Reference Level Automatically (Auto Level)

Automatically determines the optimal reference level for the current input data. At the same time, the internal attenuators and the preamplifier (for analog baseband input: the full scale level) are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to do so, a level measurement is performed to determine the optimal reference level.

Remote command:

[SENSe:​]ADJust:​LEVel


Analysis

Phase Noise (R&S FSW-K40) > Analysis
Analysis

The application provides various means and methods to analyze and evaluate measurement results.

Contents
  • Configuring Graphical Result Displays
  • Configure Numerical Result Displays
  • Using Limit Lines
  • Using Markers


Configuring Graphical Result Displays

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays
Configuring Graphical Result Displays

The "Graphical" tab of the "Results" dialog box and the "Trace" menu contain all funtions necessary to set up and configure the graphical phase noise result displays.

You can access this dialog box either via the "Phase Noise Analyzer" dialog box or the "Measurement Configuration" menu (➙ "Graphical Results" softkey).

Access the "Trace" menu with the TRACE key.

Contents
  • Scaling the Diagram
  • Configuring Traces


Scaling the Diagram

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Scaling the Diagram
Scaling the Diagram
└ X-Axis Scope
└ X-Axis Start / Stop
└ Half Decade
└ Y Axis Scaling
└ Top / Range / Bottom
└ Auto Scale Once


X-Axis Scope

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Scaling the Diagram > X-Axis Scope
X-Axis Scope

Selects the way the application scales the horizontal axis.

"Half Decade" | The horizontal axis shows one half decade that you can select.
"Manual" | The horizontal axis shows a detail of the measurement range that you can define freely.
"Meas Range" | The horizontal axis shows the complete measurement range.
Remote command:

DISPlay[:​WINDow]:​TRACe:​X[:​SCALe]:​SCOPe


X-Axis Start / Stop

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Scaling the Diagram > X-Axis Start / Stop
X-Axis Start / Stop

Defines the start and stop frequency of the horizontal axis.

Note that the displayed frequency range is a detail of the measurement range. Regardless of the displayed frequency range, the application still performs all measurement over the measurement range you have defined.

The range depends on the measurement range. and possible increments correspond to the half decades.

Available for a manual "X Axis Scope".

Remote command:

X-axis start:

DISPlay[:​WINDow]:​TRACe:​X[:​SCALe]:​STARt

X-axis stop:

DISPlay[:​WINDow]:​TRACe:​X[:​SCALe]:​STOP


Half Decade

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Scaling the Diagram > Half Decade
Half Decade

Selects the half decade that is displayed.

Available if you have selected the half decade "X Axis Scope".

Remote command:

DISPlay[:​WINDow]:​TRACe:​X[:​SCALe]:​HDECade


Y Axis Scaling

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Scaling the Diagram > Y Axis Scaling
Y Axis Scaling

Selects the type of scaling for the vertical axis.

"Auto" | Automatically scales the vertical axis.
"Top & Bottom" | Allows you to set the values at the top and bottom of the vertical axis.
"Top & Range" | Allows to set the value at the top of the vertical axis and its range.
"Bottom & Range" | Allows you to set the value at the bottom of the vertical axis and its range.
Remote command:

Automatic scaling:

DISPlay[:​WINDow]:​TRACe:​Y[:​SCALe]:​AUTO

Manual scaling:

DISPlay[:​WINDow]:​TRACe:​Y[:​SCALe]:​MANual


Top / Range / Bottom

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Scaling the Diagram > Top / Range / Bottom
Top / Range / Bottom

Define the top and bottom values or the range of the vertical axis.

Top defines the top values of the vertical axis. The unit is dBm/Hz.

Bottom defines the bottom value of the vertical axis. The unit is dBm/Hz.

Range defines the range of the vertical axis. The unit is dB.

The availability of the three fields depends on the type of manual "Y Axis Scaling" you have selected.

Remote command:

Top:

DISPlay[:​WINDow]:​TRACe:​Y[:​SCALe]:​RLEVel

Range:

DISPlay[:​WINDow]:​TRACe:​Y:​[:​SCALe]

Bottom:

DISPlay[:​WINDow]:​TRACe:​Y[:​SCALe]:​RLEVel:​LOWer


Auto Scale Once

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Scaling the Diagram > Auto Scale Once
Auto Scale Once

Automatically scales the vertical axis for ideal viewing.


Configuring Traces

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Configuring Traces
Configuring Traces
└ Trace Offset
└ Trace Smoothing
└ Smoothing Type
└ Trace Config
└ Traces
└ Quick Config
└ Trace Export
└ Copy Trace
└ Trace Math
└ Spur Removal / Spur Threshold
└ Frequency Drift: Trace 1 (On Off)
└ Spectrum Monitor: Raw Trace / Trk Trace (On Off)


Trace Offset

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Configuring Traces > Trace Offset
Trace Offset

Defines a trace offset in dB.

The trace offset moves the trace vertically by the level you have defined.

The range is from -200 dB to 200 dB.

Remote command:

DISPlay[:​WINDow]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


Trace Smoothing

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Configuring Traces > Trace Smoothing
Trace Smoothing

Defines the magnitude (or aperture) of trace smoothing in percent.

The range is from 1% to 20%. The aperture takes effect on all traces that you smooth.

For more information see "Trace Smoothing".

Remote command:

DISPlay[:​WINDow]:​TRACe<t>:​SMOothing:​APERture


Smoothing Type

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Configuring Traces > Smoothing Type
Smoothing Type

Selects the method that the application uses to smooth the trace.

For more information see "Trace Smoothing".

"Linear" | Converts the data to linear values before smoothing the trace.
"Logarithmic" | Smoothes the (original) logarithmic data.
"Median" | Smoothes the trace based on the median value of the sample.
Remote command:

DISPlay[:​WINDow]:​TRACe<t>:​SMOothing:​TYPE


Trace Config

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Configuring Traces > Trace Config
Trace Config

Opens a dialog box to configure traces.

The application supports up to 6 traces with a different setup. In the diagram each trace has a different color.

The diagram header of the measurement window contains the trace information, including a color map, trace mode and smoothing percentage.

Note that trace configuration is also possible in the "Trace" softkey menu available via the TRACE key.

└ Traces
└ Quick Config
└ Trace Export
└ Copy Trace
└ Trace Math


Traces

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Configuring Traces > Trace Config > Traces
Traces

The "Traces" tab contains functionality to configure a trace.

"Trace Selection" | The "Trace 1" to "Trace 6" buttons select a trace. If a trace is selected, it is highlighted orange. Note that you cannot select a trace if its trace mode is "Blank".
"Trace Mode" | Selects the trace mode for the corresponding trace. For more information see "Analyzing Several Traces - Trace Mode".
"Smoothing" | Turns trace smoothing for the corresponding trace on and off. For each trace, the application allows you to select the smoothing type and percentage. For more information see "Trace Smoothing" (➙ "Graphical" tab).
"Spur Removal" | Turns spur removal on a particular trace on and off. You can define a threshold above which a spur is detected with the Threshold parameter. For more information see "Spurs and Spur Removal".
Remote command:

Trace mode: DISPlay[:​WINDow]:​TRACe<t>:​MODE

Trace smoothing: DISPlay[:​WINDow]:​TRACe<t>:​SMOothing[:​STATe]

Spur removal: DISPlay[:​WINDow]:​TRACe<t>:​SPURs:​SUPPress


Quick Config

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Configuring Traces > Trace Config > Quick Config
Quick Config

Commonly required trace settings have been predefined and can be applied very quickly by selecting the appropriate button.

Preset All Traces | Resets all traces to their default mode. Trace 1 - 2 mode = Clear Write; Trace 3 - 6 mode = Blank Trace 1 smoothing = On, Trace 2 - 6 smoothing = Off
Set Trace Mode Max | Avg | Min | Trace 1 mode: Max Hold Trace 2 mode: Average Trace 3 mode: Min Hold
Set Trace Mode Max | ClrWrite | Min | Trace 1 mode: Max Hold Trace 2 mode: Clear Write Trace 3 mode: Min Hold


Trace Export

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Configuring Traces > Trace Config > Trace Export
Trace Export

The "Trace Export" tab contains functionality to export trace data.

"Export all traces and all table results" | Turns the export of all measurement results (traces and numerical results) on and off. If on, selecting a particular trace to export in the "Trace to Export" dropdown menu is unavailable.
"Include Instrument Measurement Settings" | Includes or excludes the measurement configuration as shown in the channel bar from the export.
"Trace to Export" | Selects the trace that will be exported to a file.
"Decimal Separator" | Selects the decimal separator for floating-point numerals for the ASCII Trace export. Evaluation programs require different separators in different languages.
"Export Trace to ASCII File" | Opens a file selection dialog box and saves the selected trace in ASCII format to the specified file and directory.
Remote command:

Decimal separator:

FORMat:​DEXPort:​DSEParator

Export trace to ASCII file:

MMEMory:​STORe<n>:​TRACe

Selecting a trace:

FORMat:​DEXPort:​TRACes

Export the header:

FORMat:​DEXPort:​HEADer


Copy Trace

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Configuring Traces > Trace Config > Copy Trace
Copy Trace

The "Copy Trace" softkey opens the "Copy Trace" tab of the "Trace Configuration" dialog box.

The "Copy Trace" tab contains functionality to copy trace data to another trace.

The first group of buttons (labelled "Trace 1" to "Trace 6") select the source trace. The second group of buttons (labelled "Copy to Trace 1" to "Copy to Trace 6") select the destination.

Remote command:

TRACe<n>:​COPY


Trace Math

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Configuring Traces > Trace Config > Trace Math
Trace Math

The "Trace Math" softkey opens the Trace Math tab of the Trace Configuration dialog box.

The "Trace Math" tab contains functionality to control trace mathematics.

"State" | Turns trace mathematics on and off.
"Expression" | Selects the mathematical operation.
Remote command:

State:

CALCulate<n>:​MATH:​STATe

Expression:

CALCulate<n>:​MATH[:​EXPression][:​DEFine]


Spur Removal / Spur Threshold

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Configuring Traces > Spur Removal / Spur Threshold
Spur Removal / Spur Threshold

Turns spur removal for all traces on and off and defines the threshold for spur removal.

For more information see "Spurs and Spur Removal".

Remote command:

Turn spur suppression on and off:

[SENSe:​]SPURs:​SUPPression

Set the threshold:

[SENSe:​]SPURs:​THReshold


Frequency Drift: Trace 1 (On Off)

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Configuring Traces > Frequency Drift: Trace 1 (On Off)
Frequency Drift: Trace 1 (On Off)

Turns the trace displayed in the Frequency Drift result display on and off.


Spectrum Monitor: Raw Trace / Trk Trace (On Off)

Phase Noise (R&S FSW-K40) > Analysis > Configuring Graphical Result Displays > Configuring Traces > Spectrum Monitor: Raw Trace / Trk Trace (On Off)
Spectrum Monitor: Raw Trace / Trk Trace (On Off)

Turns the traces displayed in the Spectrum Monitor result display on and off.

The "Raw Trace (On Off)" softkey controls the yellow trace.

The "Trk Trace (On Off)" softkey controls the blue trace.


Configure Numerical Result Displays

Phase Noise (R&S FSW-K40) > Analysis > Configure Numerical Result Displays
Configure Numerical Result Displays

The "Numerical" tab of the "Results" dialog box contains all funtions necessary to set up and configure the numerical phase noise result displays.

You can access this dialog box either via the "Phase Noise Analyzer" dialog box or the "Measurement Configuration" menu (➙ "Numerical Results" softkey).

Contents
  • Configuring Residual Noise Measurements
  • Configuring Spot Noise Measurements


Configuring Residual Noise Measurements

Phase Noise (R&S FSW-K40) > Analysis > Configure Numerical Result Displays > Configuring Residual Noise Measurements
Configuring Residual Noise Measurements
└ Meas Range
└ User Range


Meas Range

Phase Noise (R&S FSW-K40) > Analysis > Configure Numerical Result Displays > Configuring Residual Noise Measurements > Meas Range
Meas Range

Turns the integration of the entire measurement range for residual noise calculations on and off.

The range defined here is applied to all traces.

"On" | The application calculates the residual noise over the entire measurement range.
"Off" | The application calculates the residual noise over a customized range. The input fields next to the "On/Off" control become available to define a customized integration range. The application shows two red lines ("EL1" and "EL2") in the graphical result display to indicate the custom range.
Remote command:

Turn customized range on and off:

CALCulate<n>:​EVALuation[:​STATe]

Define start point of custom range:

CALCulate<n>:​EVALuation:​STARt

Define end point of custom range:

CALCulate<n>:​EVALuation:​STOP


User Range

Phase Noise (R&S FSW-K40) > Analysis > Configure Numerical Result Displays > Configuring Residual Noise Measurements > User Range
User Range

Defines a custom range for residual noise calculations. You have to assign a user range to a particular trace.

In the default state, user ranges are inactive. "None" is selected in the dropdown menu. If you assign the user range to a trace by selecting one of the traces from the dropdown menu, the input fields next to the trace selection become active. In these fields, you can define a start and stop offset frequency.

Remote command:

Selecting a trace:

CALCulate<n>:​EVALuation:​USER<range>:​TRACe

Define start frequency of user range:

CALCulate<n>:​EVALuation:​USER<range>:​STARt

Define stop frequency of user range:

CALCulate<n>:​EVALuation:​USER<range>:​STOP


Configuring Spot Noise Measurements

Phase Noise (R&S FSW-K40) > Analysis > Configure Numerical Result Displays > Configuring Spot Noise Measurements
Configuring Spot Noise Measurements
└ On All Decade Edges
└ On User Defined Offsets / Offset Frequency


On All Decade Edges

Phase Noise (R&S FSW-K40) > Analysis > Configure Numerical Result Displays > Configuring Spot Noise Measurements > On All Decade Edges
On All Decade Edges

Turns the calculation of spot noise on all 10x offset frequencies on and off.

Remote command:

Turn on and off spot noise calculation on 10x offset frequencies:

CALCulate<n>:​SNOise:​DECades[:​STATe]

Querying spot noise results on 10x offset frequencies:

CALCulate<n>:​SNOise:​DECades:​X?

CALCulate<n>:​SNOise:​DECades:​Y?


On User Defined Offsets / Offset Frequency

Phase Noise (R&S FSW-K40) > Analysis > Configure Numerical Result Displays > Configuring Spot Noise Measurements > On User Defined Offsets / Offset Frequency
On User Defined Offsets / Offset Frequency

Turns custom spot noise frequencies on and off.

If on, the "Offset Frequency" input fields become available. You can measure the spot noise for up to five custom offset frequencies. If active, the application adds those spots to the spot noise table.

Remote command:

Turning spot noise marker on and off:

CALCulate<n>:​SNOise<m>:​STATe

CALCulate<n>:​SNOise:​AOFF

Positioning spot noise markers:

CALCulate<n>:​SNOise<m>:​X

Querying custom spot noise results:

CALCulate<n>:​SNOise<m>:​Y?


Using Limit Lines

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines
Using Limit Lines

The "Limits" tab of the "Results" dialog box contains all funtions necessary to set up and configure limit lines.

You can access this dialog box either via the "Phase Noise Analyzer" dialog box or the "Measurement Configuration" menu (➙ "Limits" softkey) or the LINES key.

Contents
  • Using Phase Noise Limit Lines
  • Selecting Standard Limit Lines
  • Creating and Editing Standard Limit Lines


Using Phase Noise Limit Lines

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Using Phase Noise Limit Lines
Using Phase Noise Limit Lines
└ Phase Noise Limit Line
└ Selected Traces
└ Noise Floor
└ Range x - Range y
└ Copy to User Limit Line


Phase Noise Limit Line

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Using Phase Noise Limit Lines > Phase Noise Limit Line
Phase Noise Limit Line

Selects the shape of the phase noise limit line.

For more information see "Using Limit Lines".

"None" | No limit line.
"Noise floor and x Ranges" | Limit line defined by the noise floor and x corner frequencies and slopes. The application supports up to 5 ranges.
Remote command:

CALCulate:​PNLimit:​TYPE


Selected Traces

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Using Phase Noise Limit Lines > Selected Traces
Selected Traces

Selects the trace(s) to assign a phase noise limit line to.

For more information see "Using Limit Lines".

Remote command:

CALCulate:​PNLimit:​TRACe


Noise Floor

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Using Phase Noise Limit Lines > Noise Floor
Noise Floor

Defines the noise floor level in dBm/Hz of the DUT.

For more information see "Using Limit Lines".

Remote command:

CALCulate:​PNLimit:​NOISe


Range x - Range y

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Using Phase Noise Limit Lines > Range x - Range y
Range x - Range y

Defines the corner frequencies and slope for a particular segment of phase noise limit lines.

The slope defines the slope of the limit line segment to the left of the corner frequency.

For more information see "Using Limit Lines".

Remote command:

Corner frequencies:

CALCulate:​PNLimit:​FC5

Slope:

CALCulate:​PNLimit:​SLOPe<segment>


Copy to User Limit Line

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Using Phase Noise Limit Lines > Copy to User Limit Line
Copy to User Limit Line

Creates a new user limit line from the data of a phase noise limit line.

The file is stored in the default folder for user limit lines. You can load and edit the limit line via the "Select Limit Line" dialog box. For more information see "Select Limit Line".

Remote command:

CALCulate:​PNLimit:​COPY<k>


Selecting Standard Limit Lines

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Selecting Standard Limit Lines
Selecting Standard Limit Lines
└ Select Limit Line
└ Name
└ Unit
└ Compatible
└ Visible
└ Check Traces
└ Comment
└ View Filter
└ New / Edit / Copy To
└ Delete
└ Disable All Lines


Select Limit Line

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Selecting Standard Limit Lines > Select Limit Line
Select Limit Line

The "Select Limit Line" dialog box contains functionality to include standard limit lines in the measurement.

The dialog box consists of a table that shows all available limit lines and their characteristics and a few buttons to manage individual limit lines.

└ Name
└ Unit
└ Compatible
└ Visible
└ Check Traces
└ Comment
└ View Filter
└ New / Edit / Copy To
└ Delete
└ Disable All Lines


Name

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Selecting Standard Limit Lines > Select Limit Line > Name
Name

Shows the name of the limit line.


Unit

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Selecting Standard Limit Lines > Select Limit Line > Unit
Unit

Shows the unit of the limit line.


Compatible

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Selecting Standard Limit Lines > Select Limit Line > Compatible
Compatible

Shows if the limit line is compatible to the current measurement setup or not.

"Yes" | You can use the limit line because it is compatible to the current measurement setup.
"No" | You cannot use the limit line because it is compatible to the current measurement setup.


Visible

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Selecting Standard Limit Lines > Select Limit Line > Visible
Visible

Displays a limit line in the diagram area.

You can display up to eight limit lines at the same time.

Remote command:

Display a limit line:

Lower limit: CALCulate:​LIMit<k>:​LOWer:​STATe

Upper limit: CALCulate:​LIMit<k>:​UPPer:​STATe

Query all visible limit lines:

CALCulate:​LIMit:​ACTive?


Check Traces

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Selecting Standard Limit Lines > Select Limit Line > Check Traces
Check Traces

Turns the limit check for a particular trace on and off.

Remote command:

Assign a limit line to a particular trace:

CALCulate:​LIMit<k>:​TRACe

Activate the limit check:

CALCulate:​LIMit<k>:​STATe

Querying limit check results:

CALCulate:​LIMit<k>:​FAIL?


Comment

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Selecting Standard Limit Lines > Select Limit Line > Comment
Comment

Shows the comment of the selected limit line. If the limit line has no comment, this field stays empty.


View Filter

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Selecting Standard Limit Lines > Select Limit Line > View Filter
View Filter

Turns filter for the list of limit lines on and off.

By default, the list includes all limit lines that are stored on the R&S FSW.

"Show Compatible" | Filters the list of limit lines by compatibility. If on, the list includes only those limit lines that are compatible to the current measurement setup.
"Show Lines For PNoise" | Filters the list of limit lines by compatibility to phase noise measurements. If on, the list includes only those limit lines that are compatible to phase noise measurements.


New / Edit / Copy To

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Selecting Standard Limit Lines > Select Limit Line > New / Edit / Copy To
New / Edit / Copy To

All three buttons open the "Edit Limit Line" dialog box to create or edit limit lines.

When you use the "New" button, the dialog box contains no data.

When you use the "Edit" button, the dialog box contains the data of the previously selected limit line.

When you use the "Copy To" button, the dialog box also contains a copy the data of the previously selected limit line.

Remote command:

New:

CALCulate:​LIMit<k>:​NAME

Copy:

CALCulate:​LIMit<k>:​COPY


Delete

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Selecting Standard Limit Lines > Select Limit Line > Delete
Delete

Deletes the selected limit line.

Remote command:

CALCulate:​LIMit<k>:​DELete


Disable All Lines

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Selecting Standard Limit Lines > Select Limit Line > Disable All Lines
Disable All Lines

Turns all active limit lines off.


Creating and Editing Standard Limit Lines

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Creating and Editing Standard Limit Lines
Creating and Editing Standard Limit Lines
└ Edit Limit Line
└ Name
└ Comment
└ X-Axis
└ Y-Axis
└ Data Points
└ Insert Value
└ Delete Value
└ Shift X
└ Shift Y
└ Save


Edit Limit Line

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Creating and Editing Standard Limit Lines > Edit Limit Line
Edit Limit Line

The "Edit Limit Line" dialog box contains functionality to describe the shape of a limit line.

Because limit lines have to meet certain conditions for phase noise measurements, the availability of parameters is limited.

└ Name
└ Comment
└ X-Axis
└ Y-Axis
└ Data Points
└ Insert Value
└ Delete Value
└ Shift X
└ Shift Y
└ Save


Name

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Creating and Editing Standard Limit Lines > Edit Limit Line > Name
Name

Defines the name of a limit line.

Remote command:

CALCulate:​LIMit<k>:​NAME


Comment

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Creating and Editing Standard Limit Lines > Edit Limit Line > Comment
Comment

Defines a comment for the limit line.

A comment is not mandatory.

Remote command:

CALCulate:​LIMit:​COMMent


X-Axis

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Creating and Editing Standard Limit Lines > Edit Limit Line > X-Axis
X-Axis

Defines the characteristics of the horizontal axis.

The characteristics consist of the unit, the scaling and the type of values.

In the Phase Noise application, the unit for the horizontal axis is always Hz. The scaling can either be logarithmic or linear

"Unit" | In the Phase Noise application, the unit is always Hz.
"Scaling" | In the Phase Noise application, the scaling of the horizontal axis is always logarithmic.
"Type of Values" | The type of values can be absolute values or relative to the nominal frequency.
Remote command:

Type of values:

CALCulate:​LIMit<k>:​LOWer:​MODE

CALCulate:​LIMit<k>:​UPPer:​MODE


Y-Axis

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Creating and Editing Standard Limit Lines > Edit Limit Line > Y-Axis
Y-Axis

Defines the characteristics of the vertical axis.

The characteristics consist of the unit, the type of values and the usage of the line.

"Unit" | In the Phase Noise application, the unit is always dBc/Hz.
"Type of Values" | In the Phase Noise application, the type of values is always absolute.
"Line usage" | Selects if the limit line is used as an upper or lower limit line.


Data Points

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Creating and Editing Standard Limit Lines > Edit Limit Line > Data Points
Data Points

The data points define the shape of the limit line. A limit line consists of at least 2 data points and a maximum of 200 data points.

A data point is defined by its position in horizontal ("Position" column) and vertical direction ("Value" column). The position of the data points have to be in ascending order.

Remote command:

Horizontal data (position):

CALCulate:​LIMit<k>:​CONTrol[:​DATA]

Vertical data (value):

Lower limit: CALCulate:​LIMit<k>:​LOWer[:​DATA]

Upper limit: CALCulate:​LIMit<k>:​UPPer[:​DATA]


Insert Value

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Creating and Editing Standard Limit Lines > Edit Limit Line > Insert Value
Insert Value

Insert a new limit line data point below the selected data point.


Delete Value

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Creating and Editing Standard Limit Lines > Edit Limit Line > Delete Value
Delete Value

Deletes the selected limit line data point.


Shift X

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Creating and Editing Standard Limit Lines > Edit Limit Line > Shift X
Shift X

Shifts each data point horizontally by a particular amount.

Remote command:

CALCulate:​LIMit<k>:​CONTrol:​SHIFt


Shift Y

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Creating and Editing Standard Limit Lines > Edit Limit Line > Shift Y
Shift Y

Shifts each data point vertically by a particular amount.

Remote command:

Lower limit: CALCulate:​LIMit<k>:​LOWer:​SHIFt

Upper limit: CALCulate:​LIMit<k>:​UPPer:​SHIFt


Save

Phase Noise (R&S FSW-K40) > Analysis > Using Limit Lines > Creating and Editing Standard Limit Lines > Edit Limit Line > Save
Save

Saves the limit line or the changes you have made to a limit line.


Using Markers

Phase Noise (R&S FSW-K40) > Analysis > Using Markers
Using Markers

The "Marker Configuration" dialog box and the "Marker" menu contain all functionality necessary to control markers.

You can access the "Marker" menu with the MKR key and the "Marker Configuration" dialog box with the "Marker Config" softkey.

The "Marker Configuration" dialog box consists of two tabs.

The "Markers" tab contains functionlity to define characteristics for each marker.

The "Marker Settings" tab contains general marker functionality.

└ Marker 1 ... Marker x
└ Marker Type
└ Reference Marker
└ Assigning the Marker to a Trace
└ Marker Zoom
└ All Markers Off
└ Marker Table Display


Marker 1 ... Marker x

Phase Noise (R&S FSW-K40) > Analysis > Using Markers > Marker 1 ... Marker x
Marker 1 ... Marker x

Selects and turns the corresponding marker on and off.

Turning on a marker also opens an input field to define the horizontal position of the marker.

In the "Marker Configuration" dialog box, you can also define the horizontal position of each marker ("x-value").

By default, the first marker you turn on is a normal marker, all others are delta markers.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Marker Type

Phase Noise (R&S FSW-K40) > Analysis > Using Markers > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Reference Marker

Phase Noise (R&S FSW-K40) > Analysis > Using Markers > Reference Marker
Reference Marker

Defines a marker as the reference marker which is used to determine relative analysis results (delta marker values).

Remote command:

CALCulate<n>:​DELTamarker<m>:​MREF


Assigning the Marker to a Trace

Phase Noise (R&S FSW-K40) > Analysis > Using Markers > Assigning the Marker to a Trace
Assigning the Marker to a Trace

The "Trace" setting assigns the selected marker to an active trace. The trace determines which value the marker shows at the marker position. If the marker was previously assigned to a different trace, the marker remains on the previous frequency or time, but indicates the value of the new trace.

The marker can also be assigned to the currently active trace using the "Marker to Trace" softkey in the "Marker" menu.

If a trace is turned off, the assigned markers and marker functions are also deactivated.

Remote command:

CALCulate<n>:​MARKer<m>:​TRACe


Marker Zoom

Phase Noise (R&S FSW-K40) > Analysis > Using Markers > Marker Zoom
Marker Zoom

Turns the marker zoom on and off.

The marker zoom magnifies the diagram area around marker 1 by a certain factor.

Turning on the zoom also opens an input field to define the zoom factor.

Remote command:

Turning on the zoom:

DISPlay[:​WINDow:​]ZOOM[:​STATe]

Defining the zoom factor:

CALCulate:​MARKer:​FUNCtion:​ZOOM


All Markers Off

Phase Noise (R&S FSW-K40) > Analysis > Using Markers > All Markers Off
All Markers Off

Deactivates all markers in one step.

Remote command:

CALCulate<n>:​MARKer<m>:​AOFF


Marker Table Display

Phase Noise (R&S FSW-K40) > Analysis > Using Markers > Marker Table Display
Marker Table Display

Defines how the marker information is displayed.

For more details see "Marker Results" .

"On" | Displays the marker information in a table in a separate area beneath the diagram.
"Off" | Displays the marker information within the diagram area.
"Auto" | (Default) Up to two markers are displayed in the diagram area. If more markers are active, the marker table is displayed automatically.
Remote command:

DISPlay:​MTABle


How to Configure Phase Noise Measurements

Phase Noise (R&S FSW-K40) > How to Configure Phase Noise Measurements
How to Configure Phase Noise Measurements
Contents
  • Performing a Basic Phase Noise Measurement
  • Customizing the Measurement Range


Performing a Basic Phase Noise Measurement

Phase Noise (R&S FSW-K40) > How to Configure Phase Noise Measurements > Performing a Basic Phase Noise Measurement
Performing a Basic Phase Noise Measurement

  1. In the Spectrum application, define the center frequency of the DUT.

  2. Enter the "Phase Noise" application.

    The R&S FSW-K40 starts the measurement with the default configuration. The default configuration defines most settings automatically.

    If you need any custom configuration, define them after entering the Phase Noise application.

  3. Layout the display as required via the SmartGrid.

  4. Open the "Overview" dialog box to configure the measurement.

  5. Configure the frontend (frequency, level etc.) via the "Frontend" dialog box.

  6. Define the measurement range via the "Phase Noise" dialog box.

  7. Turn on frequency and level tracking via the "Control" dialog box.

  8. Run a single sweep.

  9. Turn on a marker and read out the results.

  10. Read out the residual noise over the measurement range.

  11. Customize a residual noise range and read out the results.

  12. Freeze trace 1 and 2 (trace mode: View).

  13. Turn on trace 3 and 4 (trace mode: Clear/Write).

  14. Switch the measurement mode to "IQ FFT" in the "Phase Noise" dialog box.

  15. Repeat the measurement.


Customizing the Measurement Range

Phase Noise (R&S FSW-K40) > How to Configure Phase Noise Measurements > Customizing the Measurement Range
Customizing the Measurement Range

The application provides several ways to customize. Each method features a different level of details you can define.

  1. Open the "Phase Noise" configuration via the "Overview" dialog box or the "Meas Config" softkey menu.

  2. Define the frequency offset range you'd like to measure in the corresponding fields.

  3. Select the "Sweep Type".

    1. Select sweep types "Fast", "Normal" or "Averaged" for automatic measurement configuration.

    For a custom configuration, proceed to set up each measurement parameter separately.

  4. Define the "RBW", number of "Averages", sweep "Mode" and "I/Q Window" function.

    1. Define the parameters globally for all (half) decades covered by the measurement range.

    2. Define the parameters for each individual (half) decade covered by the measurement range in the "Half Decade Configuration Table".


Remote Control Commands for Phase Noise Measurements

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements
Remote Control Commands for Phase Noise Measurements

The following remote control commands are required to configure and perform phase noise measurements in a remote environment. The R&S FSW must already be set up for remote operation in a network as described in the base unit manual.

Universal functionality

Note that basic tasks that are also performed in the base unit in the same way are not described here. For a description of such tasks, see the R&S FSW User Manual.

In particular, this includes:

  • Managing Settings and Results, i.e. storing and loading settings and result data.
  • Basic instrument configuration, e.g. checking the system configuration, customizing the screen layout, or configuring networks and remote operation.
  • Using the common status registers (specific status registers for Pulse measurements are not used).
Contents
  • Overview of Remote Command Suffixes
  • Introduction
  • Controlling the Phase Noise Measurement Channel
  • Performing Measurements
  • Controlling the Screen Layout and Result Displays
  • Configuring the Frontend
  • Controlling the Measurement
  • Configuring the Measurement Range
  • Using Limit Lines
  • Graphical Display of Phase Noise Results
  • Configure Numerical Result Displays
  • Using Markers
  • Configuring In- and Outputs
  • Automatic Measurement Configuration
  • Using the Status Register
  • Remote Control Example Scripts


Overview of Remote Command Suffixes

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Overview of Remote Command Suffixes
Overview of Remote Command Suffixes

The remote commands for the Phase Noise Measurement application support the following suffixes.

Suffix | Value range | Description
<k> | 1...8 | Selects a limit line.
<m> | 1...16 | Selects a marker or delta marker.
<n> | 1...16 | Selects a measurement window.
<t> | 1...4 | Selects a trace.


Introduction

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Introduction
Introduction

Commands are program messages that a controller (e.g. a PC) sends to the instrument or software. They operate its functions ('setting commands' or 'events') and request information ('query commands'). Some commands can only be used in one way, others work in two ways (setting and query). If not indicated otherwise, the commands can be used for settings and queries.

The syntax of a SCPI command consists of a header and, in most cases, one or more parameters. To use a command as a query, you have to append a question mark after the last header element, even if the command contains a parameter.

A header contains one or more keywords, separated by a colon. Header and parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). If there is more than one parameter for a command, these are separated by a comma from one another.

Only the most important characteristics that you need to know when working with SCPI commands are described here. For a more complete description, refer to the User Manual of the R&S FSW.

Remote command examples

Note that some remote command examples mentioned in this general introduction may not be supported by this particular application.

Contents
  • Long and Short Form
  • Numeric Suffixes
  • Optional Keywords
  • Alternative Keywords
  • SCPI Parameters


Long and Short Form

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Introduction > Long and Short Form
Long and Short Form

The keywords have a long and a short form. You can use either the long or the short form, but no other abbreviations of the keywords.

The short form is emphasized in upper case letters. Note however, that this emphasis only serves the purpose to distinguish the short from the long form in the manual. For the instrument, the case does not matter.

Example:

SENSe:FREQuency:CENTer is the same as SENS:FREQ:CENT.


Numeric Suffixes

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Introduction > Numeric Suffixes
Numeric Suffixes

Some keywords have a numeric suffix if the command can be applied to multiple instances of an object. In that case, the suffix selects a particular instance (e.g. a measurement window).

Numeric suffixes are indicated by angular brackets (<n>) next to the keyword.

If you don't quote a suffix for keywords that support one, a 1 is assumed.

Example:

DISPlay[:WINDow<1...4>]:ZOOM:STATe enables the zoom in a particular measurement window, selected by the suffix at WINDow.

DISPlay:WINDow4:ZOOM:STATe ON refers to window 4.


Optional Keywords

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Introduction > Optional Keywords
Optional Keywords

Some keywords are optional and are only part of the syntax because of SCPI compliance. You can include them in the header or not.

Note that if an optional keyword has a numeric suffix and you need to use the suffix, you have to include the optional keyword. Otherwise, the suffix of the missing keyword is assumed to be the value 1.

Optional keywords are emphasized with square brackets.

Example:

Without a numeric suffix in the optional keyword:

[SENSe:]FREQuency:CENTer is the same as FREQuency:CENTer

With a numeric suffix in the optional keyword:

DISPlay[:WINDow<1...4>]:ZOOM:STATe

DISPlay:ZOOM:STATe ON enables the zoom in window 1 (no suffix).

DISPlay:WINDow4:ZOOM:STATe ON enables the zoom in window 4.


Alternative Keywords

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Introduction > Alternative Keywords
Alternative Keywords

A vertical stroke indicates alternatives for a specific keyword. You can use both keywords to the same effect.

Example:

[SENSe:]BANDwidth|BWIDth[:RESolution]

In the short form without optional keywords, BAND 1MHZ would have the same effect as BWID 1MHZ.


SCPI Parameters

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Introduction > SCPI Parameters
SCPI Parameters

Many commands feature one or more parameters.

If a command supports more than one parameter, these are separated by a comma.

Example:

LAYout:ADD:WINDow Spectrum,LEFT,MTABle

Parameters may have different forms of values.

Contents
  • Numeric Values
  • Boolean
  • Character Data
  • Character Strings
  • Block Data


Numeric Values

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Introduction > SCPI Parameters > Numeric Values
Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point or exponent. In case of physical quantities, you can also add the unit. If the unit is missing, the command uses the basic unit.

Example:

with unit: SENSe:FREQuency:CENTer 1GHZ

without unit: SENSe:FREQuency:CENTer 1E9 would also set a frequency of 1 GHz.

Values exceeding the resolution of the instrument are rounded up or down.

If the number you have entered is not supported (e.g. in case of discrete steps), the command returns an error.

Instead of a number, you can also set numeric values with a text parameter in special cases.

  • MIN/MAX
    Defines the minimum or maximum numeric value that is supported.
  • DEF
    Defines the default value.
  • UP/DOWN
    Increases or decreases the numeric value by one step. The step size depends on the setting. In some cases you can customize the step size with a corresponding command.
Querying numeric values

When you query numeric values, the system returns a number. In case of physical quantities, it applies the basic unit (e.g. Hz in case of frequencies). The number of digits after the decimal point depends on the type of numeric value.

Example:

Setting: SENSe:FREQuency:CENTer 1GHZ

Query: SENSe:FREQuency:CENTer? would return 1E9

In some cases, numeric values may be returned as text.

  • INF/NINF
    Infinity or negative infinity. Represents the numeric values 9.9E37 or -9.9E37.
  • NAN
    Not a number. Represents the numeric value 9.91E37. NAN is returned in case of errors.


Boolean

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Introduction > SCPI Parameters > Boolean
Boolean

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0.

Querying boolean parameters

When you query boolean parameters, the system returns either the value 1 ("ON") or the value 0 ("OFF").

Example:

Setting: DISPlay:WINDow:ZOOM:STATe ON

Query: DISPlay:WINDow:ZOOM:STATe? would return 1


Character Data

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Introduction > SCPI Parameters > Character Data
Character Data

Character data follows the syntactic rules of keywords. You can enter text using a short or a long form. For more information see "Long and Short Form".

Querying text parameters

When you query text parameters, the system returns its short form.

Example:

Setting: SENSe:BANDwidth:RESolution:TYPE NORMal

Query: SENSe:BANDwidth:RESolution:TYPE? would return NORM


Character Strings

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Introduction > SCPI Parameters > Character Strings
Character Strings

Strings are alphanumeric characters. They have to be in straight quotation marks. You can use a single quotation mark ( ' ) or a double quotation mark ( " ).

Example:

INSTRument:DELete 'Spectrum'


Block Data

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Introduction > SCPI Parameters > Block Data
Block Data

Block data is a format which is suitable for the transmission of large amounts of data.

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted. #0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Controlling the Phase Noise Measurement Channel

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Phase Noise Measurement Channel
Controlling the Phase Noise Measurement Channel

The following commands are necessary to control the measurement channel.

List of Commands
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
SYSTem:PRESet:CHANnel[:EXECute]


INSTrument:CREate:DUPLicate

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Phase Noise Measurement Channel > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect] ).

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event


INSTrument:CREate[:NEW]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Phase Noise Measurement Channel > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements" .


INSTrument:CREate:REPLace

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Phase Noise Measurement Channel > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.


INSTrument:DELete

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Phase Noise Measurement Channel > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Phase Noise Measurement Channel > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:REName

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Phase Noise Measurement Channel > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Phase Noise Measurement Channel > INSTrument[:SELect]
INSTrument[:SELect] <Application>

Selects the measurement application (channel type) for the current channel.

See also INSTrument:​CREate[:​NEW].

For a list of available channel types see table "Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode".

Parameters:
<Application>
PNOise

Phase noise measurements, R&S FSW–K40


SYSTem:PRESet:CHANnel[:EXECute]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Phase Noise Measurement Channel > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


Performing Measurements

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Performing Measurements
Performing Measurements

The following commands are necessary to perform measurements.

You can also perform a sequence of measurements using the Sequencer (see "Multiple Measurement Channels and Sequencer Function").

List of Commands
ABORt
CONFigure:REFMeas ONCE
INITiate:CONMeas
INITiate:CONTinuous
INITiate[:IMMediate]
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:FHDecade
SYSTem:SEQuencer


ABORt

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Performing Measurements > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


CONFigure:REFMeas ONCE

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Performing Measurements > CONFigure:REFMeas ONCE
CONFigure:REFMeas ONCE

This command initiates a reference measurement that determines the inherent phase noise of the R&S FSW.

Parameters:
ONCE |
Example: | CONF:REFM ONCE Initiates a reference measurement
Manual operation: | See "Reference Measurement"


INITiate:CONMeas

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Performing Measurements > INITiate:CONMeas
INITiate:CONMeas

This command restarts a (single) measurement that has been stopped (using INIT:CONT OFF) or finished in single sweep mode.

The measurement is restarted at the beginning, not where the previous measurement was stopped.

As opposed to INITiate[:​IMMediate], this command does not reset traces in maxhold, minhold or average mode. Therefore it can be used to continue measurements using maxhold or averaging functions.

Manual operation: See "Continue Single Sweep"


INITiate:CONTinuous

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Performing Measurements > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the sweep mode.

Note that in single sweep mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous sweep mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous sweep mode in remote control, as results like trace data or markers are only valid after a single sweep end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the sweep mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous sweep

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the sweep mode to single sweep.

INIT:CONT ON

Switches the sweep mode to continuous sweep.

Manual operation: See "Continuous Sweep/RUN CONT"


INITiate[:IMMediate]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Performing Measurements > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

With sweep count or average count > 0, this means a restart of the corresponding number of measurements. With trace mode MAXHold, MINHold and AVERage, the previous results are reset on restarting the measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Single Sweep/ RUN SINGLE"


INITiate:SEQuencer:ABORt

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Performing Measurements > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: Event


INITiate:SEQuencer:IMMediate

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Performing Measurements > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event


INITiate:SEQuencer:MODE

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Performing Measurements > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .


[SENSe:]SWEep:COUNt

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Performing Measurements > [SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt <SweepCount>

This command defines the number of sweeps that the application uses to average traces.

(For Pulse measurements, see also "Trace Statistics" ).

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweeps, the application stops the measurement and calculates the average after the average count has been reached.

Parameters:
<SweepCount>

If you set a sweep count of 0 or 1, the R&S FSW performs one single sweep.

Range: | 0 to 200000
*RST: | 200
Example: SWE:COUN 64

Sets the number of sweeps to 64.

INIT:CONT OFF

Switches to single sweep mode.

INIT;*WAI

Starts a sweep and waits for its end.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep/Average Count"


[SENSe:]SWEep:FHDecade

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Performing Measurements > [SENSe:]SWEep:FHDecade
[SENSe:]SWEep:FHDecade

This command stops the measurement in the current half decade and continues measuring in the subsequent half decade.

Example: | SWE:FHD Aborts the current measurement and continues in the next half decade.
Usage: | Event
Manual operation: | See "Finish Half Decade"


SYSTem:SEQuencer

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Performing Measurements > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .


Controlling the Screen Layout and Result Displays

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Screen Layout and Result Displays
Controlling the Screen Layout and Result Displays

The following commands are necessary to change the evaluation type and rearrange the screen layout as you do using the SmartGrid in manual operation.

List of Commands
DISPlay:MTABle
DISPlay[:WINDow<n>]:SELect
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:STATe
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace


DISPlay:MTABle

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Screen Layout and Result Displays > DISPlay:MTABle
DISPlay:MTABle <DisplayMode>

This command turns the marker table on and off.

Parameters:
<DisplayMode>
ON

Turns the marker table on.

OFF

Turns the marker table off.

AUTO

Turns the marker table on if 3 or more markers are active.

*RST: AUTO
Example: DISP:MTAB ON

Activates the marker table.

Manual operation: See "Marker Table Display"


DISPlay[:WINDow<n>]:SELect

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Screen Layout and Result Displays > DISPlay[:WINDow<n>]:SELect
DISPlay[:WINDow<n>]:SELect

This command sets the focus on the selected result display window.

This window is then the active window.

Example: | DISP:WIND1:SEL Sets the window 1 active.
Usage: | Setting only


DISPlay[:WINDow<n>]:SIZE

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Screen Layout and Result Displays > DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SIZE <Size>

This command maximizes the size of the selected result display window temporarily. To change the size of several windows on the screen permanently, use the LAY:SPL command (see LAYout:​SPLitter).

Parameters:
<Size>
LARGe

Maximizes the selected window to full screen.

Other windows are still active in the background.

SMALl

Reduces the size of the selected window to its original size.

If more than one measurement window was displayed originally, these are visible again.

*RST: SMALl
Example: DISP:WIND2:LARG
Example:

See "Example 1: Adding and Arranging Windows" .


DISPlay[:WINDow<n>]:STATe

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Screen Layout and Result Displays > DISPlay[:WINDow<n>]:STATe
DISPlay[:WINDow<n>]:STATe <State>

This command changes the display state of the selected measurement window.

Note that this command is maintained for compatibility reasons only. Use the LAYout commands for new remote control programs

(See "Controlling the Screen Layout and Result Displays").

Parameters:
<State>
ON | OFF
OFF

The window is closed.

*RST: OFF
Usage: SCPI confirmed


LAYout:ADD[:WINDow]?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Screen Layout and Result Displays > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows" .

Example:

See "Programming Example" .

Usage: Query only
<WindowType> parameter values for Phase Noise application
Parameter value | Window type
FDRift | Frequency drift
MTABle | Marker table
PNOise | Phase noise diagram
RNOise | Residual noise table
SNOise | Spot noise table
SPECtrum | Spectrum monitor
SPURs | Spur list
SRESults | Sweep result list
STABility | Frequency and level stability indicator


LAYout:CATalog[:WINDow]?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Screen Layout and Result Displays > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName>
string

Name of the window.

In the default state, the name of the window is its index.

<WindowIndex>
numeric value

Index of the window.

Example: LAY:CAT?

Result:

'2',2,'1',1

Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:IDENtify[:WINDow]?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Screen Layout and Result Displays > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Screen Layout and Result Displays > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName>

String containing the name of the window.

In the default state, the name of the window is its index.

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Event


LAYout:REPLace[:WINDow]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Screen Layout and Result Displays > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName>

String containing the name of the existing window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<WindowType>

Type of result display you want to use in the existing window.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Example: LAY:REPL:WIND '1',MTAB

Replaces the result display in window 1 with a marker table.

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:SPLitter

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Screen Layout and Result Displays > LAYout:SPLitter
LAYout:SPLitter <Index1>,<Index2>,<Position>

This command changes the position of a splitter and thus controls the size of the windows on each side of the splitter.

As opposed to the DISPlay[:​WINDow<n>]:​SIZE command, the LAYout:SPLitter changes the size of all windows to either side of the splitter permanently, it does not just maximize a single window temporarily.

Note that windows must have a certain minimum size. If the position you define conflicts with the minimum size of any of the affected windows, the command will not work, but does not return an error.

SmartGrid coordinates for remote control of the splitters
Parameters:
<Index1>

The index of one window the splitter controls.

<Index2>

The index of a window on the other side of the splitter.

<Position>

New vertical or horizontal position of the splitter as a fraction of the screen area (without channel and status bar and softkey menu).

The point of origin (x = 0, y = 0) is in the lower left corner of the screen. The end point (x = 100, y = 100) is in the upper right corner of the screen. (See figure "SmartGrid coordinates for remote control of the splitters".)

The direction in which the splitter is moved depends on the screen layout. If the windows are positioned horizontally, the splitter also moves horizontally. If the windows are positioned vertically, the splitter also moves vertically.

Range: 0 to 100
Example: LAY:SPL 1,3,50

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Table') to the center (50%) of the screen, i.e. in the figure above, to the left.

Example: LAY:SPL 1,4,70

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Peak List') towards the top (70%) of the screen.

The following commands have the exact same effect, as any combination of windows above and below the splitter moves the splitter vertically.

LAY:SPL 3,2,70
LAY:SPL 4,1,70
LAY:SPL 2,1,70
Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:WINDow<n>:ADD?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Screen Layout and Result Displays > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction>
LEFT | RIGHt | ABOVe | BELow
<WindowType>

Type of measurement window you want to add.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:WIND1:ADD? LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:WINDow<n>:IDENtify?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Screen Layout and Result Displays > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Screen Layout and Result Displays > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Screen Layout and Result Displays > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


Configuring the Frontend

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Frontend
Configuring the Frontend

The following commands are necessary to configure the frontend settings.

List of Commands
[SENSe:]FREQuency:CENTer
[SENSe:]POWer:RLEVel
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:COUPling


[SENSe:]FREQuency:CENTer

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Frontend > [SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer <Frequency>

This command defines the nominal frequency.

Parameters:
<Frequency>
Range: | 0 to fmax
*RST: | fmax/2
Default unit: | Hz

fmax is specified in the data sheet. min span is 10 Hz

Example: FREQ:CENT 100 MHz

Defines a nominal frequency of 100 MHz.

Usage: SCPI confirmed
Manual operation: See "Nominal Frequency"


[SENSe:]POWer:RLEVel

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Frontend > [SENSe:]POWer:RLEVel
[SENSe:]POWer:RLEVel <Power>

This command defines the nominal level.

Parameters:
<Power>

Numeric value in dBm.

Range: | -200 to 200
*RST: | 0
Example:

POW:RLEV -20

Defines a nominal level of -20 dBm.

Usage: SCPI confirmed
Manual operation: See "Nominal Level"


INPut:ATTenuation

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Frontend > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Mechanical Attenuator / Value"


INPut:ATTenuation:AUTO

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Frontend > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Mechanical Attenuator / Value"


INPut:COUPling

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Frontend > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Coupling"


Controlling the Measurement

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Measurement
Controlling the Measurement

The following commands are necessary to control the sequence of the phase noise measurement.

List of Commands
[SENSe:]FREQuency:TRACk
[SENSe:]FREQuency:VERify:TOLerance:ABSolute
[SENSe:]FREQuency:VERify:TOLerance:RELative
[SENSe:]FREQuency:VERify[:STATe]
[SENSe:]IQ:DECimation
[SENSe:]IQ:DPLL
[SENSe:]IQ:TBW
[SENSe:]POWer:RLEVel:VERify:TOLerance
[SENSe:]POWer:RLEVel:VERify[:STATe]
[SENSe:]POWer:TRACk
[SENSe:]REJect:AM
[SENSe:]SWEep:SVFailed


[SENSe:]FREQuency:TRACk

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Measurement > [SENSe:]FREQuency:TRACk
[SENSe:]FREQuency:TRACk <State>

This command turns frequency tracking on and off.

Parameters:
<State>
ON | OFF
*RST: ON
Example: FREQ:TRAC OFF

Turns off frequency tracking.

Manual operation: See "Frequency Tracking"


[SENSe:]FREQuency:VERify:TOLerance:ABSolute

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Measurement > [SENSe:]FREQuency:VERify:TOLerance:ABSolute
[SENSe:]FREQuency:VERify:TOLerance:ABSolute <Frequency>

This command defines an absolute frequency tolerance for frequency verification.

If you define both an absolute and relative tolerance, the application uses the higher tolerance level.

Parameters:
<Frequency>

Numeric value in Hz.

*RST: 1 kHz
Example: FREQ:VER:TOL:ABS 100kHz

Defines a frequency tolerance range of 100 kHz.

Manual operation: See "Verify Frequency"


[SENSe:]FREQuency:VERify:TOLerance:RELative

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Measurement > [SENSe:]FREQuency:VERify:TOLerance:RELative
[SENSe:]FREQuency:VERify:TOLerance:RELative <Percentage>

This command defines a relative frequency tolerance for frequency verification.

If you define both an absolute and relative tolerance, the application uses the higher tolerance level.

Parameters:
<Percentage>

Numeric value in %, relative to the current nominal frequency.

Range: | 1 to 100
*RST: | 10
Default unit: | PCT
Example:

FREQ:VER:TOL:REL 12

Defines a frequency tolerance of 12% in relation to the nominal frequency.

Usage: SCPI confirmed
Manual operation: See "Verify Frequency"


[SENSe:]FREQuency:VERify[:STATe]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Measurement > [SENSe:]FREQuency:VERify[:STATe]
[SENSe:]FREQuency:VERify[:STATe] <State>

This command turns frequency verification on and off.

Parameters:
<State>
ON | OFF
*RST: ON
Example:

FREQ:VER ON

Turns on frequency verification.

Usage: SCPI confirmed
Manual operation: See "Verify Frequency"


[SENSe:]IQ:DECimation

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Measurement > [SENSe:]IQ:DECimation
[SENSe:]IQ:DECimation <State>

This command turns decimation of results on and off.

Parameters:
<State>
ON | OFF
*RST: ON
Example: IQ:DEC ON

Turns on decimation.

Manual operation: See "Decimation"


[SENSe:]IQ:DPLL

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Measurement > [SENSe:]IQ:DPLL
[SENSe:]IQ:DPLL <State>

This command turns the digital PLL on and off.

Parameters:
<State> | ON | OFF
Example: | IQ:DPLL ON Turns the digital PLL on.
Manual operation: | See "Digital PLL"


[SENSe:]IQ:TBW

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Measurement > [SENSe:]IQ:TBW
[SENSe:]IQ:TBW <Bandwidth>

This command defines the maximum tracking bandwidth (sample rate) for all half decades.

Parameters:
<Bandwidth>
Range: | 60 mHz to 65.28 MHz
Increment: | 10 mHz
*RST: | 60 mHz
Example: IQ:TBW 100HZ

Defines a tracking bandwidth of 100 Hz.

Manual operation: See "Max Freq Drift"


[SENSe:]POWer:RLEVel:VERify:TOLerance

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Measurement > [SENSe:]POWer:RLEVel:VERify:TOLerance
[SENSe:]POWer:RLEVel:VERify:TOLerance <Level>

This command defines a relative level tolerance for level verification

Parameters:
<Level>

Numeric value in dB, relative to the nominal level.

*RST: 10 dB
Example:

POW:RLEV:TOL 5

Defines a level tolerance of 5 dB.

Usage: SCPI confirmed
Manual operation: See "Verify Level"


[SENSe:]POWer:RLEVel:VERify[:STATe]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Measurement > [SENSe:]POWer:RLEVel:VERify[:STATe]
[SENSe:]POWer:RLEVel:VERify[:STATe] <State>

This command turns level verification on and off.

Parameters:
<State>
ON | OFF
*RST: ON
Example:

POW:RLEV:VER ON

Turns on level verification.

Usage: SCPI confirmed
Manual operation: See "Verify Level"


[SENSe:]POWer:TRACk

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Measurement > [SENSe:]POWer:TRACk
[SENSe:]POWer:TRACk <State>

This command turns level tracking on and off.

Parameters:
<State>
ON | OFF
*RST: ON
Example:

POW:TRAC ON

Turns on level tracking.

Usage: SCPI confirmed
Manual operation: See "Level Tracking"


[SENSe:]REJect:AM

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Measurement > [SENSe:]REJect:AM
[SENSe:]REJect:AM <State>

This command turns the suppression of AM noise on and off.

Parameters:
<State> | ON | OFF
Example: | REJ:AM ON Turns AM noise suppression on.
Manual operation: | See "AM Rejection"


[SENSe:]SWEep:SVFailed

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Controlling the Measurement > [SENSe:]SWEep:SVFailed
[SENSe:]SWEep:SVFailed <State>

This command turns repeated tries to start the measurement if signal verification fails on and off.

Parameters:
<State>
ON | OFF

If on, the application tries to verify the signal once and then aborts the measurement if verification has failed.

*RST: OFF
Example: SWE:SVF ON

Stops the measurement if signal verification has failed.

Manual operation: See "On Verify Failed"


Configuring the Measurement Range

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range
Configuring the Measurement Range

The following commands are necessary to configure the phase noise measurement range.

<range> suffix assignment
Suffix | Half Decade
1 | 1 Hz ... 3 Hz
2 | 3 Hz ... 10 Hz
3 | 10 Hz ... 30 Hz
4 | 30 Hz ... 100 Hz
5 | 100 Hz ... 300 Hz
6 | 300 Hz ... 1 kHz
7 | 1 kHz ... 3 kHz
8 | 3 kHz ... 10 kHz
9 | 10 kHz ... 30 kHz
10 | 30 kHz ... 100 kHz
11 | 100 kHz ... 300 kHz
12 | 300 kHz ... 1 MHz
13 | 1 MHz ... 3 MHz
14 | 3 MHz ... 10 MHz
15 | 10 MHz ... 30 MHz
16 | 30 MHz ... 100 MHz
17 | 100 MHz ... 300 MHz
18 | 300 MHz ... 1 GHz
19 | 1 GHz ... 3 GHz
20 | 3 GHz ... 10 GHz
List of Commands
[SENSe:]LIST:BWIDth[:RESolution]:RATio
[SENSe:]BANDwidth|BWIDth[:RESolution]:TYPE
[SENSe:]FREQuency:STARt
[SENSe:]FREQuency:STOP
[SENSe:]LIST:BWIDth:RESolution:TYPE
[SENSe]:LIST:IQWindow:TYPE
[SENSe:]LIST:RANGe<range>:BWIDth[:RESolution]
[SENSe:]LIST:RANGe<range>:FILTer:TYPE
[SENSe:]LIST:RANGe<range>:IQWindow:TYPE
[SENSe:]LIST:RANGe<range>:SWEep:COUNt
[SENSe:]LIST:SWEep:COUNt
[SENSe:]LIST:SWEep:COUNt:MULTiplier
[SENSe:]LIST:SWEep:COUNt:MULTiplier:STATe
[SENSe:]SWEep:FORWard
[SENSe:]SWEep:MODE


[SENSe:]LIST:BWIDth[:RESolution]:RATio

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range > [SENSe:]LIST:BWIDth[:RESolution]:RATio
[SENSe:]LIST:BWIDth[:RESolution]:RATio <Ratio>

This command defines the resolution bandwidth over all half decades.

Parameters:
<Ratio>

Numeric value in %.

The resulting RBW is the percentage of the start frequency of each half decade.

If the resulting RBW is not available, the application rounds to the next available bandwidth.

Range: | 1 to 100
*RST: | 10
Example: LIST:BWID:RAT 20

Defines a RBW of 20% of the start frequency of the corresponding half decade.

Manual operation: See "Global RBW"


[SENSe:]BANDwidth|BWIDth[:RESolution]:TYPE

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range > [SENSe:]BANDwidth|BWIDth[:RESolution]:TYPE
[SENSe:]BANDwidth|BWIDth[:RESolution]:TYPE <Mode>

This command selects the sweep mode for a all half decades globally.

Parameters:
<Mode>
IQ

Measurement based on I/Q data.

NORMal

Measurement based on spectrum analyzer data.

FFT

Measurement based on spectrum analyzer data. Kept for compatibility to R&S FSV.

*RST: Depends on half decade
Example: BAND:TYPE FFT

Selects FFT analysis for all half decades.


[SENSe:]FREQuency:STARt

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range > [SENSe:]FREQuency:STARt
[SENSe:]FREQuency:STARt <Frequency>

This command defines the start frequency of the measurement range.

Parameters:
<Frequency>

Offset frequencies in half decade steps.

Range: | 1 Hz to 3 GHz
*RST: | 1 kHz
Example: FREQ:STAR 10kHz

Defines a start frequency of 10 kHz.

Usage: SCPI confirmed
Manual operation: See "Range Start / Stop"


[SENSe:]FREQuency:STOP

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range > [SENSe:]FREQuency:STOP
[SENSe:]FREQuency:STOP <Frequency>

This command defines the stop frequency of the measurement range.

Parameters:
<Frequency>

Offset frequencies in half decade steps.

Range: | 3 Hz to 10 GHz
*RST: | 1 MHz
Example: FREQ:STOP 10MHz

Defines a stop frequency of 10 MHz.

Usage: SCPI confirmed
Manual operation: See "Range Start / Stop"


[SENSe:]LIST:BWIDth:RESolution:TYPE

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range > [SENSe:]LIST:BWIDth:RESolution:TYPE
[SENSe:]LIST:BWIDth:RESolution:TYPE <Mode>

This command selects the sweep mode for all half decades.

Parameters:
<Mode>
IQFFt

Measurement based on I/Q data.

NORMal

Measurement based on spectrum analyzer data.

FFT

Measurement based on spectrum analyzer data. Kept for compatibility to R&S FSV.

*RST: Depends on half decade
Example: LIST:BWID:RES:TYPE IQFF

Selects I/Q analysis mode for all half decades.

Manual operation: See "Global Sweep Mode"


[SENSe]:LIST:IQWindow:TYPE

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range > [SENSe]:LIST:IQWindow:TYPE
[SENSe]:LIST:IQWindow:TYPE <WindowFunction>

This command selects the window function for all half decades.

Window functions are available for I/Q sweep mode.

Parameters:
<WindowFunction>
RECtangular
GAUSsian
CHEBychev
BHARris
*RST: Depends on the half decade
Example: LIST:IQW:TYPE REC

Selects a rectangular FFT window.

Manual operation: See "Global I/Q Window"


[SENSe:]LIST:RANGe<range>:BWIDth[:RESolution]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range > [SENSe:]LIST:RANGe<range>:BWIDth[:RESolution]
[SENSe:]LIST:RANGe<range>:BWIDth[:RESolution] <RBW>

This command defines the resolution bandwidth for a particular half decade.

Suffix:
<range>
1...20

Selects the half decade.

For the suffix assignment see table "<range> suffix assignment".

Parameters:
<RBW>

Numeric value in Hz.

Note that each half decade has a limited range of available bandwidths.

*RST: | Depends on the half decade
Default unit: | Hz
Example: LIST:RANG9:BWID 100Hz

Selects a RBW of 100 Hz for the half decade from 1 kHz to 3 kHz.

Manual operation: See "Half Decades Configuration Table"


[SENSe:]LIST:RANGe<range>:FILTer:TYPE

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range > [SENSe:]LIST:RANGe<range>:FILTer:TYPE
[SENSe:]LIST:RANGe<range>:FILTer:TYPE <Mode>

This command selects the sweep mode for a particular half decade.

Suffix:
<range>
1...20

Selects the half decade.

For the suffix assignment see table "<range> suffix assignment".

Parameters:
<Mode>
IQFFt

Measurement based on I/Q data.

NORMal

Measurement based on spectrum analyzer data.

FFT

Measurement based on spectrum analyzer data. Kept for compatibility to R&S FSV.

*RST: Depends on half decade
Example: LIST:RANG9:FILT:TYPE FFT

Selects FFT analysis for the ninth half decade.

Manual operation: See "Half Decades Configuration Table"


[SENSe:]LIST:RANGe<range>:IQWindow:TYPE

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range > [SENSe:]LIST:RANGe<range>:IQWindow:TYPE
[SENSe:]LIST:RANGe<range>:IQWindow:TYPE <WindowFunction>

This command selects the window function for a particular half decade.

Window functions are available for I/Q sweep mode.

Suffix:
<range>
1...20

Selects the half decade.

For the suffix assignment see table "<range> suffix assignment".

Parameters:
<WindowFunction>
RECtangular
GAUSsian
CHEBychev
BHARris
*RST: Depends on the half decade
Example: LIST:RANG:IQW:TYPE BHAR

Selects the Blackman Harris window function for the first half decade.

Manual operation: See "Half Decades Configuration Table"


[SENSe:]LIST:RANGe<range>:SWEep:COUNt

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range > [SENSe:]LIST:RANGe<range>:SWEep:COUNt
[SENSe:]LIST:RANGe<range>:SWEep:COUNt <Measurements>

This command defines the number of measurements included in the averaging for a half decade.

Suffix:
<range>
1...20

Selects the half decade.

For the suffix assignment see table "<range> suffix assignment".

Parameters:
<Measurements>
Range: | 1 to 10000
*RST: | Depends on the half decade
Example:

LIST:RANG9:SWE:COUN 15

Includes 15 measurements in the averaging of the ninth half decade.

Usage: SCPI confirmed
Manual operation: See "Half Decades Configuration Table"


[SENSe:]LIST:SWEep:COUNt

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range > [SENSe:]LIST:SWEep:COUNt
[SENSe:]LIST:SWEep:COUNt <Averages>

This command defines the number of measurements to be included in the averaging for each and all half decades.

Parameters:
<Averages>
Range: | 1 to 10000
*RST: | Depends on the half decade.
Example: LIST:SWE:COUN 20

Defines 20 averages for all half decades.

Manual operation: See "Global Average Count"


[SENSe:]LIST:SWEep:COUNt:MULTiplier

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range > [SENSe:]LIST:SWEep:COUNt:MULTiplier
[SENSe:]LIST:SWEep:COUNt:MULTiplier <Multiplier>

This command defines a multiplier that is applied to the average count in each half decade.

Before you can use the command you have to turn on the multiplier with [SENSe:]LIST:SWEep:COUNt:MULTiplier:STATe.

Parameters:
<Multiplier> | Numeric value.
Example: | LIST:SWE:COUN:MULT:STAT ON LIST:SWE:COUN:MULT 5 Turns on the multiplier and multiplies the averages by 5.
Manual operation: | See "Multiplier"


[SENSe:]LIST:SWEep:COUNt:MULTiplier:STATe

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range > [SENSe:]LIST:SWEep:COUNt:MULTiplier:STATe
[SENSe:]LIST:SWEep:COUNt:MULTiplier:STATe <State>

This command turns a multiplier that is applied to the average count in each half decade on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See [SENSe:​]LIST:​SWEep:​COUNt:​MULTiplier.

Manual operation: See "Multiplier"


[SENSe:]SWEep:FORWard

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range > [SENSe:]SWEep:FORWard
[SENSe:]SWEep:FORWard <State>

This command selects the measurement direction.

Specifies the sweep direction. When switched on the sweep direction is from the start frequency to the stop frequency. When switched off the sweep direction is reversed

Parameters:
<State>
ON

Measurements in forward direction.

The measurements starts at the smallest offset frequency.

OFF

Measurement in reverse direction.

The measurement starts at the highest offset frequency.

*RST: OFF
Example:

SWE:FORW ON

Selects forward measurements.

Usage: SCPI confirmed
Manual operation: See "Sweep Forward"


[SENSe:]SWEep:MODE

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring the Measurement Range > [SENSe:]SWEep:MODE
[SENSe:]SWEep:MODE <Mode>

This command selects the type of measurement configuration.

Parameters:
<Mode>
AVERage

Selects a measurement configuration optimized for quality results.

FAST

Selects a measurement configuration optimized for speed.

MANual

Selects manual measurement configuration.

NORMal

Selects a balanced measurement configuration.

*RST: NORMal
Usage: SCPI confirmed
Manual operation: See "Presets"


Using Limit Lines

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines
Using Limit Lines

The following commands are necessary to set up and configure limit lines.

Contents
  • Using Phase Noise Limit Lines
  • Using Standard Limit Lines
  • Creating and Editing Standard Limit Lines


Using Phase Noise Limit Lines

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Phase Noise Limit Lines
Using Phase Noise Limit Lines
List of Commands
CALCulate:PNLimit:COPY<k>
CALCulate:PNLimit:FC1 <Frequency>
CALCulate:PNLimit:FC2 <Frequency>
CALCulate:PNLimit:FC3 <Frequency>
CALCulate:PNLimit:FC4 <Frequency>
CALCulate:PNLimit:FC5
CALCulate:PNLimit:NOISe
CALCulate:PNLimit:TRACe
CALCulate:PNLimit:TYPE
CALCulate:PNLimit:FAIL?
CALCulate:PNLimit:SLOPe<segment>


CALCulate:PNLimit:COPY<k>

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Phase Noise Limit Lines > CALCulate:PNLimit:COPY<k>
CALCulate:PNLimit:COPY<k>

Creates a new user limit line from the data of a phase noise limit line.

Suffix: |
<k> | 1...8 Number of the limit line the phase noise limit line is copied to. An existing limit line in that slot is overwritten.
Example: | CALC:PNL:COPY2 Copies the phase noise limit line to limit line 3.
Usage: | Event
Manual operation: | See "Copy to User Limit Line"


CALCulate:PNLimit:FC1 <Frequency>

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Phase Noise Limit Lines > CALCulate:PNLimit:FC1 <Frequency>
CALCulate:PNLimit:FC1 <Frequency>
CALCulate:PNLimit:FC2 <Frequency>
CALCulate:PNLimit:FC3 <Frequency>
CALCulate:PNLimit:FC4 <Frequency>
CALCulate:PNLimit:FC5 <Frequency>

This command defines the start frequency of a segment of a phase noise limit line.

CALCulate:PNLimit:FC1 is available for special phase noise limit lines with one segment or more.

CALCulate:PNLimit:FC2 is available for special phase noise limit lines with two segment or more.

CALCulate:PNLimit:FC3 is available for special phase noise limit lines with three segment or more.

CALCulate:PNLimit:FC4 is available for special phase noise limit lines with four segment or more.

CALCulate:PNLimit:FC5 is available for special phase noise limit lines with five segments.

Parameters:
<Frequency>

Offset frequency relative to the carrier frequency.

The minimum offset is 1 Hz. The maximum offset depends on the hardware you are using.

*RST: 1 MHz
Example: CALC:PNL:FC1 2MHZ

Defines a corner frequency at 2 MHz offset.

Manual operation: See "Range x - Range y"


CALCulate:PNLimit:NOISe

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Phase Noise Limit Lines > CALCulate:PNLimit:NOISe
CALCulate:PNLimit:NOISe <NoiseLevel>

This command defines the noise floor level of the DUT.

The noise floor level is necessary for the calculation of a phase noise limit line.

Parameters:
<NoiseLevel>
Range: | -200 to 200
*RST: | 0
Default unit: | dBm/Hz
Example: CALC:PNL:NOIS -150

Defines a noise floor level of 150 dBm/Hz.

Manual operation: See "Noise Floor"


CALCulate:PNLimit:TRACe

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Phase Noise Limit Lines > CALCulate:PNLimit:TRACe
CALCulate:PNLimit:TRACe <Trace>

This command selects the trace to assign a phase noise limit line to.

Parameters:
<Trace>
Range: | 1 to 6
*RST: | -
Example: CALC:PNL:TRAC 1

Assigns the phase noise limit line to trace 1.

Manual operation: See "Selected Traces"


CALCulate:PNLimit:TYPE

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Phase Noise Limit Lines > CALCulate:PNLimit:TYPE
CALCulate:PNLimit:TYPE <Shape>

This command selects the shape of a phase noise limit line.

Parameters:
<Shape>
FC1

Limit line defined by the noise floor and 1 corner frequency.

FC2

Limit line defined by the noise floor and 2 corner frequencies.

FC3

Limit line defined by the noise floor and 3 corner frequencies.

FC4

Limit line defined by the noise floor and 4 corner frequencies.

FC5

Limit line defined by the noise floor and 5 corner frequencies.

NONE

No limit line.

*RST: NONE
Example: CALC:PNL:TYPE FC2

Selects a limit line with 2 corner frequencies.

Manual operation: See "Phase Noise Limit Line"


CALCulate:PNLimit:FAIL?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Phase Noise Limit Lines > CALCulate:PNLimit:FAIL?
CALCulate:PNLimit:FAIL?

This command queries the limit check results for phase noise limit lines.

Return values:
<LimitCheck> | 1 Limit check has passed. 0 Limit check has failed.
Example: | CALC:PNL:FAIL? Queries the limit check result.
Usage: | Query only


CALCulate:PNLimit:SLOPe<segment>

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Phase Noise Limit Lines > CALCulate:PNLimit:SLOPe<segment>
CALCulate:PNLimit:SLOPe<segment> <Slope>

This command defines the slope for a phase noise limit line segment.

Suffix:
<segment>
1...5

Selects the limit line segment.

Parameters:
<Slope>

Level distance from the left border of the limit line segment to the previous one.

*RST: | 10
Default unit: | dB
Example: CALC:PNL:SLOP2 20

Defines a slope of 20 dB for the second limit line segment.

Manual operation: See "Range x - Range y"


Using Standard Limit Lines

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Standard Limit Lines
Using Standard Limit Lines
List of Commands
CALCulate:LIMit:ACTive?
CALCulate:LIMit:CLEar[:IMMediate]
CALCulate:LIMit<k>:COPY
CALCulate:LIMit<k>:DELete
CALCulate:LIMit<k>:FAIL?
CALCulate:LIMit<k>:NAME
CALCulate:LIMit<k>:LOWer:STATe
CALCulate:LIMit<k>:STATe
CALCulate:LIMit<k>:TRACe
CALCulate:LIMit<k>:TRACe<t>:CHECk
CALCulate:LIMit<k>:UPPer:STATe


CALCulate:LIMit:ACTive?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Standard Limit Lines > CALCulate:LIMit:ACTive?
CALCulate:LIMit:ACTive?

This command queries the names of all active limit lines.

Return values:
<LimitLines> | String containing the names of all active limit lines in alphabetical order.
Example: | CALC:LIM:ACT? Queries the names of all active limit lines.
Usage: | Query only
Manual operation: | See "Visible"


CALCulate:LIMit:CLEar[:IMMediate]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Standard Limit Lines > CALCulate:LIMit:CLEar[:IMMediate]
CALCulate:LIMit:CLEar[:IMMediate]

This command deletes the result of the current limit check.

The command works on all limit lines in all measurement windows at the same time.

Example: CALC:LIM:CLE

Deletes the result of the limit check.

Example:

See "Programming Example: EMI Measurement" .

Usage: SCPI confirmed


CALCulate:LIMit<k>:COPY

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Standard Limit Lines > CALCulate:LIMit<k>:COPY
CALCulate:LIMit<k>:COPY <Line>

This command copies a limit line.

Parameters:
<Line> | 1 to 8 number of the new limit line <name> String containing the name of the limit line.
Example: | CALC:LIM1:COPY 2 Copies limit line 1 to line 2. CALC:LIM1:COPY 'FM2' Copies limit line 1 to a new line named FM2.
Manual operation: | See "New / Edit / Copy To"


CALCulate:LIMit<k>:DELete

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Standard Limit Lines > CALCulate:LIMit<k>:DELete
CALCulate:LIMit<k>:DELete

This command deletes a limit line.

Usage: | Event
Manual operation: | See "Delete"


CALCulate:LIMit<k>:FAIL?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Standard Limit Lines > CALCulate:LIMit<k>:FAIL?
CALCulate:LIMit<k>:FAIL?

This command queries the result of a limit check.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result>
0

PASS

1

FAIL

Example: INIT;*WAI

Starts a new sweep and waits for its end.

CALC:LIM3:FAIL?

Queries the result of the check for limit line 3.

Example:

See "Example: SEM Measurement" .

Usage: Query only
SCPI confirmed
Manual operation: See "Check Traces"


CALCulate:LIMit<k>:NAME

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Standard Limit Lines > CALCulate:LIMit<k>:NAME
CALCulate:LIMit<k>:NAME <Name>

This command selects a limit line that already exists or defines a name for a new limit line.

Parameters:
<Name>

String containing the limit line name.

*RST: REM1 to REM8 for lines 1 to 8
Example:

See "Programming Example: EMI Measurement" .

Manual operation: See "New / Edit / Copy To"
See "Name"


CALCulate:LIMit<k>:LOWer:STATe

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Standard Limit Lines > CALCulate:LIMit<k>:LOWer:STATe
CALCulate:LIMit<k>:LOWer:STATe <State>

This command turns a lower limit line on and off.

Before you can use the command, you have to select a limit line with CALCulate:​LIMit<k>:​NAME.

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "Visible"


CALCulate:LIMit<k>:STATe

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Standard Limit Lines > CALCulate:LIMit<k>:STATe
CALCulate:LIMit<k>:STATe <State>

This command turns the limit check for a specific limit line on and off.

To query the limit check result, use CALCulate:​LIMit<k>:​FAIL?.

Note that a new command exists to activate the limit check and define the trace to be checked in one step (see CALCulate:​LIMit<k>:​TRACe<t>:​CHECk).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:LIM:STAT ON

Switches on the limit check for limit line 1.

Usage: SCPI confirmed
Manual operation: See "Check Traces"


CALCulate:LIMit<k>:TRACe

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Standard Limit Lines > CALCulate:LIMit<k>:TRACe
CALCulate:LIMit<k>:TRACe <TraceNumber>

This command links a limit line to one or more traces.

Note that this command is maintained for compatibility reasons only. Limit lines no longer need to be assigned to a trace explicitely. The trace to be checked can be defined directly (as a suffix) in the new command to activate the limit check (see CALCulate:​LIMit<k>:​TRACe<t>:​CHECk).

Example: | CALC:LIM2:TRAC 3 Assigns limit line 2 to trace 3.
Manual operation: | See "Check Traces"


CALCulate:LIMit<k>:TRACe<t>:CHECk

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Standard Limit Lines > CALCulate:LIMit<k>:TRACe<t>:CHECk
CALCulate:LIMit<k>:TRACe<t>:CHECk <State>

This command turns the limit check for a specific trace on and off.

To query the limit check result, use CALCulate:​LIMit<k>:​FAIL?.

Note that this command replaces the two commands from previous signal and spectrum analyzers (which are still supported, however):
  • CALCulate:​LIMit<k>:​TRACe
  • CALCulate:​LIMit<k>:​STATe
Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:LIM3:TRAC2:CHEC ON

Switches on the limit check for limit line 3 on trace 2.

Example:

See "Programming Example: EMI Measurement" .


CALCulate:LIMit<k>:UPPer:STATe

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Using Standard Limit Lines > CALCulate:LIMit<k>:UPPer:STATe
CALCulate:LIMit<k>:UPPer:STATe <State>

This command turns an upper limit line on and off.

Before you can use the command, you have to select a limit line with CALCulate:​LIMit<k>:​NAME.

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "Visible"


Creating and Editing Standard Limit Lines

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Creating and Editing Standard Limit Lines
Creating and Editing Standard Limit Lines
List of Commands
CALCulate:LIMit:COMMent
CALCulate:LIMit<k>:CONTrol[:DATA]
CALCulate:LIMit<k>:CONTrol:SHIFt
CALCulate:LIMit<k>:LOWer[:DATA]
CALCulate:LIMit<k>:LOWer:MODE
CALCulate:LIMit<k>:LOWer:SHIFt
CALCulate:LIMit<k>:UPPer:MODE
CALCulate:LIMit<k>:UPPer[:DATA]
CALCulate:LIMit<k>:UPPer:SHIFt


CALCulate:LIMit:COMMent

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Creating and Editing Standard Limit Lines > CALCulate:LIMit:COMMent
CALCulate:LIMit:COMMent <Comment>

This command defines a comment for a limit line.

Parameters:
<Comment> | String containing the description of the limit line. The comment may have up to 40 characters.
Manual operation: | See "Comment"


CALCulate:LIMit<k>:CONTrol[:DATA]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Creating and Editing Standard Limit Lines > CALCulate:LIMit<k>:CONTrol[:DATA]
CALCulate:LIMit<k>:CONTrol[:DATA] <LimitLinePoints>

This command defines the horizontal definition points of a limit line.

Parameters:
<LimitLinePoints>

Variable number of x-axis values.

Note that the number of horizontal values has to be the same as the number of vertical values set with CALCulate:​LIMit<k>:​LOWer[:​DATA] or CALCulate:​LIMit<k>:​UPPer[:​DATA]. If not, the R&S FSW either adds missing values or ignores surplus values.

The unit is Hz.

*RST: -
Usage: SCPI confirmed
Manual operation: See "Data Points"


CALCulate:LIMit<k>:CONTrol:SHIFt

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Creating and Editing Standard Limit Lines > CALCulate:LIMit<k>:CONTrol:SHIFt
CALCulate:LIMit<k>:CONTrol:SHIFt <Distance>

This command moves a complete limit line horizontally.

Compared to defining an offset, this command actually changes the limit line definition points by the value you define.

Parameters:
<Distance> | Numeric value. The unit depends on the scale of the x-axis.
Manual operation: | See "Shift X"


CALCulate:LIMit<k>:LOWer[:DATA]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Creating and Editing Standard Limit Lines > CALCulate:LIMit<k>:LOWer[:DATA]
CALCulate:LIMit<k>:LOWer[:DATA] <LimitLinePoints>

This command defines the vertical definition points of a lower limit line.

Parameters:
<LimitLinePoints>

Variable number of level values.

Note that the number of vertical values has to be the same as the number of horizontal values set with CALCulate:​LIMit<k>:​CONTrol[:​DATA]. If not, the R&S FSW either adds missing values or ignores surplus values.

*RST: Limit line state is OFF
Usage: SCPI confirmed
Manual operation: See "Data Points"


CALCulate:LIMit<k>:LOWer:MODE

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Creating and Editing Standard Limit Lines > CALCulate:LIMit<k>:LOWer:MODE
CALCulate:LIMit<k>:LOWer:MODE <Mode>

This command selects the vertical limit line scaling.

Parameters:
<Mode>
ABSolute

Limit line is defined by absolute physical values.

The unit is variable.

RELative

Limit line is defined by relative values related to the reference level (dB).

*RST: ABSolute
Manual operation: See "X-Axis"


CALCulate:LIMit<k>:LOWer:SHIFt

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Creating and Editing Standard Limit Lines > CALCulate:LIMit<k>:LOWer:SHIFt
CALCulate:LIMit<k>:LOWer:SHIFt <Distance>

This command moves a complete lower limit line vertically.

Compared to defining an offset, this command actually changes the limit line definition points by the value you define.

Parameters:
<Distance> | Defines the distance that the limit line moves.
Manual operation: | See "Shift Y"


CALCulate:LIMit<k>:UPPer:MODE

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Creating and Editing Standard Limit Lines > CALCulate:LIMit<k>:UPPer:MODE
CALCulate:LIMit<k>:UPPer:MODE <Mode>

This command selects the vertical limit line scaling.

Parameters:
<Mode>
ABSolute

Limit line is defined by absolute physical values.

The unit is variable.

RELative

Limit line is defined by relative values related to the reference level (dB).

*RST: ABSolute
Manual operation: See "X-Axis"


CALCulate:LIMit<k>:UPPer[:DATA]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Creating and Editing Standard Limit Lines > CALCulate:LIMit<k>:UPPer[:DATA]
CALCulate:LIMit<k>:UPPer[:DATA] <LimitLinePoints>

This command defines the vertical definition points of an upper limit line.

Parameters:
<LimitLinePoints>

Variable number of level values.

Note that the number of vertical values has to be the same as the number of horizontal values set with CALCulate:​LIMit<k>:​CONTrol[:​DATA]. If not, the R&S FSW either adds missing values or ignores surplus values.

*RST: Limit line state is OFF
Usage: SCPI confirmed
Manual operation: See "Data Points"


CALCulate:LIMit<k>:UPPer:SHIFt

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Limit Lines > Creating and Editing Standard Limit Lines > CALCulate:LIMit<k>:UPPer:SHIFt
CALCulate:LIMit<k>:UPPer:SHIFt <Distance>

This command moves a complete upper limit line vertically.

Compared to defining an offset, this command actually changes the limit line definition points by the value you define.

Parameters:
<Distance> | Defines the distance that the limit line moves.
Usage: | Event
Manual operation: | See "Shift Y"


Graphical Display of Phase Noise Results

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results
Graphical Display of Phase Noise Results

The following commands are necessary to set up and configure the graphical phase noise result displays.

List of Commands
CALCulate<n>:MATH[:EXPression][:DEFine]
CALCulate<n>:MATH:STATe
DISPlay[:WINDow]:TRACe<t>:MODE
DISPlay[:WINDow]:TRACe<t>:SMOothing:APERture
DISPlay[:WINDow]:TRACe<t>:SMOothing[:STATe]
DISPlay[:WINDow]:TRACe<t>:SMOothing:TYPE
DISPlay[:WINDow]:TRACe<t>:SPURs:SUPPress
DISPlay[:WINDow]:TRACe:X[:SCALe]:HDECade
DISPlay[:WINDow]:TRACe:X[:SCALe]:SCOPe
DISPlay[:WINDow]:TRACe:X[:SCALe]:STARt
DISPlay[:WINDow]:TRACe:X[:SCALe]:STOP
DISPlay[:WINDow]:TRACe:Y:[:SCALe]
DISPlay[:WINDow]:TRACe:Y[:SCALe]:AUTO
DISPlay[:WINDow]:TRACe:Y[:SCALe]:MANual
DISPlay[:WINDow]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow]:TRACe:Y[:SCALe]:RLEVel:LOWer
DISPlay[:WINDow]:TRACe:Y[:SCALe]:RLEVel:OFFSet
FORMat:DEXPort:DSEParator
FORMat:DEXPort:HEADer
FORMat:DEXPort:TRACes
MMEMory:STORe<n>:TRACe
[SENSe:]SPURs:SUPPression
[SENSe:]SPURs:THReshold
TRACe<n>:COPY
TRACe[:DATA]?


CALCulate<n>:MATH[:EXPression][:DEFine]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > CALCulate<n>:MATH[:EXPression][:DEFine]
CALCulate<n>:MATH[:EXPression][:DEFine] <Expression>

This command selects the mathematical expression for trace mathematics.

Before you can use the command, you have to turn trace mathematics on.

Parameters:
<Expression>
(TRACE1-TRACE2)

Subtracts trace 2 from trace 1.

(TRACE1-TRACE3)

Subtracts trace 3 from trace 1.

(TRACE1-TRACE4)

Subtracts trace 4 from trace 1.

Example: CALC:MATH:STAT ON

Turns trace mathematics on.

CALC:MATH:EXPR:DEF (TRACE1-TRACE3)

Subtracts trace 3 from trace 1.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Trace Math"


CALCulate<n>:MATH:STATe

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > CALCulate<n>:MATH:STATe
CALCulate<n>:MATH:STATe <State>

This command turns the trace mathematics on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MATH:STAT ON

Turns on trace mathematics.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Trace Math"


DISPlay[:WINDow]:TRACe<t>:MODE

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > DISPlay[:WINDow]:TRACe<t>:MODE
DISPlay[:WINDow]:TRACe<t>:MODE <Mode>

This command selects the trace mode.

Suffix:
<t>
1...6

Selects the trace.

Parameters:
<Mode>
WRITe | VIEW | AVERage | MAXHold | MINHold | BLANk
*RST: Trace 1/2: WRITe, Trace 3-6: BLANk
Example: INIT:CONT OFF
SWE:COUN 16

Turns on single sweep mode and defines a count of 16 measurements.

DISP:TRAC2:MODE AVER

Select average trace mode for trace 2.

INIT;*WAI

Performs the measurement (16 sweeps) with synchronization to the end.

Manual operation: See "Traces"


DISPlay[:WINDow]:TRACe<t>:SMOothing:APERture

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > DISPlay[:WINDow]:TRACe<t>:SMOothing:APERture
DISPlay[:WINDow]:TRACe<t>:SMOothing:APERture <Aperture>

This command defines the degree (aperture) of the trace smoothing.

A single aperture applies to all traces which require smoothing.

Parameters:
<Aperture>
Range: | 1 to 20
*RST: | 0
Default unit: | PCT
Example:

DISP:TRAC:SMO:APER 5

Defines an aperture of 5%.

Usage: SCPI confirmed
Manual operation: See "Trace Smoothing"


DISPlay[:WINDow]:TRACe<t>:SMOothing[:STATe]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > DISPlay[:WINDow]:TRACe<t>:SMOothing[:STATe]
DISPlay[:WINDow]:TRACe<t>:SMOothing[:STATe] <State>

This command turns trace smoothing for a particular trace on and off.

Suffix:
<t>
1...6

Selects the trace.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

DISP:TRAC2:SMO ON

Turns on trace smoothing for trace 2.

Usage: SCPI confirmed
Manual operation: See "Traces"


DISPlay[:WINDow]:TRACe<t>:SMOothing:TYPE

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > DISPlay[:WINDow]:TRACe<t>:SMOothing:TYPE
DISPlay[:WINDow]:TRACe<t>:SMOothing:TYPE <Type>

This command selects the trace smoothing method.

Suffix:
<t>
1...6

Selects the trace.

Parameters:
<Type>
LINear

Linear smoothing.

LOGarithmic

Logarithmic smoothing.

MEDian

Median smoothing.

*RST: LIN
Example:

DISP:TRAC2:SMO:TYPE LIN

Selects linear smoothing for trace 2.

Usage: SCPI confirmed
Manual operation: See "Smoothing Type"


DISPlay[:WINDow]:TRACe<t>:SPURs:SUPPress

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > DISPlay[:WINDow]:TRACe<t>:SPURs:SUPPress
DISPlay[:WINDow]:TRACe<t>:SPURs:SUPPress <State>

This command turns spur suppression on individual traces on and off.

Suffix:
<t>
1...6

Selects the trace.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:TRAC3:SPUR:SUPP ON

Turns on spur suppression on trace 3.

Manual operation: See "Traces"


DISPlay[:WINDow]:TRACe:X[:SCALe]:HDECade

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > DISPlay[:WINDow]:TRACe:X[:SCALe]:HDECade
DISPlay[:WINDow]:TRACe:X[:SCALe]:HDECade <HalfDecade>

This command selects the half decade to be displayed.

Before you can use the command you have to select the half decade scope for the x-axis with DISPlay[:​WINDow]:​TRACe:​X[:​SCALe]:​SCOPe.

Parameters:
<HalfDecade>

Start offset frequency of the half decade you want to display.

Note that the half decade you want to display has to be part of the current measurement range.

Range: | 100 mHz...300 mHz to 3 GHz...10GHz
*RST: | Half decade display is off.
Example: DISP:TRAC:X:HDEC 1KHZ

Displays the half decade beginning with 1 kHz.

Manual operation: See "Half Decade"


DISPlay[:WINDow]:TRACe:X[:SCALe]:SCOPe

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > DISPlay[:WINDow]:TRACe:X[:SCALe]:SCOPe
DISPlay[:WINDow]:TRACe:X[:SCALe]:SCOPe <Scope>

This command selects the way the application scales the horizontal axis.

Parameters:
<Scope>
HDECade

Shows a particular half decade only.

You can select a particular half decade with .

MANual

Shows a custom part of the measurement range.

You can select the start and stop offsets with .

MRANGe

Shows the complete measurement range.

*RST: MRANGe
Example: DISP:TRAC:X:SCOP MRAN

Shows the complete measurement range on the x-axis.

Manual operation: See "X-Axis Scope"


DISPlay[:WINDow]:TRACe:X[:SCALe]:STARt

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > DISPlay[:WINDow]:TRACe:X[:SCALe]:STARt
DISPlay[:WINDow]:TRACe:X[:SCALe]:STARt <StartFrequency>

This command selects the start frequency of the display range.

Before you can use the command you have to select a manual display range for the x-axis with DISPlay[:​WINDow]:​TRACe:​X[:​SCALe]:​SCOPe.

Parameters:
<StartFrequency>

Start offset frequency of a half decade.

Note that the start offset you want to display has to be part of the current measurement range.

Range: | 100 mHz to 3 GHz
*RST: | Manual display range is OFF
Example: DISP:TRAC:X:STAR 100HZ

Defines 100 Hz as the start of the display range.

Manual operation: See "X-Axis Start / Stop"


DISPlay[:WINDow]:TRACe:X[:SCALe]:STOP

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > DISPlay[:WINDow]:TRACe:X[:SCALe]:STOP
DISPlay[:WINDow]:TRACe:X[:SCALe]:STOP <StopFrequency>

This command selects the stop frequency of the display range.

Before you can use the command you have to select a manual display range for the x-axis with DISPlay[:​WINDow]:​TRACe:​X[:​SCALe]:​SCOPe.

Parameters:
<StopFrequency>

Stop offset frequency of a half decade.

Note that the stop offset you want to display has to be part of the current measurement range.

Range: | 300 mHz to 10 GHz
*RST: | Manual display range is OFF
Example: DISP:TRAC:X:STOP 3KHZ

Defines 3 kHz as the end of the display range.

Manual operation: See "X-Axis Start / Stop"


DISPlay[:WINDow]:TRACe:Y:[:SCALe]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > DISPlay[:WINDow]:TRACe:Y:[:SCALe]
DISPlay[:WINDow]:TRACe:Y:[:SCALe] <Range>

This command defines the display range.

Note that you have to select manual y-axis scaling before you can use the command.

Parameters:
<Range>
Range: | 1 to 200
*RST: | 100
Default unit: | dB
Example: DISP:TRAC:Y 80

Defines a display range over 80 dB.

Manual operation: See "Top / Range / Bottom"


DISPlay[:WINDow]:TRACe:Y[:SCALe]:AUTO

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > DISPlay[:WINDow]:TRACe:Y[:SCALe]:AUTO
DISPlay[:WINDow]:TRACe:Y[:SCALe]:AUTO <Mode>

This command turns automatic scaling of the vertical axis on and off.

Parameters:
<Mode>
ON

Automatic scaling is on.

OFF

Automatic scaling is off.

ONCE

Automatic scaling is performed once, then turned off again.

*RST: ON
Example: DISP:WIND2:TRAC:Y:SCAL:AUTO ONCE

Scales the vertical axis once.

Manual operation: See "Y Axis Scaling"


DISPlay[:WINDow]:TRACe:Y[:SCALe]:MANual

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > DISPlay[:WINDow]:TRACe:Y[:SCALe]:MANual
DISPlay[:WINDow]:TRACe:Y[:SCALe]:MANual <Mode>

This command selects the type of manual scaling of the vertical axis.

Parameters:
<Mode>
BRANge

Scaling based on the value at the bottom of the diagram and the axis range.

OFF

Turns manual scaling of the y-axis off.

TBOTtom

Scaling based on the values on the bottom and top of the diagram.

TRANge

Scaling based on the value at the top of the diagram and the axis range.

*RST: ON
Example: DISP:WIND2:TRAC:Y:SCAL:MAN TRAN

Scaling of the vertical axis based on the top and the range of the axis.

Manual operation: See "Y Axis Scaling"


DISPlay[:WINDow]:TRACe:Y[:SCALe]:RLEVel

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > DISPlay[:WINDow]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow]:TRACe:Y[:SCALe]:RLEVel <Reference>

This command defines the reference value or upper border of the diagram area.

Note that you have to select manual y-axis scaling before you can use the command.

Parameters:
<Reference>
Range: | -200 to 0
*RST: | -20
Default unit: | dBc/Hz
Example: DISP:TRAC:Y:RLEV -50

Defines a reference value of -50 dBc/Hz.

Manual operation: See "Top / Range / Bottom"


DISPlay[:WINDow]:TRACe:Y[:SCALe]:RLEVel:LOWer

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > DISPlay[:WINDow]:TRACe:Y[:SCALe]:RLEVel:LOWer
DISPlay[:WINDow]:TRACe:Y[:SCALe]:RLEVel:LOWer <LowerReference>

This command defines the reference value or upper border of the diagram area.

Note that you have to select manual y-axis scaling before you can use the command.

Parameters:
<LowerReference>
Range: | -400 to 1
*RST: | -120
Default unit: | dBc/Hz
Example: DISP:TRAC:Y:RLEV:LOW -100

Sets the bottom of the diagram to .100 dBc/Hz.

Manual operation: See "Top / Range / Bottom"


DISPlay[:WINDow]:TRACe:Y[:SCALe]:RLEVel:OFFSet

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > DISPlay[:WINDow]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines the trace offset.

Parameters:
<Offset>
Range: | -200 to 200
*RST: | 0dB
Default unit: | dB
Example: DISP:TRAC:Y:RLEV:OFFS -10

Defines a trace offset of -10 dB.

Manual operation: See "Trace Offset"


FORMat:DEXPort:DSEParator

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > FORMat:DEXPort:DSEParator
FORMat:DEXPort:DSEParator <Separator>

This command selects the decimal separator for data exported in ASCII format.

Parameters:
<Separator>
COMMa

Uses a comma as decimal separator, e.g. 4,05.

POINt

Uses a point as decimal separator, e.g. 4.05.

*RST: *RST has no effect on the decimal separator. Default is POINt.
Example: FORM:DEXP:DSEP POIN

Sets the decimal point as separator.

Manual operation: See "Trace Export"


FORMat:DEXPort:HEADer

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > FORMat:DEXPort:HEADer
FORMat:DEXPort:HEADer <State>

If enabled, additional instrument and measurement settings are included in the header of the export file for result data. If disabled, only the pure result data from the selected traces and tables is exported.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Usage: SCPI confirmed
Manual operation: See "Trace Export"


FORMat:DEXPort:TRACes

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > FORMat:DEXPort:TRACes
FORMat:DEXPort:TRACes <Selection>

This command selects the data to be included in a data export file (see MMEMory:​STORe<n>:​TRACe).

Parameters:
<Selection>
SINGle

Only a single trace is selected for export, namely the one specified by the MMEMory:​STORe<n>:​TRACe command.

ALL

Selects all active traces and result tables (e.g. Result Summary, marker peak list etc.) in the current application for export to an ASCII file.

The <trace> parameter for the MMEMory:​STORe<n>:​TRACe command is ignored.

*RST: SINGle
Usage: SCPI confirmed
Manual operation: See "Trace Export"


MMEMory:STORe<n>:TRACe

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > MMEMory:STORe<n>:TRACe
MMEMory:STORe<n>:TRACe <Trace>, <FileName>

This command exports trace data from the specified window to an ASCII file.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
<Trace> | Number of the trace to be stored
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR1:TRAC 3,'C:\TEST.ASC' Stores trace 3 from window 1 in the file TEST.ASC.
Usage: | SCPI confirmed
Manual operation: | See "Trace Export"


[SENSe:]SPURs:SUPPression

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > [SENSe:]SPURs:SUPPression
[SENSe:]SPURs:SUPPression <State>

This command turns spur suppression on and off.

Parameters:
<State>
ON | OFF
*RST: ON
Example: SPUR:SUPP OFF

Turns spur suppression off.

Manual operation: See "Spur Removal / Spur Threshold"


[SENSe:]SPURs:THReshold

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > [SENSe:]SPURs:THReshold
[SENSe:]SPURs:THReshold <Threshold>

This command defines the level threshold for spur removal.

Parameters:
<Threshold>
Range: | 0 to 50
*RST: | 0
Default unit: | dB
Example: SPUR:THR 10

Defines a spur threshold of 50 dB.

Manual operation: See "Spur Removal / Spur Threshold"


TRACe<n>:COPY

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > TRACe<n>:COPY
TRACe<n>:COPY <TraceNumber>, <TraceNumber>

This command copies data from one trace to another.

Parameters:
<TraceNumber>, <TraceNumber>
TRACE1 | TRACE2 | TRACE3 | TRACE4 | TRACE5 | TRACE6

The first parameter is the destination trace, the second parameter is the source.

Example: TRAC:COPY TRACe1,TRACe2

Copies the data from trace 2 to trace 1.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Copy Trace"


TRACe[:DATA]?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Graphical Display of Phase Noise Results > TRACe[:DATA]?
TRACe[:DATA]? <Trace>

This command queries the results of the graphical result displays.

Parameters:
<Trace>
TRACE1 | TRACE2 | TRACE3 | TRACE4 | TRACE5 | TRACE6
Return values:
<Frequency>, <Level>

Phase noise:

Coordinates of the phase noise trace as list of comma separated values, beginning at the nearest offset frequency.

<OffsetFrequency1>,<Level1>,<OffsetFrequency2>,<Level2>,...

Spectrum monitor:

Coordinates of the spectrum trace as a list of comma separated values, beginning at the left border of the display.

<Frequency1>,<Level1>,<Frequency2>,<Level2>,...

<Time>, <Frequency>

Frequency drift:

Coordinates of the frequency drift trace as a list of comma separated values, beginning at the left border of the display.

<Time1>,<Frequency1>,<Time2>,<Frequency2>,...

Example: TRAC? TRACE1

Queries the data of trace 1.

Usage: Query only
Manual operation: See "Phase Noise Diagram"
See "Spectrum Monitor"


Configure Numerical Result Displays

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays
Configure Numerical Result Displays

The following commands are necessary to configure the numerical phase noise result displays.

Contents
  • Configuring Residual Noise Measurements
  • Reading Out Residual Noise Results
  • Configuring Spot Noise Measurements
  • Reading Out the Spur List
  • Reading Out Measured Values
  • Reading Out the Sweep Result List


Configuring Residual Noise Measurements

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Configuring Residual Noise Measurements
Configuring Residual Noise Measurements
List of Commands
CALCulate<n>:EVALuation:STARt
CALCulate<n>:EVALuation[:STATe]
CALCulate<n>:EVALuation:STOP
CALCulate<n>:EVALuation:USER<range>:STARt
CALCulate<n>:EVALuation:USER<range>:STOP
CALCulate<n>:EVALuation:USER<range>:TRACe


CALCulate<n>:EVALuation:STARt

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Configuring Residual Noise Measurements > CALCulate<n>:EVALuation:STARt
CALCulate<n>:EVALuation:STARt <OffsetFrequency>

This command defines the start point of the residual noise integration range.

Before you can use the command, you have to turn off the measurement range integration with CALCulate<n>:​EVALuation[:​STATe].

Parameters:
<OffsetFrequency>

The minimum offset is 1 Hz. The maximum offset depends on the hardware you are using.

*RST: 1 kHz
Example:

CALC:EVAL:STAR 1 kHz

Defines an start point of 1 kHz for the residual noise range.

Manual operation: See "Meas Range"


CALCulate<n>:EVALuation[:STATe]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Configuring Residual Noise Measurements > CALCulate<n>:EVALuation[:STATe]
CALCulate<n>:EVALuation[:STATe] <State>

This command turn integration of the measurement range for residual noise calculation on and off.

Parameters:
<State>
ON

Calculates the residual noise over the entire measurement range.

OFF

Calculates the residual noise over a customized range.

*RST: ON
Example:

CALC:EVAL OFF

Uses a customized offset range for residual noise calculation.

Manual operation: See "Meas Range"


CALCulate<n>:EVALuation:STOP

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Configuring Residual Noise Measurements > CALCulate<n>:EVALuation:STOP
CALCulate<n>:EVALuation:STOP <OffsetFrequency>

This command defines the end point of the residual noise integration range.

Before you can use the command, you have to turn off the measurement range integration with CALCulate<n>:​EVALuation[:​STATe].

Parameters:
<OffsetFrequency>

The minimum offset is 1 Hz. The maximum offset depends on the hardware you are using.

*RST: 1 MHz
Example:

CALC:EVAL:STOP 1 MHZ

Defines an end point of 1 MHz for the residual noise range.

Manual operation: See "Meas Range"


CALCulate<n>:EVALuation:USER<range>:STARt

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Configuring Residual Noise Measurements > CALCulate<n>:EVALuation:USER<range>:STARt
CALCulate<n>:EVALuation:USER<range>:STARt <OffsetFrequency>

This command defines the start point of a custom residual noise calculation range.

Before you can use the command, you have to assign the user range to a trace with CALCulate<n>:​EVALuation:​USER<range>:​TRACe.

Parameters:
<OffsetFrequency>

The minimum offset is 1 Hz. The maximum offset depends on the hardware you are using.

*RST: 1 MHz
Example: CALC:EVAL:USER2:STAR 1khz

Defines a start point of 1 kHz for the second user range.

Manual operation: See "User Range"


CALCulate<n>:EVALuation:USER<range>:STOP

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Configuring Residual Noise Measurements > CALCulate<n>:EVALuation:USER<range>:STOP
CALCulate<n>:EVALuation:USER<range>:STOP <OffsetFrequency>

This command defines the end point of a custom residual noise calculation range.

Before you can use the command, you have to assign the user range to a trace with CALCulate<n>:​EVALuation:​USER<range>:​TRACe.

Parameters:
<OffsetFrequency>

The minimum offset is 1 Hz. The maximum offset depends on the hardware you are using.

*RST: 1 MHz
Example: CALC:EVAL:USER2:STOP 100kHz

Defines an end point of 100 kHz for the second user range.

Manual operation: See "User Range"


CALCulate<n>:EVALuation:USER<range>:TRACe

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Configuring Residual Noise Measurements > CALCulate<n>:EVALuation:USER<range>:TRACe
CALCulate<n>:EVALuation:USER<range>:TRACe <Trace>

This command selects the trace for a custom residual noise calculation range.

Suffix: |
<range> | 1...3 Selects the user range.
Parameters:
<Trace> | NONE Turns a user range off. TRACE1 ... TRACE6 Trace to assign the user range to.
Example: | CALC:EVAL:USER2:TRAC TRACE2 Assigns the second user range to trace 2.
Manual operation: | See "User Range"


Reading Out Residual Noise Results

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out Residual Noise Results
Reading Out Residual Noise Results
List of Commands
FETCh:PNOise:IPN?
FETCh:PNOise<t>:RFM?
FETCh:PNOise<t>:RMS?
FETCh:PNOise<t>:RPM?
FETCh:PNOise<t>:USER<range>:IPN?
FETCh:PNOise<t>:USER<range>:RFM?
FETCh:PNOise<t>:USER<range>:RMS?
FETCh:PNOise<t>:USER<range>:RPM?


FETCh:PNOise:IPN?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out Residual Noise Results > FETCh:PNOise:IPN?
FETCh:PNOise:IPN?

This command queries the Integrated Phase Noise for the first trace.

Example: | FETC:PNO2:IPN? Queries the Integrated Phase Noise for the first trace in the diagram.
Usage: | Query only


FETCh:PNOise<t>:RFM?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out Residual Noise Results > FETCh:PNOise<t>:RFM?
FETCh:PNOise<t>:RFM?

This command queries the residual FM for the first trace.

Example: | FETC:PNO2:RFM? Queries the residual FM for the first trace in the diagram.
Usage: | Query only
Manual operation: | See "Residual Noise"


FETCh:PNOise<t>:RMS?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out Residual Noise Results > FETCh:PNOise<t>:RMS?
FETCh:PNOise<t>:RMS?

This command queries the residual RMS jitter for the first trace.

Example: | FETC:PNO2:RMS? Queries the RMS jitter for the first trace in the diagram.
Usage: | Query only
Manual operation: | See "Residual Noise"


FETCh:PNOise<t>:RPM?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out Residual Noise Results > FETCh:PNOise<t>:RPM?
FETCh:PNOise<t>:RPM?

This command queries the residual PM for the first trace.

Example: | FETC:PNO:RPM? Queries the residual PM for the first trace of the diagram.
Usage: | Query only
Manual operation: | See "Residual Noise"


FETCh:PNOise<t>:USER<range>:IPN?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out Residual Noise Results > FETCh:PNOise<t>:USER<range>:IPN?
FETCh:PNOise<t>:USER<range>:IPN?

This command queries the Integrated Phase Noise for a particular user range.

The trace that is queried depends on CALCulate<n>:​EVALuation:​USER<range>:​TRACe.

Suffix: |
<range> | 1...3 Selects the user range.
Example: | FETC:PNO:USER2:IPN? Queries the Integrated Phase Noise for user range 2.
Usage: | Query only


FETCh:PNOise<t>:USER<range>:RFM?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out Residual Noise Results > FETCh:PNOise<t>:USER<range>:RFM?
FETCh:PNOise<t>:USER<range>:RFM?

This command queries the residual FM for a particular user range.

The trace that is queried depends on CALCulate<n>:​EVALuation:​USER<range>:​TRACe.

Suffix: |
<range> | 1...3 Selects the user range.
Example: | FETC:PNO:USER2:RFM? Queries the residual FM for user range 2.
Usage: | Query only
Manual operation: | See "Residual Noise"


FETCh:PNOise<t>:USER<range>:RMS?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out Residual Noise Results > FETCh:PNOise<t>:USER<range>:RMS?
FETCh:PNOise<t>:USER<range>:RMS?

This command queries the residual RMS jitter for a particular user range.

The trace that is queried depends on CALCulate<n>:​EVALuation:​USER<range>:​TRACe.

Suffix: |
<range> | 1...3 Selects the user range.
Example: | FETC:PNO:USER2:RMS? Queries the RMS jitter for user range 2.
Usage: | Query only
Manual operation: | See "Residual Noise"


FETCh:PNOise<t>:USER<range>:RPM?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out Residual Noise Results > FETCh:PNOise<t>:USER<range>:RPM?
FETCh:PNOise<t>:USER<range>:RPM?

This command queries the residual PM for a particular user range.

The trace that is queried depends on CALCulate<n>:​EVALuation:​USER<range>:​TRACe.

Suffix: |
<range> | 1...3 Selects the user range.
Example: | FETC:PNO:USER2:RPM? Queries the residual PM for user range 2.
Usage: | Query only
Manual operation: | See "Residual Noise"


Configuring Spot Noise Measurements

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Configuring Spot Noise Measurements
Configuring Spot Noise Measurements
List of Commands
CALCulate<n>:SNOise:AOFF
CALCulate<n>:SNOise:DECades[:STATe]
CALCulate<n>:SNOise:DECades:X?
CALCulate<n>:SNOise:DECades:Y?
CALCulate<n>:SNOise<m>:STATe
CALCulate<n>:SNOise<m>:X
CALCulate<n>:SNOise<m>:Y?


CALCulate<n>:SNOise:AOFF

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Configuring Spot Noise Measurements > CALCulate<n>:SNOise:AOFF
CALCulate<n>:SNOise:AOFF

This command turns all spot noise markers off (custom and 10x markers).

Example: | CALC:SNO:AOFF Turns all spot noise markers off.
Usage: | Event
Manual operation: | See "On User Defined Offsets / Offset Frequency"


CALCulate<n>:SNOise:DECades[:STATe]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Configuring Spot Noise Measurements > CALCulate<n>:SNOise:DECades[:STATe]
CALCulate<n>:SNOise:DECades[:STATe] <State>

This command turns the spot noise calculation on every 10x offset frequency on and off.

Parameters:
<State>
ON | OFF
*RST: ON
Example: CALC:SNO:DEC ON

Turns the spot noise calculation for each decade start on.

Manual operation: See "On All Decade Edges"


CALCulate<n>:SNOise:DECades:X?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Configuring Spot Noise Measurements > CALCulate<n>:SNOise:DECades:X?
CALCulate<n>:SNOise:DECades:X?

This command queries the horizontal poistion of the 10x offset frequency spot noise markers.

Return values:
<OffsetFrequency>

List of offset frequencies, one for each 10x spot noise marker. The number of return values depends on the measurement range.

Default unit: Hz
Example: CALC:SNO:DEC:X?

Return values, e.g.:

1000,10000,100000,1000000
Usage: Query only
Manual operation: See "Spot Noise"
See "On All Decade Edges"


CALCulate<n>:SNOise:DECades:Y?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Configuring Spot Noise Measurements > CALCulate<n>:SNOise:DECades:Y?
CALCulate<n>:SNOise:DECades:Y?

This command queries the vertical poistion of the 10x offset frequency spot noise markers.

Return values:
<Level>

List of level values, one for each 10x spot noise marker. The number of return values depends on the measurement range.

Default unit: dBc/Hz
Example: CALC:SNO:DEC:Y?

Return values, e.g.:

-152.560974121094,-136.443389892578,-145.932891845703,-152.560974121094
Usage: Query only
Manual operation: See "Spot Noise"
See "On All Decade Edges"


CALCulate<n>:SNOise<m>:STATe

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Configuring Spot Noise Measurements > CALCulate<n>:SNOise<m>:STATe
CALCulate<n>:SNOise<m>:STATe <State>

This command turns a custom spot noise marker on and off.

Suffix:
<m>
1...5

Selects the spot noise marker.

Parameters:
<State>
ON | OFF
*RST: All ON
Example:

CALC:SNO3:STATE ON

Turns spot noise marker 3 on.

Manual operation: See "On User Defined Offsets / Offset Frequency"


CALCulate<n>:SNOise<m>:X

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Configuring Spot Noise Measurements > CALCulate<n>:SNOise<m>:X
CALCulate<n>:SNOise<m>:X <OffsetFrequency>

This command defines the horizontal position of a custom spot noise marker.

Suffix: |
<m> | 1...5 Selects the spot noise marker.
Parameters:
<OffsetFrequency> | The minimum offset is 1 Hz. The maximum offset depends on the hardware you are using. The default value varies for each of the five spot noise markers. For marker 1 it is 1 kHz, for marker 2 it is 10 kHz, for marker 3 it is 100 kHz, for marker 4 it is 1 MHz and for marker 5 it is 10 MHz
Example: | CALC:SNO3:X 2MHz Positions the third custom spot noise marker to an offset frequency of 2 MHz.
Manual operation: | See "On User Defined Offsets / Offset Frequency"


CALCulate<n>:SNOise<m>:Y?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Configuring Spot Noise Measurements > CALCulate<n>:SNOise<m>:Y?
CALCulate<n>:SNOise<m>:Y?

This command queries the vertical position of a custom spot noise marker.

Suffix:
<m>
1...5

Selects the spot noise marker

Return values:
<Level>
<numeric value>

Phase noise level at the marker position.

Default unit: dBc/Hz
Example:

CALC:SNO3:Y?

Queries the level of the third custom spot noise marker.

Usage: Query only
Manual operation: See "Spot Noise"
See "On User Defined Offsets / Offset Frequency"


Reading Out the Spur List

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out the Spur List
Reading Out the Spur List
List of Commands
FETCh:PNOise:SPURs?
FETCh:PNOise:SPURs:DISCrete?
FETCh:PNOise:SPURs:RANDom?


FETCh:PNOise:SPURs?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out the Spur List > FETCh:PNOise:SPURs?
FETCh:PNOise:SPURs?

This command queries the location and level of all spurs that have been detected.

Return values:
<Spurs> | Returns two values (frequency and level) for each each spur that has been detected.
Example: | FETC:PNO:SPUR? would return, e.g. 1999.232666,-0.639974,6494.312500,-0.760579,19992.324219,-0.639974
Usage: | Query only
Manual operation: | See "Spur List"


FETCh:PNOise:SPURs:DISCrete?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out the Spur List > FETCh:PNOise:SPURs:DISCrete?
FETCh:PNOise:SPURs:DISCrete?

This command queries the Discrete Jitter result.

Return values:
<Jitter>
Default unit: s
Example: FETC:PNO:SPUR:DISC?

would return, e.g.

2.3e-08
Usage: Query only
Manual operation: See "Spur List"


FETCh:PNOise:SPURs:RANDom?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out the Spur List > FETCh:PNOise:SPURs:RANDom?
FETCh:PNOise:SPURs:RANDom?

This command queries the Random Jitter result.

Return values:
<Jitter>
Default unit: s
Example: FETC:PNO:SPUR:RAND?

would return, e.g.

3.59e-09
Usage: Query only
Manual operation: See "Spur List"


Reading Out Measured Values

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out Measured Values
Reading Out Measured Values
List of Commands
FETCh:PNOise:MEASured:FREQuency?
FETCh:PNOise:MEASured:LEVel?


FETCh:PNOise:MEASured:FREQuency?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out Measured Values > FETCh:PNOise:MEASured:FREQuency?
FETCh:PNOise:MEASured:FREQuency?

This command queries the carrier frequency that has been actually measured.

The measured frequency is shown in the channel bar.

Return values:
<Frequency> | Frequency in Hz.
Example: | FETC:PNO:MEAS:FREQ? Queries the measured frequency.
Usage: | Query only


FETCh:PNOise:MEASured:LEVel?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out Measured Values > FETCh:PNOise:MEASured:LEVel?
FETCh:PNOise:MEASured:LEVel?

This command queries the level of the DUT that has been actually measured.

The measured level is shown in the channel bar.

Return values:
<Level> | Level in dBm.
Example: | FETC:PNO:MEAS:LEV? Queries the measured level.
Usage: | Query only


Reading Out the Sweep Result List

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out the Sweep Result List
Reading Out the Sweep Result List
List of Commands
FETCh:PNOise:SWEep:AVG?
FETCh:PNOise:SWEep:FDRift?
FETCh:PNOise:SWEep:LDRift?
FETCh:PNOise:SWEep:MDRift?
FETCh:PNOise:SWEep:SRATe?
FETCh:PNOise:SWEep:STARt?
FETCh:PNOise:SWEep:STOP?


FETCh:PNOise:SWEep:AVG?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out the Sweep Result List > FETCh:PNOise:SWEep:AVG?
FETCh:PNOise:SWEep:AVG?

This command queries the number of measurements that have been performed in each half decade.

Return values:
<Measurements> | Number of measurements as displayed in the Sweep Result List. The command returns one value for each half decade as a comma separated list.
Example: | FETC:PNO:SWE:AVG? would return, e.g.: 10,10,10,10,10
Usage: | Query only
Manual operation: | See "Sweep Result List"


FETCh:PNOise:SWEep:FDRift?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out the Sweep Result List > FETCh:PNOise:SWEep:FDRift?
FETCh:PNOise:SWEep:FDRift?

This command queries the frequency drift in each half decade.

Return values:
<Frequency>

Frequency drift as displayed in the Sweep Result List.

The command returns one value for each half decade as a comma separated list.

Default unit: Hz
Example: FETC:PNO:SWE:FDR?

would return, e.g.:

-203.565049124882,-198.254803592339,-179.608235809952,-126.506989398971,-95.0386250484735
Usage: Query only
Manual operation: See "Sweep Result List"


FETCh:PNOise:SWEep:LDRift?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out the Sweep Result List > FETCh:PNOise:SWEep:LDRift?
FETCh:PNOise:SWEep:LDRift?

This command queries the level drift in each half decade.

Return values:
<Level>

Level drift as displayed in the Sweep Result List.

The command returns one value for each half decade as a comma separated list.

Default unit: dB
Example: FETC:PNO:SWE:LDR?

would return, e.g.:

0.84823463324,6.55278904401,1.02393361087,2.10021296216,5.28119567376
Usage: Query only
Manual operation: See "Sweep Result List"


FETCh:PNOise:SWEep:MDRift?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out the Sweep Result List > FETCh:PNOise:SWEep:MDRift?
FETCh:PNOise:SWEep:MDRift?

This command queries the maximum frequency drift in each half decade.

Return values:
<Frequency>

Frequency drift as displayed in the Sweep Result List.

The command returns one value for each half decade as a comma separated list.

Default unit: Hz
Example: FETC:PNO:SWE:MDR?

would return, e.g.:

2.17,11.45,105.11,219.37,553.48
Usage: Query only
Manual operation: See "Sweep Result List"


FETCh:PNOise:SWEep:SRATe?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out the Sweep Result List > FETCh:PNOise:SWEep:SRATe?
FETCh:PNOise:SWEep:SRATe?

This command queries the sampling rate used in each half decade.

Return values:
<SamplingRate>

Sampling rate as displayed in the Sweep Result List.

The command returns one value for each half decade as a comma separated list.

Default unit: Hz
Example: FETC:PNO:SWE:SRAT?

would return, e.g.:

25000,75000,250000,750000,2500000
Usage: Query only
Manual operation: See "Sweep Result List"


FETCh:PNOise:SWEep:STARt?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out the Sweep Result List > FETCh:PNOise:SWEep:STARt?
FETCh:PNOise:SWEep:STARt?

This command queries the start frequency offset of each half decade.

Return values:
<Frequency>

Frequency offset as displayed in the Sweep Result List.

The command returns one value for each half decade as a comma separated list.

Default unit: Hz
Example: FETC:PNO:SWE:STAR?

would return, e.g.:

1000,3000,10000,30000,100000
Usage: Query only
Manual operation: See "Sweep Result List"


FETCh:PNOise:SWEep:STOP?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configure Numerical Result Displays > Reading Out the Sweep Result List > FETCh:PNOise:SWEep:STOP?
FETCh:PNOise:SWEep:STOP?

This command queries the stop frequency offset of each half decade.

Return values:
<Measurements>

Frequency offset as displayed in the Sweep Result List.

The command returns one value for each half decade as a comma separated list.

Default unit: Hz
Example: FETC:PNO:SWE:STOP?

would return, e.g.:

3000,10000,30000,100000,300000
Usage: Query only
Manual operation: See "Sweep Result List"


Using Markers

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers
Using Markers

The following commands are necessary to control markers.

Contents
  • Using Markers
  • Using Delta Markers
  • Using the Marker Zoom


Using Markers

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using Markers
Using Markers
List of Commands
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?


CALCulate<n>:MARKer<m>:AOFF

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using Markers > CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:AOFF

This command turns all markers off.

Example: | CALC:MARK:AOFF Switches off all markers.
Usage: | Event
Manual operation: | See "All Markers Off"


CALCulate<n>:MARKer<m>[:STATe]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using Markers > CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>[:STATe] <State>

This command turns markers on and off. If the corresponding marker number is currently active as a deltamarker, it is turned into a normal marker.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3 ON

Switches on marker 3.

Manual operation: See "Marker 1 ... Marker x"
See "Marker Type"


CALCulate<n>:MARKer<m>:TRACe

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using Markers > CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:TRACe <Trace>

This command selects the trace the marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | 1 to 6 Trace number the marker is assigned to.
Example: | CALC:MARK3:TRAC 2 Assigns marker 3 to trace 2.
Manual operation: | See "Assigning the Marker to a Trace"


CALCulate<n>:MARKer<m>:X

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using Markers > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

Default unit: Hz
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.


CALCulate<n>:MARKer<m>:Y?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using Markers > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y?

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Level>

Phase noise level of the marker.

Default unit: dBc/Hz
Example: INIT:CONT OFF

Switches to single measurement mode.

CALC:MARK2 ON

Switches marker 2.

INIT;*WAI

Starts a measurement and waits for the end.

CALC:MARK2:Y?

Outputs the measured value of marker 2.

Usage: Query only


Using Delta Markers

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using Delta Markers
Using Delta Markers
List of Commands
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:Y?


CALCulate<n>:DELTamarker:AOFF

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using Delta Markers > CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:AOFF

This command turns all delta markers off.

Example: | CALC:DELT:AOFF Turns all delta markers off.
Usage: | Event


CALCulate<n>:DELTamarker<m>:MREF

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using Delta Markers > CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:MREF <Reference>

This command selects a reference marker for a delta marker other than marker 1.

The reference may be another marker or the fixed reference.

Parameters:
<Reference> | 1 to 16 Selects markers 1 to 16 as the reference. FIXed Selects the fixed reference as the reference.
Example: | CALC:DELT3:MREF 2 Specifies that the values of delta marker 3 are relative to marker 2.
Manual operation: | See "Reference Marker"


CALCulate<n>:DELTamarker<m>[:STATe]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using Delta Markers > CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>[:STATe] <State>

This command turns delta markers on and off.

If necessary, the command activates the delta marker first.

No suffix at DELTamarker turns on delta marker 1.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2 ON

Turns on delta marker 2.

Manual operation: See "Marker 1 ... Marker x"
See "Marker Type"


CALCulate<n>:DELTamarker<m>:TRACe

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using Delta Markers > CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:TRACe <Trace>

This command selects the trace a delta marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | Trace number the marker is assigned to.
Example: | CALC:DELT2:TRAC 2 Positions delta marker 2 on trace 2.


CALCulate<n>:DELTamarker<m>:X

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using Delta Markers > CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X <Position>

This command moves a delta marker to a particular coordinate on the x-axis.

If necessary, the command activates the delta marker and positions a reference marker to the peak power.

Parameters:
<Position>

The position is relative to the reference marker.

The unit is Hz (offset frequency).

A query returns the absolute position of the delta marker.

Range: The value range depends on the current measurement range.
Example: CALC:DELT:X?

Outputs the absolute frequency/time of delta marker 1.


CALCulate<n>:DELTamarker<m>:Y?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using Delta Markers > CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>:Y?

This command queries the relative position of a delta marker on the y-axis.

If necessary, the command activates the delta marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Level>

Phase noise level.

Default unit: dBc/Hz
Example: INIT:CONT OFF

Switches to single sweep mode.

INIT;*WAI

Starts a sweep and waits for its end.

CALC:DELT2 ON

Switches on delta marker 2.

CALC:DELT2:Y?

Outputs measurement value of delta marker 2.

Usage: Query only


Using the Marker Zoom

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using the Marker Zoom
Using the Marker Zoom
List of Commands
CALCulate:MARKer:FUNCtion:ZOOM
DISPlay[:WINDow:]ZOOM[:STATe]


CALCulate:MARKer:FUNCtion:ZOOM

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using the Marker Zoom > CALCulate:MARKer:FUNCtion:ZOOM
CALCulate:MARKer:FUNCtion:ZOOM <ZoomFactor>

This command defines the factor or magnitude of the marker zoom.

Parameters:
<ZoomFactor>
Range: | 1 to 20
*RST: | Zoom OFF
Example: CALC:MARK:FUNC:ZOOM 12

Zooms into the diagram with a factor of 10 around marker 1.

Manual operation: See "Marker Zoom"


DISPlay[:WINDow:]ZOOM[:STATe]

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using Markers > Using the Marker Zoom > DISPlay[:WINDow:]ZOOM[:STATe]
DISPlay[:WINDow:]ZOOM[:STATe] <State>

This command turns the marker zoom for marker 1 on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:ZOOM ON

Turns on the marker zoom.

Manual operation: See "Marker Zoom"


Configuring In- and Outputs

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring In- and Outputs
Configuring In- and Outputs

The following commands are necessary to configure the frontend settings.

List of Commands
INPut:CONNector


INPut:CONNector

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Configuring In- and Outputs > INPut:CONNector
INPut:CONNector <ConnType>

Determines whether the RF input data is taken from the RF input connector or the optional Analog Baseband I connector. This command is only available if the Analog Baseband interface (R&S FSW-B71) is installed and active for input.

For more information see "Processing Data From the Analog Baseband Interface" .

Parameters:
<ConnType>
RF

RF input connector

AIQI

Analog Baseband I connector

*RST: RF
Example: INP:CONN:AIQI

Selects the analog baseband input.

Usage: SCPI confirmed
Manual operation: See "Input Connector"


Automatic Measurement Configuration

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Automatic Measurement Configuration
Automatic Measurement Configuration

The following commands are necessary to determine measurement parameters automatically.

List of Commands
[SENSe:]ADJust:ALL
[SENSe:]ADJust:FREQuency
[SENSe:]ADJust:LEVel


[SENSe:]ADJust:ALL

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Automatic Measurement Configuration > [SENSe:]ADJust:ALL
[SENSe:]ADJust:ALL

This command initiates a measurement to determine and set the ideal settings for the current task automatically (only once for the current measurement).

This includes:

  • Center frequency
  • Reference level
Example: | ADJ:ALL
Usage: | Event
Manual operation: | See "Adjusting all Determinable Settings Automatically (Auto All)"


[SENSe:]ADJust:FREQuency

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Automatic Measurement Configuration > [SENSe:]ADJust:FREQuency
[SENSe:]ADJust:FREQuency

This command sets the center frequency to the highest signal level in the current frequency range.

Example: | ADJ:FREQ
Usage: | Event
Manual operation: | See "Adjusting the Center Frequency Automatically (Auto Freq)"


[SENSe:]ADJust:LEVel

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Automatic Measurement Configuration > [SENSe:]ADJust:LEVel
[SENSe:]ADJust:LEVel

This command initiates a single (internal) measurement that evaluates and sets the ideal reference level for the current input data and measurement settings. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Example: | ADJ:LEV
Usage: | Event
Manual operation: | See "Setting the Reference Level Automatically (Auto Level)"


Using the Status Register

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using the Status Register
Using the Status Register

The status reporting system stores information about the current state of the R&S FSW. This includes, for example, information about errors during operation or information about limit checks. The R&S FSW stores this information in the status registers and in the error queue. You can query the status register and error queue via IEC bus.

The R&S FSW-K40 features several status registers that are specific to phase noise measurements. Here is a description of those, including the corresponding remote commands.

Contents
  • Status Registers for Phase Noise Measurements


Status Registers for Phase Noise Measurements

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using the Status Register > Status Registers for Phase Noise Measurements
Status Registers for Phase Noise Measurements

The figure below shows the status registers of the phase noise application.

Status registers for phase noise measurements

The R&S FSW structures the information hierarchically, with the Status Byte register (STB) and the Service Request Enable mask register (SRE) being on the highest level. The STB gets its information from the standard Event Status Register (ESR) and the Event Status Enable mask register (ESE). The STB and ESR are both defined by IEEE 488.2. In addition to the ESR, the STB also gets information from the STATus:OPERation and STATus:QUEStionable registers. These are the link to the lower levels of the status register and are defined by SCPI. They contain information about the state of the instrument.

For a more comprehensive description of the status registers not mentioned here and status register functionality in general see the manual of the base unit.

Contents
  • STATus:QUEStionable Register
  • STATus:QUEStionable:POWer Register
  • STATus:QUEStionable:LIMit Register
  • STATus:QUEStionable:PNOise Register
  • Status Register Remote Commands


STATus:QUEStionable Register

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using the Status Register > Status Registers for Phase Noise Measurements > STATus:QUEStionable Register
STATus:QUEStionable Register

The STATus:QUEStionable register contains information about indefinite states which may occur if the unit is operated without meeting the specifications.

Bit no | Meaning
0 to 2 | Unavailable for phase noise measurements.
3 | POWer This bit is set if a questionable power occurs.
5 to 7 | Unavailable for phase noise measurements.
8 | CALibration This bit is set if the R&S FSW is not calibrated.
9 | LIMit This bit is set if a limit line is violated.
10-12 | Unavailable for phase noise measurements.
13 | PNOise This bit is set if the phase noise measurement is questionable.
14 | Unavailable for phase noise measurements.
15 | This bit is always 0.


STATus:QUEStionable:POWer Register

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using the Status Register > Status Registers for Phase Noise Measurements > STATus:QUEStionable:POWer Register
STATus:QUEStionable:POWer Register

The STATus:QUEStionable:POWer register contains information about possible overload situations that may occur during operation of the R&S FSW.

Bit no | Meaning
0 | OVERload This bit is set if an overload occurs at the RF input.
1 | UNDerload This bit is set if an underload occurs at the RF input.
2 | IF OVerload This bit is set if an overload occurs in the IF path.
3 to 14 | Unavailable for phase noise measurements.
15 | This bit is always 0.


STATus:QUEStionable:LIMit Register

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using the Status Register > Status Registers for Phase Noise Measurements > STATus:QUEStionable:LIMit Register
STATus:QUEStionable:LIMit Register

The STATus:QUEStionable:LIMit register contains information about limit lines and the results of a limit checks.

The number of LIMit registers depends on the number of measurement windows available in any application.

Bit no | Meaning
0 | LIMit 1 FAIL This bit is set if limit line 1 is violated.
1 | LIMit 2 FAIL This bit is set if limit line 2 is violated.
2 | LIMit 3 FAIL This bit is set if limit line 3 is violated.
3 | LIMit 4 FAIL This bit is set if limit line 4 is violated.
4 | LIMit 5 FAIL This bit is set if limit line 5 is violated.
5 | LIMit 6 FAIL This bit is set if limit line 6 is violated.
6 | LIMit 7 FAIL This bit is set if limit line 7 is violated.
7 | LIMit 8 FAIL This bit is set if limit line 8 is violated.
8 | Phase Noise LIMit FAIL This bit is set if a limit of the phase noise limit line is violated.
9 to 14 | Unavailable for phase noise measurements.
15 | This bit is always 0.


STATus:QUEStionable:PNOise Register

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using the Status Register > Status Registers for Phase Noise Measurements > STATus:QUEStionable:PNOise Register
STATus:QUEStionable:PNOise Register

The STATus:QUEStionable:PNOise register contains information about the status of phase noise measurements.

Bit no | Meaning
0 | No trace are active This bit is set if no trace is on.
1 | SIGNal not found This bit is set if no valid signal could be found.
2 | VERify This bit is set if signal verification has failed.
3 to 14 | Unavailable for phase noise measurements.
15 | This bit is always 0.


Status Register Remote Commands

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using the Status Register > Status Registers for Phase Noise Measurements > Status Register Remote Commands
Status Register Remote Commands
List of Commands
STATus:OPERation[:EVENt]?
STATus:QUEStionable[:EVENt]?
STATus:QUEStionable:LIMit[:EVENt]?
STATus:QUEStionable:PNOise[:EVENt]?
STATus:QUEStionable:POWer[:EVENt]?
STATus:OPERation:CONDition?
STATus:QUEStionable:CONDition?
STATus:QUEStionable:LIMit:CONDition?
STATus:QUEStionable:PNOise:CONDition?
STATus:QUEStionable:POWer:CONDition?
STATus:OPERation:ENABle
STATus:QUEStionable:ENABle
STATus:QUEStionable:LIMit:ENABle
STATus:QUEStionable:PNOise:ENABle
STATus:QUEStionable:POWer:ENABle
STATus:OPERation:NTRansition
STATus:QUEStionable:NTRansition
STATus:QUEStionable:LIMit:NTRansition
STATus:QUEStionable:PNOise:NTRansition
STATus:QUEStionable:POWer:NTRansition
STATus:OPERation:PTRansition
STATus:QUEStionable:PTRansition
STATus:QUEStionable:LIMit:PTRansition
STATus:QUEStionable:PNOise:PTRansition
STATus:QUEStionable:POWer:PTRansition


STATus:OPERation[:EVENt]?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using the Status Register > Status Registers for Phase Noise Measurements > Status Register Remote Commands > STATus:OPERation[:EVENt]?
STATus:OPERation[:EVENt]?
STATus:QUEStionable[:EVENt]?
STATus:QUEStionable:LIMit[:EVENt]? <ChannelName>
STATus:QUEStionable:PNOise[:EVENt]? <ChannelName>
STATus:QUEStionable:POWer[:EVENt]? <ChannelName>

These commands read out the EVENt section of the status register.

The commands at the same time delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:OPERation:CONDition?

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using the Status Register > Status Registers for Phase Noise Measurements > Status Register Remote Commands > STATus:OPERation:CONDition?
STATus:OPERation:CONDition?
STATus:QUEStionable:CONDition?
STATus:QUEStionable:LIMit:CONDition? <ChannelName>
STATus:QUEStionable:PNOise:CONDition? <ChannelName>
STATus:QUEStionable:POWer:CONDition? <ChannelName>

These commands read out the CONDition section of the status register.

The commands do not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:OPERation:ENABle

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using the Status Register > Status Registers for Phase Noise Measurements > Status Register Remote Commands > STATus:OPERation:ENABle
STATus:OPERation:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:LIMit:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:PNOise:ENABle <SumBit>,<ChannelName>
STATus:QUEStionable:POWer:ENABle <SumBit>,<ChannelName>

These commands control the ENABle part of a register.

The ENABle part allows true conditions in the EVENt part of the status register to bereported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<SumBit>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


STATus:OPERation:NTRansition

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using the Status Register > Status Registers for Phase Noise Measurements > Status Register Remote Commands > STATus:OPERation:NTRansition
STATus:OPERation:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:LIMit:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:PNOise:NTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:POWer:NTRansition <SumBit>,<ChannelName>

These commands control the Negative TRansition part of a register.

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<SumBit>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


STATus:OPERation:PTRansition

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Using the Status Register > Status Registers for Phase Noise Measurements > Status Register Remote Commands > STATus:OPERation:PTRansition
STATus:OPERation:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:LIMit:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:PNOise:PTRansition <SumBit>,<ChannelName>
STATus:QUEStionable:POWer:PTRansition <SumBit>,<ChannelName>

These commands control the Positive TRansition part of a register.

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<SumBit>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


Remote Control Example Scripts

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Remote Control Example Scripts
Remote Control Example Scripts

This chapter contains a few remote control example scripts for particular phase noise measurement and configuration tasks.

The first chapter contains a short sequence of commands to perform a complete phase noise measurement. The subsequent chapters contain sequences of remote commands to perform special tasks for phase noise measurements like customizing the half decade configuration table.

All examples are based on a measurement range from 100 Hz to 1 MHz.

Contents
  • Performing a Basic Phase Noise Measurement
  • Configuring the Measurement Range
  • Scaling the Display
  • Configuring Numerical Results
  • Using Limit Lines
  • Using Markers


Performing a Basic Phase Noise Measurement

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Remote Control Example Scripts > Performing a Basic Phase Noise Measurement
Performing a Basic Phase Noise Measurement
//Enter Phase Noise application
INST:SEL PNO
//Perform a preset of the channel
SYST:PRES:CHAN
//Customizing the screen layout.
//Add residual noise window:
LAY:ADD? '1',BEL,RNO
//Add spot noise window:
LAY:ADD? '2',RIGH,SNO
//Configure single sweep measurement.
INIT:CONT OFF
//Define the measurement range.
FREQ:STAR 100HZ
FREQ:STOP 1MHZ
//Select the sweep type.
SWE:MODE AVER
//Turn on frequency tracking.
FREQ:TRAC ON
//Turn on level tracking.
POW:TRAC ON
//Start the measurement with synchronization.
INIT;*WAI
//Set a marker on trace 1 and query its position.
CALC:MARK ON
CALC:MARK:X 1MHZ
CALC:MARK:Y?
//Query the residual noise results of trace 2 over the measurement range.
CALC:EVAL ON
//Residual FM:
FETC:PNO2:RFM?
//Residual PM:
FETC:PNO2:RPM?
//Residual RMS jitter:
FETC:PNO2:RMS?
//Freeze trace 1 and trace 2.
DISP:TRAC:MODE VIEW
DISP:TRAC2:MODE VIEW
//Activate trace 3 and trace 4.
DISP:TRAC3:MODE WRIT
DISP:TRAC4:MODE WRIT
//Activate linear trace smoothing for trace 4.
DISP:TRAC4:SMO ON
DISP:TRAC4:SMO:TYPE LIN
DISP:TRAC:SMO:APER 1
//Select IQ sweep mode.
SWE:MODE MAN
LIST:BWID:RES:TYPE IQFF
//Repeat the measurement.
INIT;*WAI


Configuring the Measurement Range

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Remote Control Example Scripts > Configuring the Measurement Range
Configuring the Measurement Range
Performing a customized IQ FFT measurement over the whole measurement range
//Define the measurement range.
FREQ:STAR 100HZ
FREQ:STOP 1MHZ
//Define the measurement settings for all half decades in the measurement range.
SWE:MODE MAN
//Measurement bandwidth (in per cent of the decade frequency):
LIST:BWID:RAT 20
//Averages:
LIST:SWE:COUN 20
//Mode:
LIST:BWID:RES:TYPE IQFF
//Window function:
LIST:IQW:TYPE GAUS
Customizing a half decade configuration table
//Define the measurement range.
FREQ:STAR 100HZ
FREQ:STOP 1MHZ
//Define the contents of the table manually.
SWE:MODE MAN
//Customize the range from 100 Hz to 300 Hz.
//Measurement bandwidth:
LIST:RANG5:BWID 1HZ
//Sweep type:
LIST:RANG5:FILT:TYPE IQFF
//Window function:
LIST:RANG5:IQW:TYPE CHEB
//Averages:
LIST:RANG5:SWE:COUN 5
//Customize the range from 300 Hz to 1 kHz.
//Averages:
LIST:RANG6:SWE:COUN 5


Scaling the Display

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Remote Control Example Scripts > Scaling the Display
Scaling the Display
Scaling the x-axis: displaying a half decade
//Select display of one half decade.
DISP:TRAC:X:SCOP HDEC
//Select the start frequency of the half decade.
DISP:TRAC:X:HDEC 1KHZ
//Display the full measurement range again.
DISP:TRAC:X:SCOP MRAN
Scaling the x-axis: customizing the x-axis range
//Select manual x-axis scaling.
DISP:TRAC:X:SCOP MAN
//Define the start frequency of the display range.
DISP:TRAC:X:STAR 30KHZ
//Define the stop frequency of the display range.
DISP:TRAC:X:STOP 300KHZ
Scaling the y-axis: scaling based on bottom value and range
//Select manual y-axis scaling.
DISP:TRAC:Y:MAN BRAN
//Define the bottom value.
DISP:TRAC:Y:RLEV:LOW -160
//Define the range.
DISP:TRAC:Y 60
Scaling the y-axis: scaling based on top value and range
//Select manual y-axis scaling.
DISP:TRAC:Y:MAN TRAN
//Define the top value.
DISP:TRAC:Y:RLEV -100
//Define the range.
DISP:TRAC:Y 60
Scaling the y-axis: scaling based on bottom and top value
//Select manual y-axis scaling.
DISP:TRAC:Y:MAN TBOT
//Define the bottom value.
DISP:TRAC:Y:RLEV:LOW -160
//Define the top value.
DISP:TRAC:Y:RLEV -100


Configuring Numerical Results

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Remote Control Example Scripts > Configuring Numerical Results
Configuring Numerical Results
Defining a user range for residual noise results and query the results
//Select the trace for integration.
CALC:EVAL:USER2:TRAC TRACE1
//Define the start and stop frequencies of the integration range.
CALC:EVAL:USER2:STAR 100KHZ
CALC:EVAL:USER2:STOP 1MHZ
//Query the results.
//Residual FM:
FETC:PNO:USER2:RFM?
//Residual PM:
FETC:PNO:USER2:RPM?
//Residual RMS jitter:
FETC:PNO:USER2:RMS?
Working with spot noise results
//Turn on spot noise markers on every decade edge.
CALC:SNO:DEC ON
//Turn on spot noise markers at two additional offset frequencies.
CALC:SNO1:STAT ON
CALC:SNO1:X 50KHZ
CALC:SNO2:STAT ON
CALC:SNO2:X 500KHZ
//Read out spot noise marker results.
//Read out the decade edges:
CALC:SNO:DEC:X?
//Read out the marker positions on the decade edges:
CALC:SNO:DEC:Y?
//Read out customized spot noise marker results:
//At 50 kHz:
CALC:SNO1:Y?
//At 500 kHz:
CALC:SNO2:Y?


Using Limit Lines

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Remote Control Example Scripts > Using Limit Lines
Using Limit Lines
Programming a phase noise limit line with three segments
//Define the level of the DUT's noise floor.
CALC:PNL:NOIS -134
//Select the number of line segments.
CALC:PNL:TYPE FC3
//Define the characteristics of the line segments.
CALC:PNL:FC1 300KHZ
CALC:PNL:SLOP1 10
CALC:PNL:FC2 30KHZ
CALC:PNL:SLOP2 20
CALC:PNL:FC3 3KHZ
CALC:PNL:SLOP3 30
//Assign the limit line to trace 1 and 2.
CALC:PNL:TRAC 1,2
//Query limit check results.
CALC:PNL:FAIL?
Programming a standard limit line
//Select or create the limit line by name.
CALC:LIM:NAME 'Phase Noise'
//Comment on the limit line.
CALC:LIM:COMM 'Limit line to test phase noise measurement'
//Define the horizontal data points of the limit line.
CALC:LIM:CONT 100HZ,1kHZ
//Define the vertical data points of an (upper) limit line.
//The unit is fix for phase noise measurements.
CALC:LIM:UPP -160,-170
//Shift the limit line 5 dBc/Hz down.
CALC:LIM:UPP:SHIF -5
//Turn the limit line on.
CALC:LIM:UPP:STAT ON
//Select the trace to check.
CALC:LIM:TRAC 3
//Turn on the limit check.
CALC:LIM:STAT ON
//Query the limit check results.
CALC:LIM:FAIL?


Using Markers

Phase Noise (R&S FSW-K40) > Remote Control Commands for Phase Noise Measurements > Remote Control Example Scripts > Using Markers
Using Markers
Using spot noise markers

See "Working with spot noise results".

Using normal and delta markers
//Activate and position a normal marker (marker 1).
CALC:MARK ON
CALC:MARK:X 1MHZ
//Position marker 1 on trace 2.
CALC:MARK:TRAC 2
//Query the position of marker 1.
CALC:MARK:Y?
//Activate and position a delta marker (delta marker 1).
CALC:DELT ON
CALC:DELT:X -900KHZ
//Position the delta marker on trace 2.
CALC:DELT:TRAC 2
//Query the position of the delta marker.
CALC:DELT:Y?
//Turning all markers off
CALC:MARK:AOFF
CALC:DELT:AOFF


List of Remote Commands (Phase Noise)

Phase Noise (R&S FSW-K40) > List of Remote Commands (Phase Noise)
List of Remote Commands (Phase Noise)
[SENSe:]ADJust:ALL
[SENSe:]ADJust:FREQuency
[SENSe:]ADJust:LEVel
[SENSe:]BANDwidth|BWIDth[:RESolution]:TYPE
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:STARt
[SENSe:]FREQuency:STOP
[SENSe:]FREQuency:TRACk
[SENSe:]FREQuency:VERify:TOLerance:ABSolute
[SENSe:]FREQuency:VERify:TOLerance:RELative
[SENSe:]FREQuency:VERify[:STATe]
[SENSe:]IQ:DECimation
[SENSe:]IQ:DPLL
[SENSe:]IQ:TBW
[SENSe:]LIST:BWIDth:RESolution:TYPE
[SENSe:]LIST:BWIDth[:RESolution]:RATio
[SENSe:]LIST:RANGe<range>:BWIDth[:RESolution]
[SENSe:]LIST:RANGe<range>:FILTer:TYPE
[SENSe:]LIST:RANGe<range>:IQWindow:TYPE
[SENSe:]LIST:RANGe<range>:SWEep:COUNt
[SENSe:]LIST:SWEep:COUNt
[SENSe:]LIST:SWEep:COUNt:MULTiplier
[SENSe:]LIST:SWEep:COUNt:MULTiplier:STATe
[SENSe:]POWer:RLEVel
[SENSe:]POWer:RLEVel:VERify:TOLerance
[SENSe:]POWer:RLEVel:VERify[:STATe]
[SENSe:]POWer:TRACk
[SENSe:]REJect:AM
[SENSe:]SPURs:SUPPression
[SENSe:]SPURs:THReshold
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:FHDecade
[SENSe:]SWEep:FORWard
[SENSe:]SWEep:MODE
[SENSe:]SWEep:SVFailed
[SENSe]:LIST:IQWindow:TYPE
ABORt
CALCulate:LIMit:ACTive?
CALCulate:LIMit:CLEar[:IMMediate]
CALCulate:LIMit:COMMent
CALCulate:LIMit<k>:CONTrol:SHIFt
CALCulate:LIMit<k>:CONTrol[:DATA]
CALCulate:LIMit<k>:COPY
CALCulate:LIMit<k>:DELete
CALCulate:LIMit<k>:FAIL?
CALCulate:LIMit<k>:LOWer:MODE
CALCulate:LIMit<k>:LOWer:SHIFt
CALCulate:LIMit<k>:LOWer:STATe
CALCulate:LIMit<k>:LOWer[:DATA]
CALCulate:LIMit<k>:NAME
CALCulate:LIMit<k>:STATe
CALCulate:LIMit<k>:TRACe
CALCulate:LIMit<k>:TRACe<t>:CHECk
CALCulate:LIMit<k>:UPPer:MODE
CALCulate:LIMit<k>:UPPer:SHIFt
CALCulate:LIMit<k>:UPPer:STATe
CALCulate:LIMit<k>:UPPer[:DATA]
CALCulate:MARKer:FUNCtion:ZOOM
CALCulate:PNLimit:COPY<k>
CALCulate:PNLimit:FAIL?
CALCulate:PNLimit:FC1 <Frequency>
CALCulate:PNLimit:FC2 <Frequency>
CALCulate:PNLimit:FC3 <Frequency>
CALCulate:PNLimit:FC4 <Frequency>
CALCulate:PNLimit:FC5
CALCulate:PNLimit:NOISe
CALCulate:PNLimit:SLOPe<segment>
CALCulate:PNLimit:TRACe
CALCulate:PNLimit:TYPE
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:EVALuation:STARt
CALCulate<n>:EVALuation:STOP
CALCulate<n>:EVALuation:USER<range>:STARt
CALCulate<n>:EVALuation:USER<range>:STOP
CALCulate<n>:EVALuation:USER<range>:TRACe
CALCulate<n>:EVALuation[:STATe]
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MATH:STATe
CALCulate<n>:MATH[:EXPression][:DEFine]
CALCulate<n>:SNOise:AOFF
CALCulate<n>:SNOise:DECades:X?
CALCulate<n>:SNOise:DECades:Y?
CALCulate<n>:SNOise:DECades[:STATe]
CALCulate<n>:SNOise<m>:STATe
CALCulate<n>:SNOise<m>:X
CALCulate<n>:SNOise<m>:Y?
CONFigure:REFMeas ONCE
DISPlay:MTABle
DISPlay[:WINDow:]ZOOM[:STATe]
DISPlay[:WINDow]:TRACe:X[:SCALe]:HDECade
DISPlay[:WINDow]:TRACe:X[:SCALe]:SCOPe
DISPlay[:WINDow]:TRACe:X[:SCALe]:STARt
DISPlay[:WINDow]:TRACe:X[:SCALe]:STOP
DISPlay[:WINDow]:TRACe:Y:[:SCALe]
DISPlay[:WINDow]:TRACe:Y[:SCALe]:AUTO
DISPlay[:WINDow]:TRACe:Y[:SCALe]:MANual
DISPlay[:WINDow]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow]:TRACe:Y[:SCALe]:RLEVel:LOWer
DISPlay[:WINDow]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow]:TRACe<t>:MODE
DISPlay[:WINDow]:TRACe<t>:SMOothing:APERture
DISPlay[:WINDow]:TRACe<t>:SMOothing:TYPE
DISPlay[:WINDow]:TRACe<t>:SMOothing[:STATe]
DISPlay[:WINDow]:TRACe<t>:SPURs:SUPPress
DISPlay[:WINDow<n>]:SELect
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:STATe
FETCh:PNOise:IPN?
FETCh:PNOise:MEASured:FREQuency?
FETCh:PNOise:MEASured:LEVel?
FETCh:PNOise:SPURs:DISCrete?
FETCh:PNOise:SPURs:RANDom?
FETCh:PNOise:SPURs?
FETCh:PNOise:SWEep:AVG?
FETCh:PNOise:SWEep:FDRift?
FETCh:PNOise:SWEep:LDRift?
FETCh:PNOise:SWEep:MDRift?
FETCh:PNOise:SWEep:SRATe?
FETCh:PNOise:SWEep:STARt?
FETCh:PNOise:SWEep:STOP?
FETCh:PNOise<t>:RFM?
FETCh:PNOise<t>:RMS?
FETCh:PNOise<t>:RPM?
FETCh:PNOise<t>:USER<range>:IPN?
FETCh:PNOise<t>:USER<range>:RFM?
FETCh:PNOise<t>:USER<range>:RMS?
FETCh:PNOise<t>:USER<range>:RPM?
FORMat:DEXPort:DSEParator
FORMat:DEXPort:HEADer
FORMat:DEXPort:TRACes
INITiate:CONMeas
INITiate:CONTinuous
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:CONNector
INPut:COUPling
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
MMEMory:STORe<n>:TRACe
STATus:OPERation:CONDition?
STATus:OPERation:ENABle
STATus:OPERation:NTRansition
STATus:OPERation:PTRansition
STATus:OPERation[:EVENt]?
STATus:QUEStionable:CONDition?
STATus:QUEStionable:ENABle
STATus:QUEStionable:LIMit:CONDition?
STATus:QUEStionable:LIMit:ENABle
STATus:QUEStionable:LIMit:NTRansition
STATus:QUEStionable:LIMit:PTRansition
STATus:QUEStionable:LIMit[:EVENt]?
STATus:QUEStionable:NTRansition
STATus:QUEStionable:PNOise:CONDition?
STATus:QUEStionable:PNOise:ENABle
STATus:QUEStionable:PNOise:NTRansition
STATus:QUEStionable:PNOise:PTRansition
STATus:QUEStionable:PNOise[:EVENt]?
STATus:QUEStionable:POWer:CONDition?
STATus:QUEStionable:POWer:ENABle
STATus:QUEStionable:POWer:NTRansition
STATus:QUEStionable:POWer:PTRansition
STATus:QUEStionable:POWer[:EVENt]?
STATus:QUEStionable:PTRansition
STATus:QUEStionable[:EVENt]?
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:SEQuencer
TRACe[:DATA]?
TRACe<n>:COPY


Legal Notice

R&S®FSW-K40
Phase Noise Measurements

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.